Playback/Recording WITHOUT audible input monitoring fails miserably

I installed Audacity 3.4.2 a couple of weeks ago on an up-to-date Windows 11 machine. Everything has worked brilliantly until this morning when I have run into a “feature” that seems insurmountable. If I disable audible input monitoring, then neither playback nor recording work anymore. This happens using either of these two paths to disable the feature (both of which seem to do the same thing):

Transport->Transport Options->Enable audible input monitoring
(or)
Edit->Preferences->Recording->Audible input monitoring

When I disable that feature and try to record, “dropouts” are detected, there’s a lot of buzzing and hissing, and newly attempted recordings are empty. If I turn that feature back on, everything behaves as expected, but I have unwanted echoing from the microphone in my headphones or speakers.

I seem to have the same problem this person posted about a few years ago but then never responded again:

I am using a blue USB microphone and an old set of headphones (or speakers) plugged into the audio output jack. I have tried:

  • Changing every possible intput/output/mix configuration in Windows.
  • Changing USB ports for the mic.
  • Checking for updates (none available).
  • Rebooting.
  • Reinstalling Audacity (removing via control panel, removing the left-over files, then re-installing from this site).
  • Cussing and crying just a little bit.
  • Searching this forum (and google).
  • Taking a long walk, cussing and crying just a little bit in the great outdoors just for a change of venue.

Nothing seems to help. I just want to turn audible input monitoring back off and record my garbage in peace.

EDIT: I have also noted that even after uninstalling and removing the path (Program Files->Audicity) and re-installing, my old settings are still in place. One thing I had changed was to set Audio Settings->Latency compensation to -150 milliseconds and that change remains even after reinstalls. Is there some other place I should be looking to remove conf files?

Any thoughts?

Mike

I decided to go through every possible setting, change them, and see what happened. As it turns out, the very first setting seems to have resolved the symptom:

Audio Settings->Host was set to MME. I changed this to “Windows DirectSound” with identical results. However, when I change this to “Windows WASAPI” the problem goes away and I can record and playback again without input monitoring enabled.

This isn’t something I had fiddled with it before, so I am having trouble explaining the cause and resolution, but hopefully this will help someone else.

As a side note, changing this setting also reduced the monitoring delay from 150ms to 5ms.

Marking this as solved.