Playback pauses on Mac (driving me crazy!) Help!

Can someone help me? Audacity pauses (for seconds or milliseconds) upon playback when I’m mixing tracks and I can’t seem to fix that. It’s almost rendering it unusable.
Audacity version: I’ve tried but that’s even worse for pauses
OS: Mac: 10.14.7 I have resisted upgrading because some of my apps would no longer work.

I did read the Audacity faqs and help files.

This is playback only. I record on a Tascam deck, import the WAV files, and mix and master in Audacity. This was not happening until recently. When using Audacity, I shut all other apps and even disconnect WiFi and Bluetooth.

The Audacity file is thirteen stereo tracks. I am reading and saving locally to my internal hard disk which has about 185 GB free.

I’ve checked the settings in Audacity. I need sample rate to be 44100 and have downgraded sample format to 24 bit. Sample rate converter is medium with no dither. High-quality conversion is High-quality with shaped dither. I want the best quality possible to export the stereo mix to a WAV (and then to an MP3. I edit the wav a little.).

Playback length is 6 seconds. Seek time 1 and 15. Vari-speed play is checked.

On devices, I have experimented to change buffer length. 0 (suggested for a Mac) makes it worse. 300 (default is 200) seems slightly better. I have not changed latency compensation because I’m not recording live.

Viewing is waveform (which I need) logarithmic, stem plot.
Spectrograms Mel; color default, window type Hann, window size 1024 default, zero padding factor 2, enable spectral selection (maybe not needed?)

Does anyone have any suggestions? This is driving me mad. This mac generally is slow but I can’t replace it.

I love Audacity and have been using it for decades!

Thank you!!!

When using Audacity, I shut all other apps and even disconnect WiFi and Bluetooth.

You hit everything I would have done. There are a couple of magic thoughts.

With everything closed except Audacity and the show opened, run Go > Utilities > Activity Monitor (CPU). See what the machine is thinking about while the show is open.

Screen Shot 2022-10-30 at 15.42.27.png
I have a rogue application that occasionally starts up “branches” in the background. It’s not bashful.

This mac generally is slow but I can’t replace it.

That’s not a good sign. Split the show into half just as a test and see if the problem goes away—or changes.

You can run out of machine. Audio (and Video) run in real time and the machine can’t signal “Wait A Second While I Catch Up.” This isn’t a spreadsheet or text document where you don’t notice a small delay. You may be experiencing the machine whimpering for help.


WIndows guy here.

Yes - that, and did you say you also tried rebooting the machine ?

Hi kozikowski and Jademan,

Thanks, yes, Jademan, I did reboot—a few times. Thanks.

Kozikowski: I will check the processes, thanks. It’s only on playback. When I’m rendering the multiple tracks to a stereo WAV and then an MP3, there is no pause on the stereo files and they don’t have breaks in them. I think it’s processing too much with all those tracks.

The Mac is about eight years old. It works okay for other things I need but, yes, I’m thinking maybe I have to wipe the whole thing and reinstall from my backup and see if that speeds up the Mac. I think it is the processor. (Can’t afford a new one at this time.)

I’ll look at the system monitor tonight—I’d thought about that but never got around to it.

Thank you so much for your help!!!