Playback of imported/recorded files distorted and fast.

This is a tough one to describe, but I’ll do my best.

Say I open an mp3 file with Audacity, it imports just fine – there are no errors, and the wave forms look as they should. But when I press play, Audacity seems to fast forward through the track (at a rate of approximately six times normal speed), but the sound isn’t just fast, it’s distorted and sounds muffled. (Unfortunately, I can’t provide an audio example as I use audacity to capture system sounds.) The playback speed slider is on normal, so it’s not that. Similarly, when I record from my soundcard, it works as it should, but when I playback the recorded audio, again, it’s too fast and distorted. However, if I export the recorded sound as .wav, and play it back through VLC, the sound is fine. It’s normal speed and clear as a bell. My point is, Audacity seems to be working fine. It’s capturing sound correctly, it’s exporting sound correctly, it’s just not playing sound correctly. During playback, if I faff about with the sliders, it tends to crash, too.

I’m currently using Manjaro Linux 0.8.6, Audacity version 2.0.3-2, and am using pulseaudio. (Correctly chosen in the options.)

Any ideas?

Say I open an mp3 file

Let’s say you didn’t. Let’s say you opened a compressed type of file such as an AAC or M4A. Audacity doesn’t know how to manage those and so it plays them as if they were normal files giving the chipmunk sound.

You can use the FFMpeg software to make Audacity recognize and play many more different file types.


Yes, but the issue isn’t that I’m having a problem with mp3 files. I simply mentioned mp3 as an example. The problem is with sound playback. If I capture my system sound – so this is before I’ve exported the raw sound into any format, compressed or otherwise – the sound plays fast and distorted.

That sounds very strange - I’ve not come across this problem.

If you only have one sound card installed, there should be options in the record and playback devices in the Device Toolbar that include (hw:0,0) in their names. Try selecting those, and ensure that no other application is using sound, then see if that works any better.

Just a quickie before bed: after a bit of fiddling, I seem to have developed a rather clumsy workaround. I can record from my soundcard using the default pulseaudio settings, but to play the recording back I have to switch to the sound on my video card (HDMI). I can then play and edit, but if I try to record with HDMI sound, nothing comes through. A bit rough and ready, but it’ll work at a push. I just can’t work out why I’m having this problem. Generally Audacity works just fine for me. I did a search on the Manjaro forums in case it was an Arch problem, but I couldn’t see anything. Will have a twiddle over the next few days and see whether I can come up with anything else.

Thanks for the help so far…

It makes me shudder whenever I read “HDMI” in the same paragraph as anything to do with audio. I’ve seen so many problems related to HDMI audio, not only on Linux but on Windows too.

In this instance, it’s actually pulse audio causing the problems. It’s glitch-free mode. When I disable it Audacity keeps crashing and speeding. When I enable it, my overall sound is a bit dodgy. Oh, the agony of choice.

Thanks for the suggestions, guys. Now I know what’s wrong, I can at least work on it. I suspect it’s un-solveable, but there we go.

Did you find a solution for this problem? I have same one.

Im’ on Achlinux 64

Try playing at the same sample rate that you record at.

What are the audio devices in Help > Audio Device Info?

If you have pulse, have you installed pulse audio volume control?

In Help > About Audcity, “Build Information”, what is the enabled sample rate conversion library?

In the Quality Preferences, try a lower quality converter for the “Real-time” sample rate converter.


The problem is in the pulse audio. From a thread I’ve found that if you start the Audacity with the following command

env PULSE_LATENCY_MSEC=30 audacity

the playback plays correctly

I had the same thing happen with Ubuntu 14.04, After running pavucontrol, I realized I had setup for 5.1 sourround, I switched back to 2 Channel Stereo, and the issue vanished.
This may not be your issue, but hopefully it may help somebody sometime.

Thanks for the great posts, this page helped me work out a solution.

I had this problem in my manjaro distro too. seems specific to the distro. Ill submit something downstream there. different things tried and now it works. First was to change the driver in settings…I thought I changed from default or pulseaudio to alsa, but now I don’t see an alsa setting…anyway try fiddling there. Then I installed all the pulseaudio applets and widgets and ran the env variable suggested above. Now it plays back properly, including after rebooting.