Playback not working


I am using a 64 bit operating system. I am using Audacity to look at Bat acoustic WAV files (upto 6MB), so very high frequency, short files. Sample rate is set at 384000. I have been using Audacity on a laptop and have not had any problems with playback. I have now downloaded Audacity on a computer and another laptop. I am not able to get either to playback.

When I go to play a file using the play at speed button, (with playback speed at 0.16) I get the following pop up:

Error while processing sound device. Please check the playback device settings and the project sample rate.

The SR has been set to 384000. The Playback device settings were blank. I checked out the RealTek sound card and it hadn’t been updated since 2010. So I have updated this and now I can see MME in Audio host and Microphone (RealTek High definition) in Playback Device (speakers). However I can not see any options to choose anything in Recording device and recording channels. But I didn’t think these would be required when only playing back calls. I always import and export the files as I need to change the name of the file to contain the bat species that is present within the file.

I have tried the earphones in both jacks and there is still the same problem. When I look in Device Manager in Audio Inputs and Outputs, it tells me the Realtek High Definition Audio :This device is working properly.

When I reduce the SR in the bottom left hand corner of Audacity to 109200 it will start to play the file but then stop a fraction of a second in. By right clicking on the speaker on the right of the quick launch tool bar at the bottom of windows and clicking on sounds, I then double click on the headphones that are highlighted green and go into Advances in Default format it gives me the option to change the SR and bit depth, but I am not sure what this is for exactly. And this only goes up to 192000 Hz. If I change this it doesn’t appear to make any difference.

When I look in Recording devices the recording devices do not seem to be not active (a red downwards facing arrow as opposed to a green tick on the laptop I have that is working properly). When I double click on them and look in properties it is telling me that the device is working properly but it is just a High Definition Audio Device from Microsoft, not RealTek, as it is on the laptop that is working correctly, but I cannot see any way to change this. If I click on the Change setting button it just take me back to the High Definition Audio Device Properties pop up box.

Sorry, long explanation but wanted you to know I have been looking at different options to fix this.
I look forward to your response. Thank you. Sarah Barry.

1 Like

Please tell us what version of Audacity you have (see the pink panel at the top of the page).

I don’t know how you updated the audio drivers on one of the machines, but the best way to do this is to go to the web site of the computer manufacturer, assuming it is a branded computer like Dell or Lenovo. Then you would probably get some recording devices and the playback error might go away if it is related to bad drivers. However if any of these machines came with older Windows and you upgraded them to Windows 10, there may not be any Windows 10 drivers available for them.

You should restart Audacity after making any settings changes in Windows Sound, otherwise you might get “Error opening”.

You could also try Windows WASAPI host with the Exclusive Mode boxes enabled in Windows Sound (below the box where you see the different sample rates).


Hello Gale,

Thank you. I am using Audacity 2.1.2 on both computers. They are both older computers that have been updated with Windows 10. I managed to update the driver for the personal computer without any issues (that I am aware of). I haven’t attempted to update this on the laptop, as it is a volunteers laptop, so do not want to change anything unless totally necessary. Plus updating the driver on the personal computer doesn’t seem to have solved the issue.

I am using a Project sample rate of 384000 (we are looking for bats with calls going upto 145 kHz). This is set within the drop down menu in the bottom left of the display. Playback works fine at this SR on the newer laptop that I originally have been using with Audacity. (This was also upgraded to Windows 10). But if I change the SR rate down to 192000 on the 2 computers I was struggling to get to playback, it works fine. The majority of bat calls we are looking at are under 96kHz. So, by doing this we are able to playback the calls successfully. However, I am a little confused with this and how the SR is running at 192000 as when I playback calls, there are clearly parts of the call that are over 96000 that are being displayed on the spectrogram. My understanding is that the file that is shown, is limited to the SR the software is set at? So and calls over 96000 can not be shown/played back? The SR within the bat detector that we made the recordings with was set at 384000. If you could give me any information on this I would be very grateful.

When I look at the Exclusive Mode box there is no mention of Windows WASAPI. There are 2 boxes to check here, both of which are already checked, Allow apps to take exclusive control of this device and, Give exclusive mode applications priority. (I am assuming the apps they are referring to is WASAPI?).

I really appreciate your help with this. Thank you.

The maximum frequency that you can display in the spectrogram is half the sample rate shown in the track’s information area.

This is independent of the project rate, which controls the sample rate of playback and the sample rate at which tracks are mixed or exported. If the project rate is below twice the frequency of the sound to be listened to, playback won’t be able to reproduce any of that sound (at standard playback speed).

The “Exclusive Mode” boxes in Windows Sound don’t mention WASAPI. When you enable the boxes, and you choose Windows DirectSound or Windows WASAPI host in Audacity’s Device Toolbar, this in theory lets Audacity request the playback sample rate direct from the card without intermediate resampling by Windows. So in theory this could help reduce “error opening” problems.

But you shouldn’t try Windows DirectSound in your case as a possible solution. Try WASAPI, if MME errors. DirectSound won’t help you because it is limited to maximum 192000 Hz (as I understand it). Also on Windows Vista and later, DirectSound does not have direct access to the hardware because it goes through WASAPI, and so it probably won’t help fix “error opening” issues.

If the computer sound card was not originally designed for Windows 10, you may receive unpredictable results even if you obtain drivers for it from the computer manufacturer that claim to support Windows 10.

It is also possible that the sound device on the problem computers does not support more than 192000 Hz playback. The Default Format rates shown in Windows Sound may not necessarily be a guide to this. Help > Audio Device Info… top right of Audacity will show you information on what rates PortAudio thinks your device supports under the different audio hosts. You can also check the rates reported for the sound card in an application like SoundCheck.

You could consider buying a more modern USB sound card that is meant for Windows 10, and be sure before buying it what maximum sample rates it supports.

All this said, if you make the playback speed low enough, you may be able to hear a representation of the bat calls even at 192000 Hz or lower project rate. Obviously you can’t, as a human, hear higher than about 20000 Hz yourself.


Thank you for such a thorough response. I will go through all of the message fully in the next few days but for the meantime can you please tell me where you mean by track’s information area? Thank you.

Above the Mute/Solo buttons, where it says “Hz” and mono or stereo.