Playback issue when playing MP3 files

Recently changed OS to Monterey 12.7.4, also upgraded Audacity to 3.5.1.
When playing back any mp3 file the cursor lags behind the actual position of music being played. Not sure if there’s a setting to correct this, or how to get this corrected.

Thanks in advance for any and all help!!

To fix the cursor lag in Audacity, try adjusting the buffer settings in Edit > Preferences > Recording, or update the Latency compensation in Devices.

I doubt that either of those will work, as they are settings that affect recording, not playback.

The issue is the way Audacity refreshes the screen on macOS. This was an issue several years ago, which I thought had been fixed.

What Mac are you using? Is it Intel (x86) or Apple (ARM)? Try downloading the installer DMG for your specific processor as opposed to the universal installer.

Thanks for the response…

I’m not computer savy, however it appears my Processor is 3 GHz 6-Core Intel Core i5.

Can you give me a little more information on how to go about downloading the installer DMG?

Thanks for your time and help!!!

On this page: Audacity ® | Download for Mac OS

scroll down to x86_64 dmg (Intel) and click the “Download DMG” button beside it. Follow the instructions to drag the Audacity application to your Applications folder. Yes, replace the current version.

Great information, and solution provided!!

Audacity is working great, no lags to contend with.

Thanks a million for your time and help,

For some reason, my lag has returned in Audacity…no sure how to proceed from here!!