Playback is high-speed and crackly

I have the same problem (for about a year). All applications work fine, Audacity plays back CRACKLE.

Linux Mint, and tried others; notebook Toshiba.

I’ve split this to a new topic because there was no mention of crackle in the other topic, so this is likely to be a different issue.

Which version of Mint?
Which version of Audacity?
What are you trying to record?
Is the problem only on audio that you have recorded, or does it also happen with imported tracks?
What audio equipment are you using? (recording and playback).
What settings in the device toolbar?
Have you changed any of the Audacity default settings? If so, what have you changed?

To answer most questions: I didn’t change anything. All versions. Playback anything.
The behavior is like this: 1st time play back is okay. If I pause and play back again, the cursor moves faster and instead of normal sound - crackle an noise. And the program hangs. After forcing quit and restarting the program the list of sound devices in Audacity becomes shorter. And the playback is crackle from the 1st time.
If you restart the system, the 1st playback is fine again, the list of devices is full; but should you pause and play back again, the problem happens again.

My guess is that some other program is trying to get exclusive access to the sound card.

When you first start Audacity, what options are listed in the record and playback boxes of the device toolbar?

Do you have any other audio programs running either in the foreground or background? (Your web browser counts as an “audio program” if there are web pages that include audio).

I consider this a bug of the program, because I’ve tried everything. with and without other programs, all distros of linux. from scratch. One thing is different though, today I installed Ubuntu, and the playback returned to normal without restarting the program:
[normal playback] - [pause] - [crackly playback] - [pause] - [normal playback]

But then I switched to Linux Mint for other reasons.

Why is it important if other programs try to use the device?! Earlier it wasn’t an issue.

Most Desktop Linux distributions these days use PulseAudio to manage the computer sound services. PulseAudio requires exclusive access to each audio device. That means, if an audio device is in use, then PulseAudio cannot use it.

By default, Audacity uses the computer’s default sound system (as said, that is usually PulseAudio). If PulseAudio is unable to access the device and Audacity is using PulseAudio then there will inevitably be problems.

You can make Audacity bypass PulseAudio and use the ALSA directly. To do this, select the appropriate “hw” device in the device toolbar. Note that if Audacity bypasses PulseAudio and accesses the “hw” device directly, then that will deny exclusive access of that device to PulseAudio, so other programs using PulseAudio will not be able to use that device.

The “hw” options usually provide Audacity with the most robust connection to the audio device, but at the expense that the device is then not available to PulseAudio and Audacity loses other benefits of PulseAudio such as volume controls that work via PulseAudio. Input/output levels for Alsa devices are always available via “Alsa Mixer” which is a simple mixer application shipped on mosy (all?) Linux desktop systems. Alsa Mixer can be started by typing alsamixer in a terminal window.

The audio system on Linux is not the most user friendly, though it has come a long way over the last few years and continues to improve.

Actually I managed now to work in Audacity after choosing “dmix”. But trying to use other applications causes problems.

Thank you, steve, for your time. You helped me. Even though it works so weird.