Playback has stopped working again

Hello! New user here. I posted this problem a few days ago and thought I got it fixed, but the problem has resurfaced again. Here’s what’s happening:

I downloaded Audacity for some grad school projects; I made one project in the old version about a month ago and it worked great. Now I upgraded to the new version, started a new project and got a good way through it, but suddenly the playback has stopped working.

I will try to be as clear as possible in my description. I open the project and I click play. Playback works for a few seconds, maybe 10 seconds at max. Then the cursor stops moving as if the playback has been paused or stopped. I try to click play and nothing happens. I try to start from a different place in the recording and nothing happens. I try to play from the beginning and nothing happens. Clicking any of the play, pause, stop, or record buttons results in the square stop button “clicking” itself constantly, as if I am clicking Stop over and over again.

Closing and reopening the program results in the same error. Restarting my computer and opening the program results in the playback working for about 10 seconds again and then going back to the same error. I have tried using my laptop instead of my computer (also Windows) and I get the same error. I opened my old project that I completed before the update and I now get the same error in that project as well.

Reinstalling the program worked for a couple hours of editing work, but it has now started to do the same thing again, and reinstalling isn’t fixing it anymore.

Any help would be greatly appreciated!

Thank you!!!

You don’t say what you are playing back to. If you are having the same problem on two different computers, perhaps the issue lies with a common playback device. Perhaps bluetooth headphones or speakers?

Thank you for this suggestion. Between my laptop and my desktop, I have used two different playback devices (wired headphones on desktop and built in speakers on laptop). I did attempt to use a different playback device on my desktop just now (built in speakers) and the same error happened. I then tried to change the output from the dropdown menu in Audacity… and it crashed. I received a problem report that is very long but lists this: “Crash reason: EXCEPTION_ACCESS_VIOLATION_READ”

I don’t know what that means. Any other ideas? Thank you again!!!

I am also having this problem intermittently. During playback the sound will stop but the line continues moving. If I click the stop button it will spastically click itself dozens of times. While that is happening you can’t click anything else. Only when it stops can you attempt to start over or close. I rescan audio devices routinely everytime I open Audacity (several times a day). Sometimes it helps, sometimes it doesn’t.

No change in the audio connections I have been using with Audacity for over 3 years.

I’m getting the self clicking stop button as well…I might have found a workaround.

Usually my Audacity project files are stored on a server so multiple people can access them on their individual laptops. That’s when the problem occured.

Saving both the project file and the wav-file of the unedited recording locally on my laptop has fixed the problem at least for now. Don’t know about your data storage situation, but maybe this helps?

In my case maybe a unstable connection to the server where the files are stored has something to do with it? Audacity doesn’t seem to handle shaky network connections while a project is used very well. Caused problems sometimes also before version 3.x. But I’m just guessing…hope this can be fixed soon.

From the manual (In the yellow box near the top of this page:

You are > strongly > advised > NOT > to save your active project to an external USB stick/disk, networked storage or cloud storage as it is unlikely to be fast enough for satisfactory recording and editing.

It still used to work fine for 99% of the time, but i guess i’ll it’s time to change habits :slight_smile:

I just want to add that even with the more frequent freezes and crashes that have been happening for me lately, I’ve never lost any data or even work progress, so you get an A++ for your recovery method :slight_smile:

Yes it is :slight_smile:

Being “fast enough” is only part of the problem with network drives and AUP3 projects. There are also more technical issue associated with file locking and secure database transactions, which in the worst case scenario could lead to unrecoverable corruption of the project.

What I’ve been doing recently (and this seems to work pretty well), is to keep projects when NOT in use on Google Drive (plus another backup copy somewhere), then copy the project from Google Drive to my computer’s internal SSD when I want to work on it, then copy it back to Google Drive when I’ve finished (plus another backup copy somewhere else). Copying from Google Drive is reasonably quick with broadband. Copying back to Google Drive can be a bit slow, but Google Drive can do that in the background while I’m doing something else.

If you come up with a better workflow, please do share it with us - we’re all getting used to the new format and its pros and cons.

Do you mean storing the aup on a network drive when not in use could be unsafe as well? I really hope you don’t…that would complicate things quite a lot.

I guess the new workflow will consist of copying projects back and forth between the network and my local drive as you said. i’ll definitely let you know if i suffer a sudden stroke of genius and comeup with something better.

No I don’t mean that.
Once the project is fully closed (safest is to wait until you have quit Audacity), the project is fully contained in the AUP3 file and can be saved / copied / moved just like any other file.

While the project is open, there is still temporary data (.WAL and in some cases .SHM files) that may or may not be required by the project. It’s while these transient files exist that the project is vulnerable.

ok thanks for the clarification