Permissions for local manual?

I can’t access my local manual. I believe it’s installed in the correct place, according to

└── help
    └── manual
        ├── favicon.ico
        ├── images
        ├── index.html
        ├── m
        ├── man
        └── quick_help.html

but perhaps significantly, index.html can’t be accessed there - the browser (any browser: FF, Chrome, Opera) won’t load it, but the text editor will. (The file is not damaged, it’s accessible with a browser where I downloaded and unzipped it.) So if the installed path is correct, it looks to me like a permissions problem. The directories are all “drwxr-xr-x”. The files are all “-rw-r–r–”.

OS is Ubuntu Linux 18.04.4
Audacity 2.3.3
Manual files are dated 15 Nov 2019

What happens if you double click on the “/usr/share/audacity/help/manual/index.html” file?

Thank you for responding.

As I wrote,

the browser (any browser: FF, Chrome, Opera) won’t load it, but the text editor will.

By this I did mean double-clicking, and not accessing it via Audacity itself. Via Audacity, I get the ‘View the manual on-line’ window.

Having powered down the machine, and therefore restarted Audacity for a second time, index.html will now open from /usr/share/audacity/help/manual/index.html, but still not from inside Audacity.

In Audacity Preferences, is “Location of Manual” set to “Local”?

Indeed it is. Because I’m on a metered Internet tariff, having the manual local makes a lot of sense.

After my last post, I changed ownership of everything below “/usr/share/audacity” from “root root” to be the same as “/usr/share/audacity”, which was “root users” - to no effect. I am not a member of “users”, but making myself a member also had no effect.

I confirm I’m still getting the “Help on the Internet” window that starts “The Manual does not appear to be installed. Please view the Manual online or download the Manual…” either when clicking “Manual” in “Welcome to Audacity - How to get help” as Audacity starts up, or via the top menu “Help… > Manual”


I just installed the manual locally on Linux Mint 19.3 which parallels your environment. I used the following procedure:

cd ~
mkdir help
cd help
unzip -a ~/Downloads/
sudo su -
cd /home/username
chown -R root:root help
chmod -R 0644 help; chmod -R +X help
mv help /usr/share/audacity

I previously had the manual selected as Internet but at the next start Audacity changed this to Local and the manual opens correctly in my browser when it’s selected from the Help menu.


Thanks for the suggestion, but having (almost) exactly repeated your steps (I’d already got the manual extracted in my downloads directory), the problem persists.

The only difference is I now have ownership as root root, which I had originally. All the file permissions are identical to what I had.

This does not make sense. By default, html files will open in the default web browser. There must have been some reason why it didn’t, and rebooting is not going to change that. Somehow you must have change the file association of html files, and then somehow partially fixed it, but not completely fixed it. Do you recall doing anything to change the default file association for html files?

In the “Preferred Applications” app, what is set for “Web Browser”?

It’s not making sense to me either. My normal default browser is Opera. I have not knowingly changed anything, yet now I can open the HTML files in situ by doing Open with other application… Firefox (or Chrome) but not by double-clicking, which invokes Opera - it reports “Not allowed to load local resource: file:///usr/share/audacity/help/manual/index.html”. But if I extract the files from the zip download into my Downloads directory, they open immediately in Opera. Which is why I thought it’s a permissions/ownership problem.

I’ve got to ask you to confirm the directory structure I have is correct, because it wasn’t totally clear to me – I think because the directory “manual” was included in the zip package but “help” was not, exactly what the final file structure should be. Who should be the owner of /usr/share/audacity and its subdirectories, and what should the permissions there and below be?

This is on my machine (and it works as expected):


total 24
-rw-r–r-- 1 root root 4586 Dec 11 2017 EQDefaultCurves.xml
drwxr-xr-x 3 root root 4096 Mar 15 22:54 help
drwxr-xr-x 3 root root 4096 Oct 27 10:35 include
drwxr-xr-x 3 root root 4096 Oct 27 10:35 nyquist
drwxr-xr-x 2 root root 4096 Oct 27 10:35 plug-ins

total 4
drwxr-xr-x 5 root root 4096 Mar 15 22:54 manual

total 116
-rw-r–r-- 1 root root 15086 Mar 15 22:54 favicon.ico
-rw-r–r-- 1 root root 60030 Mar 15 22:54 index.html
drwxr-xr-x 5 root root 4096 Mar 15 22:54 m
drwxr-xr-x 3 root root 20480 Mar 15 22:54 man
drwxr-xr-x 3 root root 4096 Mar 15 22:54 manual
-rw-r–r-- 1 root root 11905 Mar 15 22:54 quick_help.html

total 8884
-rw-r–r-- 1 root root 13103 Mar 15 22:54 aac_export_options.html
-rw-r–r-- 1 root root 12092 Mar 15 22:54 ac3_export_options.html
-rw-r–r-- 1 root root 14491 Mar 15 22:54 accessibility.html
-rw-r–r-- 1 root root 23345 Mar 15 22:54 adjustable_fade.html
-rw-r–r-- 1 root root 15175 Mar 15 22:54 advanced_mixing_options.html
-rw-r–r-- 1 root root 17066 Mar 15 22:54 alternative_noise_reduction_techniques.html
-rw-r–r-- 1 root root 22796 Mar 15 22:54 amplify_and_normalize.html
-rw-r–r-- 1 root root 15574 Mar 15 22:54 amplify.html

It looks as if my installation - recently updated - is somewhat different. I’ve got this structure and files

excluding of course “help”, in “/snap/audacity/599/usr/share/audacity” and “/snap/audacity/current/usr/share/audacity”.
I don’t have those where yours are.

root@r-X550CL:/snap/audacity/599/usr/share/audacity# ls -l
total 5
-rw-r–r-- 1 root root 4586 Feb 23 20:34 EQDefaultCurves.xml
drwxr-xr-x 3 root root 31 Feb 23 20:36 include
drwxr-xr-x 3 root root 552 Feb 23 20:36 nyquist
drwxr-xr-x 2 root root 620 Feb 23 20:36 plug-ins

root@r-X550CL:/snap/audacity/current/usr/share/audacity# ls -l
total 5
-rw-r–r-- 1 root root 4586 Feb 23 20:34 EQDefaultCurves.xml
drwxr-xr-x 3 root root 31 Feb 23 20:36 include
drwxr-xr-x 3 root root 552 Feb 23 20:36 nyquist
drwxr-xr-x 2 root root 620 Feb 23 20:36 plug-ins

This is the first mention of it being a snap package.
That will be the problem. Snap packages run in a “sandboxed” environment which, for security reasons, limits the application’s access to the outside world.

I don’t use snap packages myself, so I don’t know a lot about them and I can’t test, but you could perhaps try putting the help folder inside:

Snap is the default now, apparently.

One obvious comment: the manual installation note needs to mention that the instructions don’t apply in that case.

So, is it worth pursuing, is it likely that Audacity will be patched to accept either location, or would you recommend removing Audacity and re-installing using Apt (it still appears to be available that way)?

And thank you for the time and effort you’ve put into this.

You could log a bug with Ubuntu for the missing manual.

The Audacity documentation assumes that package builders build Audacity according to the instructions. If the package maintainers decide to do something different (which we don’t know about), then it is arguably their responsibility to inform their users of limitations / bugs in their package. We have no control over what Ubuntu do with our source code.

I suggest that you try moving the help folder from
and let us know what happens.

I’ll give that a try. As snap seems to be the flavour of the month, it does seem incumbent upon them to complete the job.

True, but a simple mention that the 3rd party has introduced a failure mode would have saved both of us - and presumably is likely to save others in the future - a lot of time and effort.

It’s read-only, and I can’t figure out how to change that. (It’s RO a long way back up the tree.)

Again, thanks for the help.

Which we certainly could have done, had we known.

We do know that there is at least one flatpak version of Audacity, but last time I looked there were multiple problems with it.
There are also more that 670 forks of Audacity on GitHub.


Thanks, I shall do that.