Paste (Command V) Works Very Slowly

Audacity 3.0.2
Computer: iMac 21.5 inch, Late 2015
macOS: Big Sur

This is kind of a weird problem (for me anyway, hopefully not for somebody). I am doing an audiobook. While doing this, I create and copy 0.8 seconds of silence to use between sentences. I then paste that 0.8 seconds of silence between the two sentences I want (overwriting the extra time and flubs and whatnot). A couple minutes into the timeline of a long chapter (about an hour of recorded time that I would eventually carve down into half an hour), the paste started to give me the rainbow wheel for a few seconds before pasting. Another dozen pastes, and it is taking over three minutes for the wheel to stop spinning and do the edit.

Playback, copying a section (command c), silencing a section (command l), etc, are not affected and do not produce a lag. Just when I paste. I opened up a different chapter of my book, and the paste works fine on that chapter. (Though I am worried other chapters will develop this problem as I keep editing them. The problem crept into this chapter as I was working.) I think it is a file problem. Shutting down Audacity does not work. Rebooting the computer does not work.

Any suggestions from somebody who has also had this problem?

So on Windows, I generated 1 hr of audio and randomly pasted several dozen .8 second clips in the audio, and was unable to duplicate this problem.

Have you tried Save Project > Backup Project, then working from that backup?

It isn’t a problem for my other files either. I just finished editing the next chapter that I recorded right after the one giving me problems, and the paste command worked fine the entire time. It seems to be just that one file. I’ll try your suggestion.

It looks like I fixed the problem. :smiley: I exported the problem track into an MP3, and then I imported the MP3 back into Audacity. Now the past command works again!