"Paste" command not working in macro batch application [SOLVED]


I created following simple macro for batch application on audio files:

Normalize:ApplyGain=“1” PeakLevel=“-0.1” RemoveDcOffset=“1” StereoIndependent=“0”

First I copy some audio from an Audacity track (usually some seconds of silence with a sound at the end), close the track so that the project is empty or simply open a new project, and apply the above macro to a batch of files. This normalizes the selected files, pastes the copied audio to the end, and exports as mp3s. At least since Audacity 3.0.3 the copied audio is not appended anymore - i.e. the files are exported without the previously copied audio added. I have returned to Audacity 2.4.2 where the macro is working again.

Right now this is working fine for me, but at some point I would like to upgrade to the latest version of Audacity again.

Thank you for your consideration,

Windows 10, 64x

It looks like a bug. Thanks for reporting it.

A workaround is to export the audio that you want to append as an audio file (for perfect quality, use “WAV 32-bit float”), then import that file each time you want to use it with “Import2:”

Thank you for your prompt reply. Will do as advised.

Give a shout if you need help getting it to work with “Import2:” - it’s not completely straightforward :wink:

(I’ve logged the bug)

Yes, it took me some time :'D, but I finally came up with the following:

Normalize:ApplyGain=“1” PeakLevel=“-0.1” RemoveDcOffset=“1” StereoIndependent=“0”

This seems to work with Audacity 2.4.2 and I assume with the latest version as well. If otherwise I will post.
Thanks again.

Nice :ugeek: I think that’s the most efficient solution - I’ve not tested with Audacity 3.x, but I expect it will work.

Yes, I just reinstalled Audacity 3.0.5 and it’s working fine. Nice to be back to the latest version :slight_smile:

Super. Thanks for the update.

I’ll close this topic as “solved”, not because the bug is fixed (it isn’t yet, but it is logged for fixing), but because it offers a usable workaround for anyone else that encounters this problem.