overlapping of backing track while recording

After importing an audio track and trying to record vocals in the separate layer, the backing which is playing in headphones is also getting recorded,NEED THE SOLUTION ASAP

Two things can cause that.

You need to be recording from your microphone or microphone system ONLY. Not What-U-Hear, Stereo Mix or other software device. This is the probable cause if you like recording internet music. That’s the wrong setting for Overdubbing.

Audacity > Edit > Preferences > Recording. De-select [_]Playthrough.