I’m sure this is an issue that is addressed here a lot, but I couldn’t find an exact answer to what I’m trying to do.

I’m trying to overdub bass into my recording. A few days ago, a friend and I recorded a song with guitar and drums playing at the same time. It sounds great and I’ve got it just where I want it. Today, I’m trying to add in the bass and vocals but I’m having some issues. When I go to record a new track for the bass, it records the drum-and-guitar track into this track along with bass. I want to have these in two tracks (track one drums-and-guitar, track two, bass).
I’ve made sure that I checked “Play other tracks while recording new one” and unchecked “Software Playthrough.”
Can anybody give me a hand?
I’m using version 1.2.6 by the way.

It’s almost certainly a sound card set-up issue.
You need to have your sound card set to record from the input that you are using (mic or line) and not “Stereo Mix”.

I’m trying to adjust the input source on the mixer toolbar, but it is greyed-out and I can’t change anything. It is currently blank.

I also feel that I should mention I’m running the bass amp straight into a cheap Behringer 5 channel mixer and that straight into my computer via tape out (with the red and white pieces).

That’s just a shortcut really, and often did not work in the old 1.2 version of Audacity. (it still does not always work in the current 1.3 version, but it works a lot more often than the old one did).

Since the shortcut does not work you can go directly to the sound cards own interface and control it from there.

Assuming that you are on some version of Windows (?) there should be a loudspeaker icon near to the time/date in the bottom right corner of the desktop. Double click (or right click) to open the sound card “mixer”/“Control Panel”. All of the sound card user settings are in there (though some of them can be difficult to find), The exact layout of the sound card mixer depends on the sound card, the sound card drivers, and the operating system.

Great! That fixed that problem!

But alas, a new one has arisen. It appears that the tracks fall out of sync. At first I thought my sense of rhythm was just way worse than I expected, but after messing with it a few times, this is just not the case. Any ideas?

Are you using a high quality sound card, some cheap and nasty on-board sound, or something in-between?
Is the timing out by a consistent amount, or gradually drifting?
What’s your operating system?