Overdubbing issue

Hi everyone, help me out here.
I have 2 mp3 files, one with vocals/accompaniment and another the same with just the backing tracks. Imported the one with vocals and added a new track so that I can record on the second track while playing playing the mp3. When I play back the second track as a solo and muting the first track, I can still hear the first track also being played on the second track which means it’s obviously being recorded on the second track. How can I eliminate that? What I am trying to achieve is to play along with the vocals and then replace the mp3 track with just the backing track.

Oh, and I forgot to mention, I am using a Boss GT-100 effects pedal which is connected to my laptop via USB. My primary recording/speaker devices is the GT-100.

Turn off Audacity > Edit > Preferences > Recording > [_] Playthrough while you’re overdubbing.

Make sure you’re recording from a real device that you can reach over and touch and not a software “fake device.” This one pops up if you like to record Youtube or other internet content. The convenient way to do that is record from Stereo Mix (for common example) which folds back your computer’s playback and record services. It’s a process not a device. You can’t touch it.

Unfortunately, they don’t make this easy because many actual, real, hardware devices have magic names. My Behringer UCA-202 real stereo interface’s name is "USB Audio CODEC."


Do you mean to say that your GT-100 is selected in the Device Toolbar ?

Do you mean to say that your GT-100 is selected in the Device Toolbar ?

It may or may not say GT-100. A good way to sort what you have is Transport > Scan Audio Devices and look at the recording device list on the Audacity tool bar.

Screen Shot 2021-08-04 at 7.05.04 AM.png
That example is my Behringer stereo interface. Disconnect your GT-100 and scan again. The name it uses should vanish.

Screen Shot 2021-08-04 at 7.05.38 AM.png
If those two scans are the same, then Audacity is not seeing your device or connection.


Yes, that’s what I select (both recording and playback) works fine when recording. my only issue is with track 2 capturing the playback from track 1 along with my guitar :slight_smile:
pic 1.jpg

Thanks for the quick response. I can see my device in the recording / playback devices. To frame the same question in a different way :wink: Lets say I record something on track 1 (stereo). Then create a new track and record something else on that. Is there a way of playing each track (using the solo option) and being able to listen to what was recorded one each track separately, In my case, the first track becomes a part of the second track.
pic 1.jpg

(I am looking for a GT-100 manual and I cannot find any such documentation on the web.)

Let me suggest simply using your laptop’s headphones as Audacity’s output device.

To confirm that you are using the Solo function properly, you can simply delete [x] the track that is muted, then recall it with Ctrl+Z.

There is one other place where this unintentional foldback can happen.

There are sound mixers that have the ability to mix the backing track with the live show and present it to your headphone connection. That’s perfect overdubbing—so far so good. But they also have a setting to send the mix to the recorder instead of the pure, fresh performance. It’s beginning to sound like what you have.

And without an instruction manual, we’re stuck.


I don’t know that we covered this in the message so far, but you have to use headphones for almost all overdubbing jobs. You can’t have a live microphone and a speaker feed in the same room with an overdub session.


I beleive you’re right about the setting. Is probably something I’m missing. I am using headphones which is plugged into the Boss GT-100 and can listen to both the guitar and the sound off audacity. The user manual is too large to be attached but here is the link. Really appreciate both your assistance.

Yes Jade, I did try deleting the track with the mp3 and could still hear the mp3 being played back on the new track. Is when I realised what was happening.
Link to the manual if that’ll help. Thanks again.

The manual is not clear and suggests that you should never be getting this “crosstalk”.

However, have you tried setting OUTPUT LEVEL to 0 ?

Output level to zero sends no sound to the laptop. Will check Page 43. Says about normal / dry out / reamp option but am not very clear about what it means. :wink:

It will take a while to dig out of this one.

Does Boss have a help desk or forum?

Just to cover it and without going all the way back to the top, do you have a microphone and a speaker running in the room during overdubbing? Yes, you might be wearing headphones, but if you take them off, does the room sound drop dead except for the tiny little mousy sound coming from the headphones?


Will reach out to the Boss support team too. As for the sound, the laptop mic and speaker is not used, instead the boss unit is selected as the recording device and the sound is coming off the boss unit (via the USB). My headphones are connected to the phones port on the unit.

At the risk of repeating myself,

I think the difference between the normal or dry out selection is going to be whether your effects are applied before returning to the USB port (dry=no effects). Just don’t reamp or you won’t get any guitar output.

Do you have a solid body electric guitar with magnetic pickups? That should be OK. If you have a hollow or semi-hollow body guitar, make very sure your speakers are turned OFF.

Jade, I tried the reamp / dry out setting and saw a stack amp with one signal out and the receive signal in but didn’t help. But I did try recording the first and second track on audacity and it worked fine with the recording and playback coming out individually. Seems to be an issue with the imported mp3 that’s getting mixed up with the new tracks. Food for thought :slight_smile: