Overdub doesn't work with Tascam US-1200 [SOLVED]

I have been using Audacity with my Tascam US-1200 for years, but it suddenly won’t work when I try to record an overdub. It was working, and suddenly stopped. I can record a track from scratch just fine using a mic plugged into the Tascam. But if I have a track already open and press record to record an overdub track, the transport doesn’t start. I can also play a track no problem through either my speakers, which are attached to an audio amp attached to the Tascam, or on headphones plugged into the Tascam. And, as I said, I can record as long as there is not another track already open in Audacity.

Here’s what I have tried so far:
I checked all the settings. In Audacity record settings, I have “Play other tracks while recording (overdub)” and “Record on a new track” checked, but all other options are off. I checked the quality settings, and the default sample rate is set to 44100 Hz, 24-bit, as is the Tascam.
I uninstalled and reinstalled Audacity. I have version 2.4.2.
I uninstalled Audacity and deleted the Audacity folder in %appdata%. Then I reinstalled.
I uninstalled and reinstalled the Tascam drivers.
I downloaded the latest Tascam drivers, uninstalled the old ones, and installed the newest ones.

Here’s my setup:
Windows Home 64-bit version 2004 build 19041.508
ASUSTek EEEPC with Celeron J1900 at 2 GHz
8 GB Ram
Tascam US-1200

Just to be sparkling clear, you can record a fresh track just fine, but using that fresh track as the backing track, you can’t record a second track? You didn’t exactly say those words.

It’s an oddly common failure to go through all those checks and have a recording fail because of a bad backing track recorded somewhere else.

24-bit is a little unusual for home producers. Any specific reason you’re doing that?


Sorry. I didn’t say that clearly enough. I can record a fresh track with a mic, and then can’t dub over it. When I start the recording for the dub, the transport doesn’t move. I also tried several of my “music minus one” type tracks, and all of them fail the same way. I just tried several more, and each time, the transport would not move.

Actually, I set it to 24 bit trying to get it to work. The Tascam is set to 24 bit, and I didn’t find a way to change that. I was just trying to match what the Tascam is set to in case it needed to match. It also was failing before I changed that setting. It was originally set to the Audacity default of 32 bit float.

I just set it back to 32 bit float and tried several more times, both with fresh tracks I recorded and with “music minus one” tracks, and it still fails in the same way.

Not that it makes any difference… Is your output device always running through the TASCAM ?

Similar Tascam problem solved here … https://forum.audacityteam.org/t/track-1-records-onto-track-2-when-overdubbing/56696/8

Jademan - Yes. the only audio output hooked to the computer is the Tascam. And Audacity is set to use the Tascam as both input and output.

Trebor - I appreciate your response, but that thread doesn’t seem to have any relationship to my problem except for the Tascam brand name. In that thread, the backing track is recorded into the dubbed track. That’s not at all what’s happening in my case. In my case, it won’t record at all.

I’m beginning to think that this is caused by a fault in the Tascam US-1200. I was actually fighting dropouts in the sound when this happened. I had forgotten that because this problem began a couple of weeks ago and I’m just now getting back to troubleshooting it. I was just hoping that one of you more experienced Audacity folks would be able to point out some option that I had accidentally set that would cause this.

one of you more experienced Audacity folks would be able to point out some option that I had accidentally set that would cause this.

That’s what we would normally do, yes. “Did you set the frammistat option?”

But every so often someone will arrive with a problem we’ve never seen before.

I was actually fighting dropouts in the sound when this happened.

That’s good to know. Overdubbing is the first time the system has to play the backing tracks absolutely perfectly in real time and record the new work absolutely perfectly in real time. If there’s anything wrong with the bitstreams at all, the session will go face-forward into the mud.

How long is the USB cable? Do you have another one? Unconditionally stable USB cables rarely go over 6 feet (2M).


You were saying you couldn’t record a second track.
It is possible to set a mixer so the output from the first track mutes (ducks) the subsequent recording.
( As there is no output from the computer when the first track is recorded there is no problem on that one ).
There may be a control called loopback or ducking on the physical mixer or it’s software which you can disable.

(If it can record the first track, then it’s not a faulty mixer, it’s just configured wrong).

Someone will correct me, Audacity does its stuck cursor thing when it can find a valid device, but the bitstream from that device drops dead.

Losing a bitstream in the middle of a musical note is pretty unusual. Most of the time digital does it’s traditional thing of either working or not. A ratty bitstream is one of the conditions in the super-rare middle. The bitstream is sorta, kinda, most of the time there, maybe.

That condition is unstable. It should be possible to change anything and have the problem change. I would totally start with the USB cable. Make it new and short.


So…? Have you tried using another output device?

That was a good thing to try. The USB cable I was using was 5’ long. I substituted another one that is about 1.5’ long. It is one I use to program Arduinos with, so I know it’s a good cable. But that didn’t fix the problem. I also switched that cable to another USB port on the computer in case that was the problem. All to no avail.

As another test, I plugged in a small SoundBlaster USB audio dongle that I have, and made that the input to Audacity. And it will overdub.

I conclude that, even though the Tascam does allow me to make recordings using a mic, it must have some problem streaming the two separate streams during an overdub. I have ordered another USB audio device, a Focusrite Scarlett 2i2, to replace the Tascam. If that doesn’t get me going again, I can always return it.

Thanks for your help.

Just to close out this “event”, I ordered the replacement USB audio interface unit, and it works just fine. So the problem wasn’t Audacity or any of its settings.

Thanks for your help, everyone.

Thanks for the update.
I’ll close this topic as “solved”.