overdub - cant hear myself

i’ve tried several times to do an overdub. i followed the online manaual instructions for all my settings. but i still can’t either hear myself at all or very lightly in the background. i created the sound track using the vocal remover.

i have a sony F-V220 dynamic microphone and a viahd audio sound card. i am running win7.

so as far as i can tell one of 3 things are wrong - my settings or i have a poor microphone or i have a poor sound card.

but i would appreciate some help from you all experts to help me figure this out. do you suggest a certain type of mic or sound card? are there particular settings i need to check to make sure they are right?

thanks for the help!

– karen

You never said if the overdub worked. If you perform even without hearing yourself, do you appear on the recording?

I’m guessing yes. You are “overdubbing,” but in my words, not “Perfect Overdubbing.”

Perfect Overdubbing happens when you can hear yourself in live performance and your headphone show is the same show a client or customer would hear if you stopped right now and shipped the performance.

Perfect Overdubbing is very desirable, but much harder to do.

There is little or no information on your soundcard, but can we assume it’s an internal computer soundcard? As a fuzzy rule, you can’t listen to the computer to hear yourself. I’ll tell you how to do that later, but it’s not useful because the computer will give you your voice back late with an echo and you can’t use it for the performance.

To get Perfect Overdubbing, you have to be able to listen to your microphone, mixer or sound device, not the computer. Recent offerings call that “Zero Latency Monitoring.”

This microphone can do that.

So with your current setup, the best you can do is perform “blind” (so to speak) and only hear the theatrical mix when you play the whole thing back after your done.

This person is funneling a little of his voice up to his ear through his cupped hand.

I know that looks like a comedy bit, and the picture is taken from a comedy TV show, but that’s a real thing. I have pictures of people overdubbing with only one side of the headphone over their ear. The other ear is uncovered so they can hear themselves.

Audacity > Edit > Preferences > Recording: [X] Playthrough
If everything else is set up correctly, that will fold your own voice back to you. I don’t think you have to restart Audacity. I don’t remember.


The change takes affect when you press OK.


sorry - i wasn’t very clear. no it didn’t work. i know i can’t hear myself when i sing during the recording. i’m ok with that. i did the funneling.

when i play it back - that’s when i can’t hear myself.

i should also mention that on the music track i’m using i have a very tall sound wave pattern. but i noticed on the recording the waves are either flatline or very short (and i do mean short!). so i have two windows basically that represent my music and then when i press the record button - a 3rd window comes up which should represent the combo of the music track and my recorded voice. in this 3rd window is where the sound wave is short to sometimes non-existant. when finished, when i highlight only the 3 window - which should be my recorded voice along with the music - and play it - that’s when i can’t hear myself.

my mic input in audacity is as high as it can go and for what it’s worth the output (speaker) is about 75-80%.

does this help? i hope so.


There are two things wrong there.

If you are using Audacity from Audacity ® | Download for Windows then each track is not in a separate window that you can drag around. If your version of Audacity does that then it’s a fake or experimental version someone made and we can’t help you with that.

Secondly you should be recording only your mic in the new track. Audacity will mix your mic-only recording with the music in the tracks above. So choose the external microphone as recording device in Device Toolbar.


You may have violated one of the overdubbing setups. Make a straight, plain recording first, before you get tangled up in overdubbing settings.

That and getting the right Audacity. That’s a problem.


i downloaded audacity from your website. no one gave it to me.

what i did was import a wave file and i’m pretty sure it gave me two windows - a sound wave pattern in each. i thought this was normal because i thought i had read somewhere about inverting the tracks. but anyway - after i imported the wave file i used the vocal removal isolation tool.

then as soon as i hit the record button i get another window. this is the one that has the short/flatline sound wave. and yes - it does mix the two patterns when i playback.

i’m at work right now - but when i get home i’ll check to see what version of audacity i have and i want to also dbl check that i really do get two windows when i import the wav file. i’ll try and paste into my next msg. maybe it’s just one window that is split with two sound waves - one on top of the other. at any rate i can’t move them around. all i can do is close them.

i’ll also go back through the overdub steps to make sure i have it right. i’ll be sure and choose the external mic as the recording device.

thanks for your patience and your help.

When you import a stereo file it is in one track with a horizontal divider between left and right channel. You can use the track’s dropdown menu to split the stereo track into two tracks, one for the left channel and one for the right channel.

It’s a new track. An essential definition of a “window” is that you can drag it around, resize it at any edge and usually it has buttons to close, minimise or maximise/restore (even if those buttons could be greyed out). So it’s just a little terminology difficulty. Technically you could call the track a “pane”.


then as soon as i hit the record button i get another window. this is the one that has the short/flatline sound wave. and yes - it does mix the two patterns when i playback.

This may be just confusing and compounding errors on what’s supposed to happen.

Each time you press Record, Audacity should produce a new blue wave (or two). That’s normal. It happens whether you’re in overdubbing or not.

It is expected that your voice, if that’s what you’re recording, appears on that new blue wave. It’s also expected that it appear by itself. There’s a common error where the new blue wave contains everything, and not just your voice. That’s not useful and we can fix that.

You can listen to any blue wave you want, or any combination by clicking the MUTE and SOLO buttons to the left. If you SOLO your voice, you should hear your voice and nothing else.

From your description, I suspect if you SOLO your voice, you won’t hear anything. It’s pretty common to plug in a new microphone and produce really, really low volume recordings, particularly if you’ve never used a microphone before.

As a fuzzy overview, you should never be using a microphone without headphones. Are you using headphones? If you try to do it with speaker sound, that can create all sorts of odd problems and damaged blue waves.

The setup for Overdubbing has you making a plain voice recording first. Did you do that? That’s a big deal. If you don’t, you could chase your tail for a long time wondering what’s wrong.

Save your music tracks if you haven’t already. Use WAV or Save a Project. Do not use MP3 for anything.

Restart Audacity. Make sure your microphone is selected, your headphones are plugged in and press Record. This graphic is the goal.

You don’t have to hit that exactly, but if you’re producing flat blue waves, that will need to be fixed before we go any further.


ok - i think we were just saying the same thing - just using different words. i said window when i should have said - when i import the wave file i have 1 track split in 2 and then when i hit record i get a second track. i am so sorry to cause the confusion.

i’m going to try and do a plain voice recording again.

yes i’m using headphones.

btw - the mic i am using - is NOT usb. i bought one that has the 3.5m jack - i think i read somewhere that usb mics were not as good as the mics that have the 3.5m connection.

i’ll reply again once i’ve done this.

thanks again for all of the help. i really appreciate it!

– karen

i think i read somewhere that usb mics were not as good as the mics that have the 3.5m connection.

You should probably stop reading that.

You read about all the USB problems because the number of USB microphones greatly outnumbers the analog/3.5mm plug sort. There may not be anything wrong with the analog microphone, but they’re forced to route through the computer sound card and most sound cards are rubbish. I have used a microphone such as that with an adapter and higher-end sound mixer multiple times and I’ve been very pleased with the work.


good news! while i didn’t have time to run through all the set up steps last night - i did purchase a new mic earlier this week - usb this time instead of the 3.5mm. and it worked! so while not inexpensive - it appears to me the first mic was the issue. however - being the glutton for punishment that i am - i am going to go through the setup tutorial again and use the first mic and see if i can get it to work. i also need to understand the setup piece - so even if it doesn’t work with the first mic once i’m finished - at least i will have gained some very valuable knowledge!

thanks to all of you for all of your valuable input and help!

– karen