output sound volume

It seems Audacity takes control of the output volume on all devices: built-in internal speakers, USB headset, etc.
For example, after having used Audacity with built-in internal speakers output checked in, when I try to listen through the USB headset, there is no sound at all.
I must open an audio file in Audacity, check the USB headset for output; quit Audacity and try again to listen through the USB headset but, the volume is not what it would have been had Audacity done nothing to change the output.
This happens with all applications.
The volume is limited and it cannot be made louder no matter what one tries to do.
My USB headset volume is less than one half of its original volume.
I shall appreciate all help anyone can provide.
Thank you

iMac 2.5 GHz Intel core 15, 16GB memory

What USB headset is that?

I’ve used Audacity extensively with Snow and never seen that behaviour. So I’m guessing the driver for the USB headset has something to do with it.

What is supposed to happen is that you can choose whatever output device you like in Audacity, and that does not affect which device is the default (selected) device in the system Sound Preferences.

But when a particular device is selected as the Audacity output device, then if that device has output level controls, changing the playback level slider in Audacity changes the output level of that device in the system (whether that device is system default or not).

The same applies to input devices and input levels too.


The headset is a Sennheiser PC 8 USB
It is a plug and play set so, I don’t think it has a driver.
I had the same problem with a Logitech USB headset before.

I am saying that if I choose whatever output device in Audacity, that device affects the system Sound Preferences.
If I want to use a particular output device in system Sound Preferences, I must first open a file in Audacity and change the output device (in Audacity) so that Audacity’s match the system Sound Preferences I choose, otherwise I get no sound.
This procedure is quite a drag.

For some reason, this does not solve the volume output problem I mentioned on my post,
Thank you

Are you saying that if you select device A in Sound Preferences, change in Audacity from device A to device B (or launch Audacity with device B already selected), then device B becomes physically selected in Sound Preferences?

What exact version of OS X and what exact version of Audacity (all three numbers) are you using? Look in Audacity > About Audacity… for the version number.

Do you have more than one USB audio device connected at the same time? If so do they both have the same name in Sound Preferences?


No; what I say is, if I select device A in Audacity and want to listen sound through device B selected in Sound Prefs I get no sound.
Audacity actually overrides whatever is selected in Sound Prefs.

OS X 10.6.8

I have only one USB audio device.

Well you could try 2.1.3-alpha from http://www.audacity.homerow.net/index.php?dir=mac/ then at least we will know if it happens there.

Also please save and attach the contents of Help > Audio Device Info… top right of Audacity. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 What different playback device are you using in Audacity and why can’t you use the USB headset in Audacity too?

No-one here still has OS X 10.6.8 as far as I know. Apple make it near impossible to install 10.6 on a modern Mac and you can’t test audio issues properly in a virtual machine. But no-one else has reported your issue.


There are 67 folders in the parent directory (this is what I get when clicking on the link you give me.)
Can you please tell me which folder contains 2.1.3-alpha?

See attachment.

I know about using OS X 10.6.8 on newer Macs. My experience with Lion and Mavericks is not good. I still prefer OS X 10.6.8 and would not give it up until I’m forced to buy a new Mac. I have an iMac 2.5GHz Intel core 15 that I like a lot. I have tried some newer Macs and have not been satisfied with their behavior. Also, I’ve installed Mavericks on an external HD but stopped using it after the second run.

Thank you
deviceinfo.txt (3.01 KB)

Normally it is best to take the latest build, so try the ZIP of the release configuration build:

Audacity will sooner or later drop support for OS X 10.6 because it impedes developing Audacity for current macOS. It will happen as soon as we fix enough bugs to make a good “final version” for Snow Leopard.


Tried it, no difference at all.
What’s happening to Audacity, has it gone bilingual?
This build is in Spanish which I know but it makes me feel schizo. I prefer to have everything in English so as not to be forced to switch to a different language.

A pity!

The build is language-independent. If you have the Mac running in Spanish then Audacity defaults to Spanish.

You can choose the language you want at Audacity > Preferences…, “Interface” section.


My Mac is not running in Spanish; I don’t understand why this build opened in Spanish.
In any case, I don’t see your comment on “Tried it, no difference at all.”
Where do I go from here?

Nothing can be fixed until we can reproduce the problem. No-one else has the problem that you are experiencing and no-one here has a working installation of Snow Leopard. Apple dropped support for Snow Leopard over two years ago. And even so, no-one reported this problem when Snow Leopard was in Apple support.

Can you still run Mavericks on the external drive you mentioned? Does Mavericks exhibit the problem?

Also you can look at http://www.audacityteam.org/download/legacy-mac/. There is an older 2.0.6 version of Audacity you can try, or older 2.0.x versions if you click the GoogleCode link farther down that page.


I’ve had this error with Audacity too, under Snow. It’s been a while and I can’t remember exactly how I solved this. And it probably was an older Audacity version too.

Did you delete some languages from your Mac?
Did you try resetting system language to English in System Prefrences-> Language & Text?
Did you try SL-NTFS (a Windows utility enabling use of NTFS disks) or anything likewise?

BTW I don’t think this is an Audacity error, as it seems to happen to a lot of applications in rare cases.

Haven’t deleted any language.

Language & Text in System Preferences is set to English.
Didn’t try SL-NTFS
This issye happened only in Audaccity.


The problem doesn’t happen in Mavericks, i wonder why. The computer is one; Mavericks is installed on an external HD but the Mac is controlling it. Baffling since the headset has no driver; it’s a plug and play set.

Thank you Gale

Sometimes Core Audio prefs get corrupt and you need to trash them. Give this a try:

  • Go to ~/Library/Preferences/Audio
  • Delete com.apple.audio.DeviceSettings.plist
  • Delete com.apple.audio.SystemSettings.plist
  • Restart your Mac

There is no Audio folder in ~/Library/Preferences.
Do you mean /Library/Preferences?
I find com.apple.audio.DeviceSettings.plist & com.apple.audio.SystemSettings.plist in /Library/Preferences/Audio

Yes. Sorry, brainfart.