Out of nowhere, can't record anything!

Hey everyone! I thank you in advance for any help.

I have been using Audacity with my Windows 10 laptop for months with no issues… until now.
I have been recording vocals and guitar (thru effect rack) thru Lexicon Alpha, with settings…
Windows WASAPI
Lexicon Alpha In/out
Stereo and mono recording (depending on vocals or guitar)
Speakers (2-USB Audio Device)

I have made sure Audacity and the Lexicon have been updated. I also know the Lexicon is working with the wiring because the connection shows up and I here the mic or guitar audio thru my stereo which is thru the lexicon.
Trying deferent things, I keep getting code 9996 or 9999.

I need to try to fix this ASAP because I am doing songs for a church’s on line service.
Thanks again!

For error 9996, check your USB leads, try a different USB socket, try changing the USB lead.
This error code indicates that the device isn’t working, which is most likely (though not always) a connection problem.

Error 9999 is a general error indicating that “something is wrong”.

Thanks Steve. I have tried other USB inputs as well as trying stereo in on the lexicon and trying the mono (a different input to the lexi) and no of it works to record. But I know sound is getting thru the lexi because it is coming thru the headphone out.
I don’t have another interface to test :frowning:

I turned off everything, used another USB in, and it IS working! You must have the special touch!

Just when I thought It was good… I recorded in MME based on videos (although I had always used WASABI in the past). But when I recorded another track, it changed the pitch and speed of the track.
Then I tried again with a new track using WASABI like I used to, a new error of 9997 invalid sample rate popped up. ???
This is crazy. I wish I could figure this out myself but I have a lot more trouble learning things since I was diagnoses with astrocytoma (brain cancer).
Again, I appreciate any help in advance.

You need to check in the Windows Sound control panel and ensure that the sample rate for your audio device is the same in both the Recording tab and the Playback tab.
Both of these sampling rates should match the “Project Rate” in Audacity.
The “Project Rate” is near the bottom left corner of the main Audacity window.

I have tried everything with no success. If I uninstall and then re-install Audacity, will I lose my files (recordings)?

Did you find the sample rate settings in the Windows Sound control panel? What are they set to?

Inside the Lexicon settings, it was 44100, but inside the speakers setting, it was 48000.
I know my guitar pedal (Fractal AX8) puts out 48000 but my mic (thru a TC-Helicon pedal) is 44100.
So should I change the Lexicon setting to 48000 and then make sure I set all tracks on Audacity to 48000?
Thanks Again!!

This is happening to me as well. I was checking the sample rates and sometimes it fixes it but sometimes it happens when I haven’t changed a thing! Windows 10 Aud 2.3.3