Openvino can't be activated in Audacity 3.5.0 with win 10

Thank you @mac-christian for explaining that – make sense.

@Helmut1, What happens if you copy & paste mod-openvino.dll into C:\Program Files\Audacity folder, and then drag that into DependenciesGUI? Does it show any of those DLL dependencies as resolved?

@Helmut1,

And here’s something that maybe you can try:

  1. Download https://github.com/KhronosGroup/OpenCL-SDK/releases/download/v2023.04.17/OpenCL-SDK-v2023.04.17-Win-x64.zip

  2. Inside this zip in bin folder you’ll find OpenCL.dll. Can you drop this into your Audacity folder (same one that has Audacity.exe, etc.)?

  3. Try changing module to enabled, restart Audacity.

And this is because I see OpenCL.dll is not being found in Windows system folder, in your screenshots (still not sure why it’s not resolving the other DLL’s though)

Hey Ryan, it works!!! :star_struck:
Many thanks!
Schould I leave the copied DLL’s where they are?

That’s great news! I guess we need to start packaging OpenCL.dll into our installer to avoid other potential users hitting this. Thank you for your help!

You can delete the mod-openvino.dll that you copied into your Audacity folder if you want, but it’s not hurting anything…

Great Help :kissing_heart:

I got the same issue, running Audacity 3.5.1 on Win 10. It worked fine in Audacity version 3.4.2, but upgrading to 3.5.1 appears to have broke something. Copying both mod-openvino.dll and OpenCL.dll into “C:\Program Files\Audacity” did not fix it.

Thus, I have attached a screen shot of the Dependencies output. It shows that lib-effects.dll and lib-mixer.dll are missing. However, Process Explorer does show both lib-effects.dll and lib-mixer.dll there when running audacity.

As a result of this, I reinstalled 3.4.2, and all is well, once again. If there’s something that you would like for me to try, let me know. Otherwise, I’ll just stay on 3.4.2.

Hi @dchester,

If you upgrade Audacity to 3.5.1, then you need to also update the plugins to the 3.5.1-compatible version, found here: Release v3.5.1-R2.1 · intel/openvino-plugins-ai-audacity · GitHub

Thanks,
Ryan

Hi guys I got the same issue - 'Unable to load the “mod-openvino” module error.

I followed the advice given above and sure enough the Dependencies report shows OpenCL.dll as the issue. There is definitely a file with that name in C:\Windows\System23 (though it’s dated 14/11/2016). So I downloaded the version of OpenCL.dll as suggested above and copied it to the Audacity installation folder but now when I try to activate the OpenVINO module and relaunch Audacity I get a crash report error pop-up which sadly fails to send the crash report in any case!.

I have included the contents of the crash report below.

The only way I can get back into Audacity is to remove/rename the OpenCL.dll file in the Audacity installation folder (and it once again reports that is cannot load the mod-openvino modules again, and thus disables it…

Any help you can offer would be gratefully received.

Many thanks,
Tony

Machine config:

Device name CAD03
Full device name CAD03.XXXXXXXXXXX.co.uk
Processor Intel(R) Xeon(R) CPU X5650 @ 2.67GHz 2.66 GHz
Installed RAM 48.0 GB
Device ID BDB8FF2E-18F0-4C1D-A094-032767AD383C
Product ID 00330-71232-22167-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Edition Windows 10 Pro
Version 22H2
Installed on ‎10/‎12/‎2020
OS build 19045.4291
Experience Windows Feature Experience Pack 1000.19056.1000.0

Crash report contents (was too many characters to just paste in this comment):
Audacity Crash Report Text Contents.txt (58.2 KB)

P.S. I forgot to mention I’m using Audacity 3.5.1 and OpenVINO v3.5.1-R2.1. I have also tried the uninstall procedure listed above, including removing the Audacity folders. I’ve also tried Installing Audacity v3.5.0 and the corresponding version of OpenVINO to the exact same outcome. Please helllllppp!

This topic was automatically closed after 30 days. New replies are no longer allowed.