Opening Audacity sets speaker output to 0

Every time I open Audacity, my computer speaker setting changes to zero and I can’t find any setting to adjust this. I edited the audacity.cfg file to empty, set the output to 50, exited Audacity and opened it again and it still changes to 0. Actually, sometimes it does NOT reset to 0 so I don’t know what to do…any help will be appreciated.

I have Windows 7 on a Dell XPS Laptop and am using Audacity version 2.0.5.



Do you use Skype? Do you leave it running in the background? Try closing it all the way. If you set the Audacity playback control (Speaker Symbol in the Control Bar) to half-way, does it stay there if you close and reopen Audacity? If you watch the Windows volume control when you change the Audacity speaker volume, does it change in step?

If they seem to be divorced or schizophrenic, then there may be something else in your system trying to set volume. Do you have a USB sound device like an active mixer?


Hello Koz!
I turned Skype off and it didn’t help. When I change the Audacity speaker output slider, the Windows mixer slider changes as well. I set the speaker slider to 50 and closed Audacity. When I open it again, the Audacity speaker icon appears with new volume marks - either zero or something other than 50. 21 this time. Zero the next time. Then 21 again. Then zero. Then zero. This is all without opening a file - just the program. Once I open a project, sometimes the level changes again and sometimes it doesn’t. I have an effects pedal that works well for both input and output and it doesn’t matter if it’s connected or not. What do you think? I mean, it would be nice to not have to set the volume level every time, know what I mean?


It would be, yes. We need to wait for someone who knows more about the Windows internals than I do.
I have to ask if you restarted the machine.


Yes - restarted many times but this has been an issue since I first started using Audacity. At first it seemed evil but when I could get my sound back by turning up the volume it was downgraded to irritating.

What was your first version of Audacity, or have you only used 2.0.5?

What is the exact name of the output device in the second box of Device Toolbar ?

What is the exact XPS number of the Dell? The most likely explanation is that you have bad (or incorrect) audio drivers for your built-in sound device (assuming that is what you are using).

Have you changed the audio drivers for the machine, for example, installed generic Realtek drivers? Might there have been a bad Windows Update for these drivers?

You can read more about “audio driver issues” here: .


Hi Gale,

I don’t remember the version I first used - is there a way to find that out? It was always a straightforward download for it and all the updates.

I read the audio driver issues and just checked Windows Driver Update and the Dell site and all of my drivers are up to date. I fiddled with the MAXX Sound program and the changes to that had no effect on the problem.


Dell System XPS L502X
Operating System Microsoft Windows 7 Home Premium Edition (64-bit)

Manufacturer Intel(R) Core™ i7-2670QM CPU @ 2.20GHz (CPU:0)

Sound Devices Realtek High Definition Audio Intel(R) Display Audio

Not really, how long have you been using Audacity?

OK so do you have “Realtek ALC665 Audio Driver” version “,A04” from ?

Can you say more about what that program is? It is still possible some audio program you have is interfering with the sound device.


The program is Dell Audio by Realtek - HD Audio Manager. I downloaded and installed the ALC665 Audio Driver and the speakers still went to 0 but sometimes they would go to 21 so once they go to 0 they aren’t stuck there!

So how long have you been using Audacity (roughly)?

Editing audacity.cfg to “empty” won’t set it to factory-shipped defaults if you ever used a 1.2 or earlier version of Audacity.

Quit Audacity, select and delete the entire contents of audacity.cfg then type or paste in the following at the top:


Or reinstall Audacity with “Reset Preferences” checked half way through the installer.

If the problem persists, try changing to “Windows DirectSound” host in Device Toolbar .

If it was me and this annoyed me enough, I would probably add a keyboard shortcut for the “Adjust Output Gain” command, then create an AutoHotkey script (or similar) that launched Audacity, waited for the “Audacity” title bar, then called the shortcut for “Adjust Output Gain”, entered your desired value and pressed ENTER.


I tried everything and to no avail. I give up and will wait until someone who has solved this problem shows up. Until then I will click the speaker slider back to 50 for every file. Not a big deal but it is irritating.

Thanks for your input and I hope you never get this problem!


If you have only been using Audacity a short while you could try 2.0.3 or 2.0.1, at least to confirm if the problem exists there or not: .

I would not go back to an older version than those.