opening aiff files produces noise[WORKAROUND]

I have a couple of aiff files (finder says they are AIFF-C audio) that produce noise when I open them with audacity. One is a constant loud buzzing, the other is mostly silence punctuated by loud buzzing. Both files play fine in iTunes; both are recordings of phone calls off skype - I don’t recall what I used to record them, possibly wiretap (they are about five years old).

Any suggestions? I could export them from iTunes in a different format but I don’t know how - perhaps you can’t any more?

I installed Audacity 2.0.3 from the dmg and I’m using 10.7.5

Any suggestions?


The AIFF-C (“compressed”) container format can contain many different types of compression.

It seems these have a type of compression not recognized by Audacity.

Try converting them to WAV or uncompressed AIFF with Max:

Alternatively, since they play correctly in iTunes, use iTunes to convert them to WAV or MP3 (use the highest quality MP3 setting).

– Bill

Well, I thought about converting with iTunes, but I can’t find an “export” function. But I’ll try Max, thanks.

In iTunes:
Go to Preferences, the General section, then click the “Import Options” button. Choose the encoder and options (if available). Close preferences.
Click on the track you want to convert. Click File > Create New Version > Create … Version (it will indicate the file type you chose in Import Options).
A new track is created.
Find that new track in your iTunes library and move it where you want.

– Bill

Thanks Bill, both answers do what’s needed!


Since iTunes can open these files it’s quite likely Audacity could if its QuickTime importer was able to get to them, but I suspect the standard WAV/AIFF importer called “libsndfile” is opening them even though it doesn’t support the format that is in them. You could look at Help > Show Log… to see what is actually happening.

If you come across any more files like that you could try a similar trick mentioned here if you wanted to. In the Extended Import Preferences create a rule for *.AIFF (or *.AIFC if the files have that extension), drag the QuickTime importer to the top of the list, then uncheck the “Attempt to use…” box and click OK.