Only microphone as recording device on W10

I am using Audacity 2.1.2. I just upgraded it after upgrading to Windows 10.

I have just upgraded to Windows 10 and I had some problems with the VIA audio chipset on the integrated soundcard for my Asus G75VW laptop. It has 2.1 sound and the recommended drivers sounded horrible as there were no low frequencies at all. I fund on a forum that the drivers for W8.1 worked and they do.

I’ve had the problem before of no audio mix to record, so I right clicked on the speaker and went to the recording devices tab. Right clicking shows that show disabled and disconnected devices are both already ticked, but there is only a microphone there.

Refreshing devices in device manager and rebooting have had no effect. Might downloading the nightly build help, or is there some more fundamental problem?

I had a program for recording the screen with sound to make training videos, that used a software audio card and that has gone as a playback/recording device as well.

Thanks for any help anyone can give.

According to your laptop does not support Windows 10 so it is no surprise the audio did not work properly. According to that link the latest official audio drivers are for Windows 8.

You can try recording computer playback with the Windows WASAPI host in Audacity’s Device Toolbar. See this link:


Thank you Gale, but where on that page does it say it does not support Windows 10?

Microsoft compatibility advisor said it works fine and indeed it is working fine apart from the audio. A search reveals that it is a common problem caused by VIA not being in any hurry to support their past customers.

That is why I am wondering if this is down to VIA’s poor drivers, or something else in W10 that perhaps I do not know about?

Thank you for your help though.

Because according to that page there are no drivers of any kind for it for later than Windows 8.1 (and even that only has a few drivers).

Evidently that laptop was released with Windows 7 and then Windows 8, which seems to be confirmed by recent reviews I have looked at.

So because there are no ASUS-supplied VIA Windows 10 audio drivers for it, I assume you were previously using Microsoft generic Windows 10 audio drivers for it. Windows will probably see those as “compatible”, but that won’t necessarily mean you will have good audio playback or recording or a full range of audio inputs with those drivers. The same goes for the ASUS-supplied Windows 8 audio drivers, but you “may” have more success with those.


or it could just be the page has not been updated.

Both of these show how to get the audio working again and say that it is the only problem with Windows 10. Sadly neither of them restore the stereo audio mix though. Remember that I ran Microsoft’s own comparability wizard several times over the last year or so and it has always said that the computer IS compatible, and so do the searches on the internet. Indeed that is what I am using now to post this. It all seems to be working fine, except for the inability to record audio. Even the playback is beautiful and stunning for a laptop. The latest drivers actually sound better than ever, but I will have to try the advice given of using the Windows 7 drivers and not updating them that I have just discovered as a possible work-around. Hopefully that will restore the stereo audio mix… Thankfully I have saved all the installation files I’ve ever used, so I actually have a version of the Windows 7 drivers, just possibly not the later Windows 7 drivers.

Thank you for your time and help.

Have you tried Windows WASAPI loopback recording with the drivers you have now, if they otherwise sound good?


OK, finally got it to work, but it is a kludge.

First you will need to download the last drivers I can find that will work with Audacity and still give you 5.1 sound on your Asus G75VW notebook. The last drivers I have found that work are VIA You will also need to download the new Microsoft “patch” called “Show or hide updates troubleshooter package” (KB3073930).

I used Advanced Uninstaller Pro (free version) to uninstall EVERYTHING from the chipmaker “VIA”. Reboot and immediately run the MS hide updates. Hide all updates that are from “VIA”.

Immediately install the old Asus VIA drivers Reboot and right-click on the little speaker icon on the taskbar and set up the 5.1 audio. Do the usual things to get “audio mix” to show up as a recording device. If audio mix doesn’t show up, uncheck the boxes to show hidden and disabled devices on the recording devices tab and reboot again.

Around now, you will loose all audio again and all recording ability.

Go to device manager and sound, video and game controllers. Right click on VIA Audio and left-click on properties. Go to the driver tab and click on roll back driver if it is not grayed out.

Run the MS hide updates tool again and hide the updates it finds for VIA again.

Reboot and hopefully this time your old drivers will stick and you can have your 5.1 audio back and by right-clicking on the littler speaker and clicking on recording devices the re-enabling show hidden and disabled devices, you will get audio mix back, so you can use Audacity again. This has been working for me now for about a week and has survived updates and reboots.

The latest drivers from VIA will work on W10, but you get lovely sound, but not 5.1 audio. Also there is no audio mix with them.

Thanks for posting your information, Doghouse.