only line entry on with US-122

I just installed audacity 2.0.5 on my new computer (win 7)
I use a tascam US-122L and I don’t get the mic entry for it only the line entry
what can I do to get it?

The Tascam US-122L is a “2 channel” device.
Audacity does not have “channel mapping” so when using a 2 channel device, Audacity will treat “channel 1” of the device as the “Left” or “Mono” channel and will treat “channel 2” as the “Right” channel.

This means that if you set Audacity to record “1 (mono) channel” (using the device toolbar), Audacity will record “Channel 1” of the Tascam (the left channel). If you set Audacity to record “2 (stereo) channels”, Audacity will record “Channel 1” (the left Tascam input) as the left channel and “Channel 2” (the right Tascam input) as the right channel.

If you wish to record only Channel 2 of the Tascam, you will need to set Audacity to record “2 (stereo) channels”, then split the stereo track into 2 mono tracks and delete the unwanted channel. See here for how to split stereo tracks to mono:

Note that on Windows you may also need to set the Tascam to record 2 channels (stereo) in the Windows Sound Control Panel.

Hi Steve thx for the reply
I have no pb to reccord,
my pb is on my last computer I had for my tascam 2 choices in audacity : “line” and “mic”,
now I have only “line” and the result is of course terrible (numerised sound)…

What does “pb” mean?

sorry… it means “problem”… :wink:

I find that surprising. Usually USB devices only have one option, with the selection between Mic / Line being made on the device itself.

If you are sure that there should be other options for the Tascam, look in the Windows Sound Control Panel to see if any of the options are disabled or hidden.

Ok I checked on my old computer and you’re right there was then only “TASCAM” with no precision…
I never had problem with it
The thing is on the new computer the sound is OK and then sunddenly becomes “numerised”…
Is there any known incompatibility between with Tascam US 122L and Audacity on windows 7?
I checked the tascam on qbase and it works OK…

I tried to change the driver… but it’s still the same: Reccords OK for 3/5 minutes, then numerised sound and then jumps!
(works all right on the old computer -XP- and on qbase (but I prefere the sound quality on audacity…)
Every informations wellcome!

I don’t know what you mean by “numerised”. Could you try to describe that, or post a short example. See here how to post a short WAV sample:

like this!

argh, it just made the same on qbase… so not an audacity pb… maybe with win 7?
thx for beeing there any way!!!

Check that you have the most recent drivers installed:
(read the “release note” document before installing the drivers)

that’s what I’ve done (I tried the 2 different drivers proposed on the site)
I suspect now maybe a electrical problem on the usb plug…
I’ll come back here if I find some kind of Windows7 or audacity problem
thx a lot!

Please let us know if you discover the cause and/or solution, whatever it happens to be. It could help other Audacity users if they encounter the same problem.
Good luck.

Also make sure you connect to an empty USB hub on the computer.

Windows 7 has sample rate and sample format settings. When using external devices you need to be sure Windows settings don’t conflict with Audacity settings. Try Host: Windows DirectSound in Device Toolbar . Set Project Rate bottom left to 48000 Hz. Choose Edit > Preferences, choose “Quality” and set “Default Sample Format” to 24-bit.

Then right-click over the speaker icon by the system clock, and choose “Recording Devices”. Right-click over the Tascam and choose “Properties”. Then click the “Advanced” tab and put a checkmark (tick) in both Exclusive Mode boxes. Click OK and OK and restart Audacity. Then even if “Default Format” on that “Advanced” tab conflicts with your Audacity settings, Audacity should ignore the Windows Default Format and request the rate and bit depth directly from the device.