One channel on one PC, two channels on another...

Hi all

Long-time Audacity fan here - in over ten years of happy use I’ve come up against my FIRST snag! Forever grateful to everyone who takes part in the making of this awesome piece of software :slight_smile:

Now for a really amateur hour question - I confess I don’t know a LOT about the technical side of sound recording and Audacity has been a great pal in making sure I can wing it to date… but this time I’m at a loss.

I am using a Behringer UMC404HD USB interface. On one computer, it works as intended - channels 1 and 2 record into the L and R channels of a stereo track respectively. However, for boring work related reasons I need to get the same thing working on a second computer. On this second PC, only channel 1 records into both the left and right tracks of a stereo track. Channel 2 can be heard just fine on the monitor, and indeed visually shows a signal on the computer in question in the Win sound devices list and on other software (so the signal from channel 2 is definitely reaching the computer) but Audacity just won’t hear it. It’s not that it’s only recording one channel - it’s placing channel 1 into both tracks.

I have scoured every setting I can find between the two computers and cannot work out what I’m doing it wrong - everything seems to be configured absolutely identically in Preferences and in the sound device settings. Both computers are running Audacity 2.4.2 on Windows 10.

Does anyone have any tips? Sorry for the dumb question! I’m sure I’m missing something crazy obvious, I just can’t figure out what it is. :slight_smile:

There’s a setting in the Windows Sound Control panel (where the recording devices are listed). Unfortunately Microsoft keep moving things around and hiding things, but you’re looking for something like this:

Select the device that corresponds to the Behringer’s channels 1&2 and select “Properties > Advanced”. Ensure that the device is set to “stereo”.

No such luck I’m afraid :frowning: unless I’m missing something in your response, I don’t see any mono vs stereo option in the Advanced tab (or any other tab in the Properties dialog).

You found it - I was referring to the bit that shows “2 channel, 24-bit, 48000 Hz (Studio Quality)”.
“2 channels” = “stereo”, so that’s not the problem.

What are you recording? (What is plugged into the UMC404HD?)

How, precisely, did you determine that “only channel 1 records into both the left and right”?

Channel 1 is an XLR mic, channel 2 is an XLR cable connected to a PC out of the headphone jack (I am trying to record audio narration whilst also capturing game audio as I play). The devices, however, don’t seem to be a factor as if I swap them over the PC sound records on both left and right instead and it’s the mic sound that vanishes on the recording (despite both still showing signals in the Win sound control panel).

Re: left and right both taking channel 1, hopefully this visual will show why I’m making that assumption.

On my old PC I get the mic audio on the Left (top) and the game audio on the bottom (right) as intended:
On my new PC however the mic audio records into both channels in Audacity:
I thought initially the new PC just didn’t support input from two channels, but it’s definitely receiving the channel 2 input because when I turn off the mic in channel 1 and just play audio through channel 2, it still registers a sound in control panel (in this screenshot nothing is being played into channel 1):
Super stumped by this whole thing! Thanks for your help.

What happens if you plug your mic into channel 2, nothing into channel 1, and then record a stereo track?

I assume that you’ve checked that the “mono” button does not affect the USB output?