Not hearing sound when recording/listening through Turntable

Hello, Im sure its been asked plenty but I have just started using a new computer (Windows 7) and installed latest Audacity (2.1.1) and am attempting to record or at least just listen to vinyl records on non-USB turntable. I have USB connected speakers and have 3.5mm jack going into computer(tried all jacks: line in, headphones, mic). On audacity I see green lines on the recording level up top from audio playing but cannot hear anything, even humming sound from non-grounded turntable.

On older computer I was using I had older version of Audacity and played just fine. Does this have something to do with updated features on current audacity and/or new computer? All sound devices have been checked on computer as well. (Playback devices/recording devices).

NOTE: Under audacity FAQ it mentions standalone turntable needs a external interface to pass through phono but as stated older computer and older audacity worked just fine without.


external interface

If your turntable is part of an entertainment system and the connection is from Line-Out RCAs, then no, you’re good to go. Connect to Line-In (blue??).

If it’s a “real” turntable with the little thin black ground wire, then yes, it’s highly recommended to use a Phono Preamp. It doesn’t have to be crazy. The Behringer UFO-202 works fine and even has a little place for the ground wire.

The sound from a turntable isn’t “flat.” It’s intentionally distorted with the RIAA curve to make all the bass tones fit in the groove. It’s good to take that distortion out before you listen. Maybe the music is a lot higher quality than you think it is.

That may solve your other problems as well. That will appear as a simple audio interface to the computer when you plug the USB connector in. Restart Audacity, switch to the Behringer and go. Some Windows machines like to mess with the speaker feeds when you plug in USB systems. Change the speaker back to normal.

If all you have trouble doing is hearing the show, you can change that with the Audacity Device Toolbar. Tell it to play audio to the soundcard, whatever it’s called on your machine.

Device Toolbar Instructions

Also, Edit > Preferences > Recording > Playthrough (select)