Not able to record in Audacity

Hi there!
so for the last couple of days i haven’t been able to record anything on audacity. I use a USB-interface (steinberg UR22 MKII), i made sure that the in-and output are set up accordingly, I updated my drivers,made sure that the sample rate was at 44100 and updated to the latest version of Auadcity, and still nothing.
What’s strange is that when i play the instruments through the interface connected to my laptop, i can hear them, even when recording, but Audacity simply does not record it.
Does anyone know what I could do to fix this??? I’d be forever gratefull
thanks :slight_smile:

Make sure Audacity has permission to use the microphone: Turn on app permissions for your microphone in Windows 10 - Microsoft Support

Also check these steinberg UR22 MKII related forum issues:

  1. Audacity and Steinberg UR22 mkII Microphone Issue
  2. Mic not working UR22MKII [SOLVED]

thank you so much! installing the new driver solved the problem! :slight_smile:
only now when i record it also records the entirety of all pre-recorded tracks onto the new empty track, any idea how to fix this?

i should add to this that i have MME set as the host and that both my in and output are the line from the UR22

Typically this is solved by using headphones that seal around the ear so that the microphone can’t pick it up. :wink:

Hahah, I used headphones! And also when i turned the knob all the way to input instead of DAW, so no sound would play, it would still record the rest of the song.

You should have Listen to this device=OFF, and Transport Options > Software Playthrough=OFF, > Overdub=ON.

What happens if you set Audacity’s playback device to the PC headphone jack?

You can try WASAPI but make sure you are NOT using a loopback device.

When i select the built-in headphone port as an output Audacity doesnt record the rest, just the track i am trying to record.Where can i turn of the Listen to this device option? can’t seem to find it :frowning:
and thank you so much for answering all my questions!

[u]Listen To This Device[/u] is a Windows setting. [Edited to correct URL]

[u]Software Playthrough[/u] is a “similar” Audacity setting.

i should add to this that i have MME set as the host and that both my in and output are the line from the UR22

The newest host/protocol is WASAPI and MME is the oldest. They all should work but if one doesn’t work you can try the others.

The USB device should be selected as your Recording Device, and also as your Playback Device if that’s where you’ve got your headphones plugged-in. (The “Playback Device” is also your “Monitoring Device”.) But with WASAPI you’ll also see the USB device with “loopback”. Do NOT select loopback as your recording device… That records the output from the device (which is useful if you are recording streaming audio, where there’s no analog-input to your soundcard/interface).

i followed all the advice ypu guys kindly gave me but still audacity won’t record just the instrument i’m playing, rather the entirety of it. pretty weird…

I’m probably missing something obvious. I think it is time for someone else to step in. In the meantime, perhaps you will want to post some illustrative screen shots.

Hi. I am not sure that this will solve the issue but you can try.

The Steinberg driver will provide you an option to Enable Loopback; You can check if that option is enabled in your system.
Steinberg USB Driver.png

On your Mac, choose Apple menu > System Preferences then click Security & Privacy in the left-hand menu and the click the Privacy tab. Click Microphone in the left-hand menu. Select the checkbox next to an application (Audacity) to allow it to access the microphone. It should Work I think.

or maybe not, since:

  1. This is the Windows forum board, not MacOS.
  2. “Microphone permissions” was suggested in the very first reply to this question: Not able to record in Audacity - #2 by jademan