Noise Removal

I cannot get the Noise Removal options to work. I am following the directions by highlighting a section to get the noise profile and then select all but then the buttons to finish the noise removal process will not highlight. What should I do?

I’m guessing from thousands of miles away. Highlight the “room tone” segment and get the noise profile. Then highlight the portion of the song you want to process. Press go. Try manually selecting a small portion instead of Select All.

Is there anything magic about your song? Did you import an MP3 or a WAV file and was it in a format that Audacity recognizes? Audacity will try to mount and play a song even though it doesn’t really know what’s going on. This leads to some amusing propblems and failures downstream from the real problem.

Are you in mono or stereo? Multiple tracks?

If Audacity has to go through extensive conversions in addition to effects application, sometimes it doesn’t go so well.


This is not a song, I have uploaded a cassette tape into the Audacity program of a church sermon. I am then trying to take out the static noise in the background. The options on the Noise Removal feature will not light up after I have gotten the noise profile and I am trying to finish the process.

Because you didn’t post in a platform or version segment of the forum, I have to start asking you what kind of computer and which version of Audacity.


Since this is a church office my computer is several computers put together so it is not an “official” kind of computer like Dell. The Audacity program is the 1.3 Beta or I believe is the newest version. And don’t get too technical, I am definitely not a computer wiz. The noise I am trying to remove is just simple static.

I don’t mean to sound snippy. I’m helping a bunch of people and I go as fast as I can.

So it’s a Windows machine (Platform) running the Beta 1.3 version of Audacity. Can you tell which Windows and the accurate Audacity version? Look in Help > About. Which Windows screen do you get when you turn the machine on?


I apologize for being such a dumb dumb and you are not being snippy, without turning off my computer I’m not sure, but it is the Windows version behind the new Vista version, if that helps, and the Audacity download name was Audacity 1.3.4 (beta) is all I know.


No bells or alarms so far. Can you describe the setup for Audacity to capture the tape? Tape player with a cable from Line-Out to the computer Line-In?

Has this ever worked?

Do any of the other Effect tools work, like Effect > Fade Out?


I have the same problem with NOISE REMOVAL. The OK and PREVIEW buttons are grayed out and cannot be clicked (like before you click GET NOISE PROFILE). It’s as if the “GET NOISE PROFILE” button is not working properly. I clicked the GET NOISE PROFILE button and the NOISE REMOVAL window goes away as normal, but when I select EFFECT > NOISE REMOVAL … again, the OK and PREVIEW buttons are still grayed out. I suspect it’s grayed out because Audacity is waiting for me to get the noise profile, but somehow it’s not accepting the noise profile I selected.

I have multiple versions of Audacity - 1.3.4-beta (Unicode), 1.3.3-beta (Unicode), 1.3.2-beta (Unicode), 1.2.1, and 1.2.6 from PortableApps. The audio files have various sources - mp3 from a Zoom H2 portable recorder, wav files ripped from an audio cd with a program called ExpressRip (the audiocd was from a DVD writer that burned a live recording directly to an audiocd), mp3 files from commercial CDs, mp2 files demuxed from a VCD with tmpgenc. I’ve even tested by recording a few seconds with Audacity itself and tested the Noise Removal effect on the recording without saving it first. There’s no difference. I suspect, the problem is not with the sound files (especially considering the last one, audio recording from within Audacity itself), because they all play fine, and there are no other problems with them, other than on Noise Removal in Audacity.

Perhaps there are some settings in Audacity that I may have accidentally changed without noticing, or my computer config may have changed (as in moving/deleting folders, or adding/removing audio/video codecs).

I had been using Audacity for a very long time (a few years). The Noise Removal initially worked without problem, on all the versions. I know I’m using it correctly because I’ve been using this Noise Removal effect on a couple of hundred files over the past year. About half a year ago, this problem appeared on the 1.3.2 version. But it still worked on 1.3.3 and 1.3.4. However, the problem has now also spread to the 1.3.3 and 1.3.4 versions, as of last week. So I’m forced to go back to the 1.2.6 and 1.2.1 versions (both still works), which is a shame because the 1.3.3 and 1.3.4 versions has much improved features.

I always get the zip version of Audacity that does not require an installer (because I have a couple of PCs, and it’s much easier to just copy folders than to run the installer for every program on every computer). So far the problem has affected one computer only. Unfortunately, it’s my main one where I do all my audio file processing work on.

I believe that by default all 1.3.x versions will put their configuration files in the same place, thus overwriting each others configuration file. For this reason it is probably better not to have the multiple versions of 1.3 on the same machine (unless you configure them to use different configuration files). This may well explain why your other 1.3 versions have “caught” the same ailment from each other.

You can safely delete the configuration file and it will “reset” Audacity to a fresh install.

The default location of the configuration file is:

  • Windows:
    Documents and SettingsApplication DataAudacityaudacity.cfg

  • OS X:
    ~/Library/Application Support/audacity/audacity.cfg

  • Linux:

Hey, thanks a lot Steve. That solved it!