Noise Reduction/Removal

The Paul-L De-Clicker plugin* does do a good job , but takes its time. With the settings shown below the processing time is approximately three times the play back time …

[ * Audacity does not come with Paul-L’s deClicker installed , you can get a copy of it from here : the “Declicker.ny” file at the bottom of the post . Put a copy of that “Declicker.ny” file into Audacity’s plugins folder , then it can be included in Audacity’s “Effect” list via “manage” at the top of the effect list ].

And you won’t need some of those corrections if it turns out there’s something you can do to the physical studio to get rid of that 90Hz tone. That will speed things up.


Thanks, guys!!

My friend said he can rig me a shock mount, much like the homemade one you described, Koz. I’m sure you’re right that something is coming up through the table. Could be the A/C.

So Koz, in order to get my super quiet recordings up to ACX standards, I would run the Amplify effect approximately 3 times? That’s one thing that I haven’t been able to figure out – how do I know when the overall volume is within the submission requirements (where on the recording do I look to find that info)? I posted that question in another thread (technically that + how do I ensure the volume of all my chapters is consistent), but no one has bitten yet, and I’m trying to take advantage of your expertise while I have your attention :slight_smile: Your help is greatly appreciated.

And I wonder why my volume is so low in the first place. I record fairly close to the mic (3-4 inches). Is this as simple as turning up the gain when I record?


Shoot. OK, so in the mastering process, should I amplify first until I get to a submission-ready level, then perform the other steps? I did the process in the ACX -recommended order (Hi and Lo Pass filters, Normalize peaks, Equalize, Limit), but it was too quiet, so last, I amplified it. Well now the peaks are way above -6dB… :imp: Where did I go wrong?

Also, everyone who’s been contributing to this thread, I’m going to need your home addresses so I can send you a beer or something - I would truly be lost without your help! :wink:

Trebor, I just ran into a similar problem that you solved so nicely with the notch filter a few months ago – hoping you (or anyone!) can diagnose this one as well. Same situation - weird tone, noise reduction doesn’t fix it. I just recorded my first dual-narrator project, and we did it in the other narrator’s home studio. This same tone pops up every once in a while - I’m wondering if it happens when one of us accidentally steps on the headphones cord or bumps the mic in a certain way?? I’ve tried messing around with various frequencies to see if I can find the culprit, but to no avail. I’m using Windows 7 Home Premium, Audacity 2.1.0, .exe installer. Thank you!!

There is a fairly constant tone on that at 44Hz , but I can only just hear it , it’s visible on the spectrogram …

You could remove the 44Hz tone with a notch-filter , but I don’t think that tone is the intermittent noise you are hearing.

The conspicuous intermittent problem is excessive-sibilance : when the speaker says “realiZe” “childiSH.
The cure for excessive-sibilance is a de-esser plugin* , e.g. Paul-L’s De-esser.

There are also a few clicks, e.g in “they’re” , Paul-L’s De-clicker will get rid of those …

[ * Other free de-esser plugins are available which work in Audacity on Windows, e.g. Sibalance [sic] , SpitFish ]

Thanks so much!! Awesome, awesome, awesome. I will get those two plug-ins today and keep you posted as to how it goes. I’m a “clicker,” almost all the freaking time – I haven’t yet figured out how not to be so clicky. Most days I am; some days I sound crystal clear. Have high hopes for that De-Clicker!!

Turns out the clear days are when you’re slightly buzzed on Chablis. Even worse would be the invitation from the local school for a lecture about your announcing secrets.

Warm lemon and honey?

No, more like Domaine Louis Moreau in a large glass.


LOL thanks Koz. But also, oh no! There is definitely a tone that keeps popping up - a few times now it’s responded to the 44Hz notch filter, but there are some long sections where it’s not (I’ve played around with all the Hertzes [that’s correct; I promise :stuck_out_tongue:] from 40-60 and nothing is doing the trick. Help please!! You guys are the best.

ARGHHHHH so frustrating because it seems to go in and out… hoping there’s a quick(ish) fix?? The attached sample is longer and (along with some fun mouth noise - you’re welcome) you can hear it getting more and less intense…

On that one the main culprit is 79Hz , (& harmonic at 158Hz ) …
Unidentified-Tone_CG wav  (182 04 KiB).png
The pitch is changing slightly with time : maybe a fan ?, or other electric-motor ,
( So it’s not mains hum, whose pitch is very constant ).
Notch-filters are only 100% effective when the pitch (frequency) is constant.

Your [female] voice doesn’t contain frequencies below 150Hz , so using the equalizer you could remove all content below 150Hz , which will remove the deep parts of the humm noise …

In addition you’d have to apply a notch-filter to remove the 158Hz tone.

Uh-oh – when I apply those two notch filters (79 and 158Hz), it almost entirely eliminates the hum, but it also eliminates the lovely resonance in my co-narrator’s voice (cf attached clip)… Any ideas?? Maybe the undiscerning audio book listener won’t notice the hum?! I’m freaking out a teensy bit, as re-recording the entire project really is not an option, and this tone shows up quite frequently. Is it possible there’s a separate fix I can apply to the hum when I’m speaking vs. when he’s speaking? Crazy tedious, but again, better than re-recording. Would it be helpful for me to upload (or PM) a longer sample - one that contains the hum throughout, plus both of our voices? Thanks so much.

I can’t hear any hum on the “before” on that one, when the man is speaking.
[ The equalization suggestion in my previous post could only work for a female voice ].

If you split your recording into two synchronised tracks : one with everything above 200Hz , the other with everything below 200Hz, then apply a dynamic-range-expander, ( e.g FLOORFISH ) , to the sub-200Hz track ,
that will selectively attenuate the bass [hum] when the man isn’t speaking . Then recombine the two tracks.

Hmmm. Yes… if I just split the track… :confused: How would I go about doing that?

BUT if you couldn’t hear the hum… and I also had someone else listen to one of the chapters where the hum is definitely there (I can see it on the sound meter and feel it vibrating my ear drum), and he didn’t notice anything wrong… would it be a fair assumption that your average audio book listener won’t be freaking out about it in the way that I am?

Maybe the undiscerning audio book listener won’t notice the hum?! …

They may not. But ACX will. Or the Robot will get there before human Quality Control.

We simulated what the robot is going to do with Will’s compilation testing tool called ACX Check (if I haven’t mentioned that already). It’s a plugin that appears under Analyze.

That may be the older one. The newer one is prettier, but says the same things. I gotta fix that one of these days.

ACX has a very simple weed-out process that catches ratty submissions. When you’re speaking, your peak sound values have to stay below -3dB, your volume or loudness has to be between -18dB and -23dB, and when you stop talking, what’s left (the background noise or Room Tone) has to settle below -60. If you do a very good quality job of announcing, you can crank out one of these compliant clips without a big deal, or your clip can be made complaint with a simple volume change. I, my very self, have done this, so I know it can be done. It’s not fantasy and it also happens to be broadcast standard.

Then it’s on to the human Quality Control. If you got past the Robot by applying legions of filters, effects, patches, modifications, and changes, you will most likely fail QC with “Excessive Processing” (he said, gazing up at the above thread’s list of notches and filters).

Without knowing any more about your setup than the amount of corrections it appears to require, I would think about changing it.

You can achieve the -3 thing with Normalize. I use -3.2 instead of -3 for safety. Conversion to MP3 later can mess with this setting.

– Select the whole clip or show by clicking just above MUTE.
– Effect > Normalize: [X]Remove DC, [X]Normalize to -3.2 > OK

Then Analyze > ACX Check and see what it says.


Thanks, Koz.

I want to make sure I’m understanding everything correctly. You ran the clip through ACX check and it failed based on the sound floor being above -60dB?

I’m actually pretty proud of my home studio setup, and consistently pass ACX’s checks with just a high- and low-pass filter :smiley: – the problem is that this project (~6 finished hours) has already been recorded in a different studio, over 100 miles from my house, and I’m just trying to salvage it. If I were to paste clean noise over all the dead space that currently has the hum, would that be a suitable fix?

If not, and I go the route Trebor recommended (splitting the track into two tracks - one above 200Hz and one below, etc.) - can one of you please break that process down into steps (as though you’re explaining it to a drunk kindergartener)? Y’all are my heroes. Seriously.

Also, Koz, in reference to your point about the -3 – you said you use Normalize to -3.2. I’ve been using the Hard Limiter at -3.2 and that seems to work. Would normalizing be better, and if so, why? Thanks! Also, happy new year!!

I’m just trying to salvage it.

I remember now. Sorry. This is me going in the corner, drinking tea and not “helping” any more.

Normalizing (and its cousin Amplify) just turn the volume up and down. They are not “processing” tools and after using them, you can come along later and put the volume right back where it was with no harm done. We can’t reverse processing tools like limiters, compressors and noise reduction (other than UNDO). This is where the sticklers will post that you can cause intentional damage with Amplify and you can remove battery damage with Normalize and that can’t be reversed. All true, but those are celebrity applications. In normal use for most people they just make the show louder and softer with slightly different philosophy between them.

Pasting The Blackness of Space Silence over all the hummy bits will trigger the “Overprocessing” rejection. You have to do an extraordinary amount of work without seeming as though you’re working hard. I’m a great fan of Noise Reduction over Noise Removal because in judicious, gentle amounts, Noise Reduction is effective and ACX can’t find it.

You are rescuing a show bordering on forensics. Not a job to be taken lightly [he said, backing out of the room].


I’ve been using the Hard Limiter at -3.2 and that seems to work.

Dueling posts.

I don’t know how Hard Limiter works. That’s one of the tools that got massaged over the last couple of Audacity versions.
The final arbiter is ACX Check, followed by listening to the work. That’s what’s going to happen after you submit.

Peaks may very well change when you create the MP3. That’s the reason for 3.2 instead of 3.0. If you shoot for -3.0 in the WAV master and the MP3 has any conversion error at all, you lose. -3.2 may not be enough, but it’s far better than shooting for the real thing.

One other note. ACX puts great stress on consistency throughout a reading and chapter to chapter. It should not be necessary to constantly adjust the radio in your car to hear the whole show. Back when I traveled more, I used to greatly enjoy the Sarah Vowel audiobook CDs.


Hmmmmmmm OK but it’s not the Black Silence of Space though; it’s room tone from that very studio (recorded at the very beginning of our session, without the hideous fan or me stepping on the headphone cords or the AC kicking on in the next room or whatever the hell that damned hum is). So that shouldn’t count as overprocessing, right??

And to your other point - when I try the noise reduction effect, it takes away the hum but totally distorts the voice… It’s so strange – there are entire chapters and minutes-long segments of chapters that have no awful hum at all, and then suddenly it’s back! And then just as quickly sometimes, it’s gone… Just trying to figure out the best thing to do to those hummy sections. You’re saying the room tone paste won’t cut it?