Noise introduced when exporting in Audacity

I had a question about something that I had noticed whenever I macro batched files in Audacity. I noticed that there would be some extra noise on the high end after batching. So I did a test and exported five seconds of silence that I generated in iZotope RX and looked at what the spectrogram showed. I created the test file as 16 bit 48k WAV since that’s mainly what I work with.



Can anybody tell me why it does this and how to mitigate it possibly? I’d like to use Audacity for some batch macroing for specific functions that I can’t do in other programs, but if every time I run it through a batch setting and it keeps introducing more noise each time then that will be a problem for me.
Thank you

Audacity adds the tiniest bit of shaped dither noise to exports. That’s on purpose and you might want to leave it there.

Audacity’s internal sound format is 32-bit Floating to avoid damage and distortions when you apply filters, effects and corrections. For one example, Audiobook Mastering frequently drives the show into overload in the middle of the process. But then it brings the volume back down again later and everything is happy. That process wouldn’t work in other sound formats. 32-Floating doesn’t overload.

But when you export in “normal” formats, there is the possibility of sound damage going to a lesser quality format, so Audacity adds very slight “fuzziness” so the errors don’t line up and become audible.

If you do your effects and then export 32-float, you don’t need that conversion dither and you can turn it off.

Preferences > Quality.

It depends on your final goal.


Scientists frequently run into problems with Audacity.

If it’s a choice between being scientifically perfectly accurate and sounding good, Audacity will pop for sounding good.

There’s tricks to this, too. If you pull a sound into Audacity and don’t change it, you don’t need the dither to export it back out again. So if all you’re doing is clip management, you may be able to turn it off.


I got it figured out. I changed the quality setting in preferences. Preferences > Quality > High-quality Conversion > Dither: set to None.

Yeah all I’m using is clip and file management. I have other programs for making the audio sound a certain way. So I’m using Audacity after I have already applied settings, effects, noise reduction, etc. I don’t need it to sound different than how I already exported my files from those programs.