Noise gate plugin download problem

Hi everyone, I would need the noise gate plugin, but the link here ( only downloads a .txt file. Any ideas how to proceed? Thanks a lot for your suggestions!

Sometimes macOS (or is it Safari?) insists on adding the “.txt” extension to some downloaded files. Is the filename “Noisegate.ny.txt”? If so, just delete the “.txt” at the end. MacOS may ask for confirmation. Then drag the renamed file to the Plug-Ins folder.
– Bill

Yes, the filename is “Noisegate.ny.txt” but the .txt at the end can’t be deleted. Dragging it into the Plug-Ins folder (with the .txt extension) didn’t work (well it did work but it doesn’t show in the Plug-Ins folder in audacity) :frowning:

You’ll need to right click on it then click “get info” and then from there, you can (about halfway down) edit the name and remove the .txt. Then hit enter and move it to the appropriate folder.

Thanks for the tip. I’ve never encountered this problem myself, so didn’t know about the Get Info trick.
– Bill

The Mac tries to identify the download and if it’s never met a Nyquist file before, it takes a quick look inside. If the work is mostly text (which it would be) it takes a wild stab at it, jams .txt on the end and calls it good. In fact, if you wanted to modify this nyquist file, or just look inside it, you might open it in TextEdit.

The only part of this that fails is in Audacity which is actually looking for a proper .ny file name.

I wonder if it’s possible to tell the Mac not to do that. Like Get INFO on a .ny file and tell it to open in TextEdit. Then it would have a registered APP and wouldn’t need to change the filename.

TextEdit can cause problems, here, too. It comes out of the tin trying to be a word processor. You can stop it by TextEdit > Preferences > Format > [X] Plain Text.

I wrote major pieces of my web page programming by hand in TextEdit.


I’ve never had problems like this and I wonder if it’s because my Get INFO looks like this…

Screen Shot 2019-03-04 at 19.37.44.png

So I tried this out on my Macbook Air which has downloaded nyquist files before.

Safari insisted on adding .txt. Firefox didn’t. Then I tried again in Safari, and again Safari added .txt. The Air is running Mohave.

Get Info on a nyquist file showed TextEdit as the default for “Open with”.

My conclusion: the culprit is Safari.

As for renaming, no problem. Doing the “rename click” on “Noisegate.ny.txt” highlights everything except “.txt” (making it appear that you can’t change the extension).
But you can highlight “.txt” or put your cursor at the end and delete “.txt” without a problem.
Years ago OS X would ask if you really wanted to change the extension, but no longer, it appears.

Exactly the same behaviour on my iMac running 10.13.4. Safari adds the “.txt” extension, Firefox doesn’t, and renaming is possible but subtly discouraged.

– Bill

Finder > Preferences ?

Screen Shot 2019-03-04 at 20.30.05.png

Perfect, it worked! Thanks very much!

macOS 10.13.4
So, yes, this explains why my Finder is not warning about changing the extension.
Note that I am not showing all extensions, but document extensions are still shown.
I still maintain that the culprit is Safari.

Your Finder prefs window appears to be from a much older OS.
– Bill

I’m having the same problem, tried Safari = .txt tried Firefox, gives options to open it with , lists about 50 of my macs options to open, same with google , what should I open with?

The current version of Audacity ships with Noise Gate included. There is no need to download or install it separately.

Hi Steve, thank you for that.

When you say ships with Audacity, what do you mean? :slight_smile:

I imagine you mean “comes with?” :slight_smile:
Heidi the Noob

Yes. The Noise Gate plug-in is included in the Audacity download and is installed automatically.
You can get the current version of Audacity from the main Audacity website: Audacity ® | Downloads