Noise Gate MIA?

I am using Audacity version 2.1.3 on my mid 2010 iMac running Sierra and enjoying the software. I used the .dmg installer when installing it. However, I need the noise gate and have downloaded it, paced it into the correct folder and tried activating it under the Add/Remove plug ins menu . It doesn’t show up and it’s ruining some otherwise great sounding recordings! Any suggestions? I even tried un installing it and wasn’t able to delete all the old plug ins. Is a complete reinstall a good idea? How can I get the noise gate to come in and save the game? Thanks in advance.

We need details …

Where did you download it from? Did you get it from ?
What is the file extension? Is the file named “noisegate.ny”
What do you mean by “the correct folder”? Did you put it in ~/Library/Application Support/audacity/Plug-ins ?

– Bill

The file is named correctly. However, my Mac can’t find the folder. Or there is nothing in it. How do I get to the folder? Entering the line in the Finder window reveals nothing there. Should I try a re install of the program? The last time it didn’t un install properly. Suggestions? Thanks in advance.

Note that the folder you want to find is

~/Library/Application Support/audacity


/Library/Application Support/audacity

Note the “~” character at the start - it’s important.

Click on the “Go” menu in the finder.

Select “Go to folder…”

In the dialog, type ~/Library/Application Support/audacity then click the “Go” button.

First you said “placed it into the correct folder” but then you said “my Mac can’t find the folder”. One of these statements is incorrect.

Re-installing will not help.

– Bill

I just found the folder and placed the Noisegate.ny item in the folder. I also went to the program and the add/remove plug ins menu and tried activating it without success. What is the precise line of code in the Menu? I have another noise gate item in there as well and need the exact line description to activate it correctly. Thanks Bill.

Click on the effect, then the “Enable” button, then OK.

– Bill

Got it. Thanks very much!

So I’ve done that–I see the effect I want in the “new” category, I click “enable” and it still doesn’t appear in the effects list.

Background–I recently updated from 2.1 to 2.2.0 and the noisegate, de esser, and de clicker disappeared from the menu. And I’ve spent the better part of an entire day trying to figure out what happened, what folder the .ny effects have to go into. And I can see them now (they’re in a lot of folders that I’ve tried); but they don’t appear in the effects pulldown menu even when I’ve enabled them.
I even downloaded 2.2.1 and tried it to see if the problem I was having was one that got fixed. One of the threads I had found about the noisegate was suspended and no reason given so I thought maybe it was being addressed with an update.

and Noise Gate is MIA, and so are de esser and de clicker.
Thanks in advance.

10.13.1 is my operating system, if that matters. (And I hope it doesn’t.) :smiley:

If you find and rename these Audacity files : “pluginregistry.cfg” & “pluginsettings.cfg”,
(to , say, “pluginregistry-old.cfg” “pluginsettings-old.cfg” )
new versions will be created when you restart Audacity, then hopefully you’ll get access to all the plugins.

[ If this doesn’t solve the problem, delete the new versions of those two Audacity files, then remove “-old” from the names of the old versions to get back to where you were ].

A finder search reveals that the only copies of those files are html and in the manual.
What does this mean? That my Audacity isn’t registered?

A Finder search may not look in your Library folder.

In the Finder, click on the Go menu and choose “Go to Folder”. In the dialog, type: ~/Library/Application Support/audacity. Note the “~” character at the beginning. This should reveal the audacity folder, and in that the pluginregistry.cfg and pluginsettings.cfg files. Also in that folder is the “Plug-ins” folder, which is where you should put the “Noisegate.ny” file.

– Bill

I was working with 2.1. and it didn’t work (the directions you supplied); so I moved that app and opened the new 2.2.0 and tried again. The effects and analysis (wave stats) now show up in the appropriate menus, but they’re greyed out and can’t be applied…NO WAIT A MINUTE–I’d not loaded a file and selected anything. AND when I did that, they turned black and WORKED. BRAVO!!!
Thank you SO MUCH. I’m back at it now with the latest version of Audacity! With about 6 hours of recording to do, and 12 hours of proofing and adjusting on the new book!