Noise automatically added when exporting to WAV

I need to manipulate and save sounds on 16 bit. I use WAV because it is lossless and I need to process the files in other software.

When exporting to WAV or amplifying a “silent” sound, a noise of typically 3 bits is automatically added by Audacity. I checked the file using a binary editor. This is an issue when you need to use a lossless codec :frowning: .

This behavior has been present for years, so it is not version dependent.

If it is not a bug, how to get rid of this ?


Strictly speaking, that is not always true.

If the sample rate is reduced, then the audio bandwidth is reduced, which could lose some high frequencies.

If the sample format is reduced, then there is a loss of precision, which appears as “quantization noise”.
Quantization noise is the effect of rounding high precision samples to lower precision.

Audacity works internally in 32-bit float, so when exporting as 16-bit there is a reduction in precision from 32-bit float to 16-bit.
As with most audio editors, Audacity tries to minimise the noise by a process called “dither”. See:
In short, “dither” replaces “quantization noise” with “dither noise”, which is usually less objectionable than quantization noise.

Dither may be turned off in preferences, though note that in most normal audio work, better sounding audio is achieved by using dither.
Note also that dither increases the dynamic range of 16-bit audio beyond the 90 dB that is available for undithered 16-bit.

Great, this is exactly what I was looking for.
What I am doing is closer to signal processing than sound editing which explain why I prefer not to have noise added when exporting.
Thank for your clear and detailed answer !

That makes sense. Audacity is optimised for “audio quality”, but that sometimes goes against the needs of “scientific” uses.