No Waves?

I am a user of a MacBook Pro (version 10.5.8) and I downloaded Audacity to make my own nightcored music. I currently have version 2.1.0. At first I did not understand how to get a track into Audacity, so I looked up a tutorial. It was the tutorial on the Audacity wiki, and it explained how to get the desired track into the program. I did as told, waited seven or eight seconds for it to load… and then I looked to see what to do next.
“Look at waves.”
I looked at my open Audacity window, and there were no waves. I tried expanding it. Still no waves. When I clicked the green triangle to play it, nothing played.
I’m confused as to why this happened. Please answer if you can ^^

If you don’t even see a flat line where the waves should be, are you importing an MP4, M4A or other QuickTime-based audio file? If so, please see Audacity 2.1.0: FFmpeg required for MP4/M4A/MOV/ALAC import.

Another way to get around that problem is to download the current Audacity 2.1.1 instead from Audacity ® | Download for Mac OS.

If you see a flat line where the waves should be, then please check you are following Installation: Do NOT run Audacity from the DMG!!!.