No Waveform when open a WAV File

I try to open a wave file for edit with Audacity, but no waveform is drawing…

I have installed the latest version, and the LAME and FFMPEG libraries.

Please read the pink panel at the top of the page and tell us your version of Audacity and Windows.

When you import a WAV file you should see an option to “copy in” the WAV or to “read the file directly”.

If you choose to read directly, then instead of a long progress dialogue waiting for the WAV to import, you see the hatched pattern in your image. The waveform is progressively drawn so as to replace the pattern, but you can click anywhere while the waveform is being drawn to jump the waveform drawing to that point. See On-Demand Loading - Audacity Manual.

If you don’t like the pattern, choose copy in.

If you choose to read directly, do not delete, move or rename the WAV files you are importing.

Are you saying that the pattern never gets replaced by the waveform?

By the way, in your image, you have no recording devices available.


The Latest Version on Windows 7.

I have used Audacity for many years, and this is the first time i have a problem. I try with “make a copy before”, but now I get this! I probe with a mp3 file, and get the same result. I get the same results on all files.
I get this, befor format Win 7 and install the latest Audacity version.

Please give us all three Audacity version numbers as requested (see the pink panel at the top of the page).

The current Audacity version is 2.1.1. You can get it here:

I suggest you obtain Audacity 2.1.1 as per the link above. Halfway through the installation, enable (put a tick in) the “Reset Preferences” box. When you launch Audacity, confirm you want to reset preferences.

Then you will not see the hatched pattern when importing an MP3, if it is really an MP3.

For WAV, you have to choose copy in, if you do not like the pattern.

If there is still a problem after that, then the files you are currently importing may be corrupted.


When that happens, it usually means that there is a problem with your Audacity temporary directory. See Edit > Preferences… then the “Directories” section for the location of your Audacity temporary directory.

Make sure you have permission to write to that directory and that the drive is working correctly and has sufficient space.

Make sure Norton or some other security or clean up tool is not deleting the temporary files.


It Works!!
I install the 2.1.1 version, with “reset preferences” option, and now, the waveform is working.

Only works if runs Audacity with ADMIN PRIVILEGES… if not, there are the same problem…

That indicates that there is a problem with your Audacity temporary directory. The write permissions for the current location require admin privileges. You need to set the temp directory to a location where your normal user account has read/write access. See Edit > Preferences… then the “Directories” section for the location of your Audacity temporary directory.

“Reset Preferences” should already have set your Audacity temp directory to C:\Users<your user name>\AppData\Local\Temp\audacity_temp. You should have permission to write there. If not, your permissions are messed up.

You can right-click over any folder, choose Properties at the bottom, then the “Security” tab to check permissions on that folder. You have to be logged in as admin to change those permissions.