No "USB Audio CODEC" for Input Choice [SOLVED]

Greetings all.

I’m running a few year old Mac Mini (the version from the first year they removed the CD slot) with 8GB and running “Yosemite” Mac OS X 10.10.3. I have a turntable which plugs into my phono preamp and then to my preamp and amplifier. I recently purchased a phono preamp which supports USB out. The photo preamp is working fine. I connected the USB cable from the phono preamp, turned up the gain for USB Out, and connected the other end of the USB cable to a free USB port on my Mac Mini. I started playing some vinyl and that plays through my audio system just fine.

Where I run into trouble is that Audacity help shows graphics in the Sound pane which show a “USB Audio CODEC” input selection. I have no such option. I’ve read here that that may be a remnant of PowerPCs but I don’t know if that is true. I also read here that I needed to launch “Audio MIDI Setup”. It also does not show me a “USB Audio CODEC” choice. Nor do I have this option in Audacity’s preferences. Until I can get the Mac Mini to see my audio USB input, I am dead in the water. The fact that Audacity works with Mac OS X 10.10 has me stumped too as without the “USB Audio CODEC” choice I have no idea how to get my USB audio source seen within Audacity. I have unplugged the USB from the Mac Mini, restarted it, plugged in the USB cable while the computer was “live” and so on and so forth to no avail.

I look forward to getting a solution to my problem from one of you knowledgable folks. Thanks!


That’s backwards. Audacity checks for new devices when it starts, so connect and settle down first and then start Audacity. You can also use Transport > Rescan…

Plug the device in and Apple (Desktop upper left) > System Preferences > Sound > Input.
Do you see your device there or something that could be your device? Most important, does the blue ball sound meter bounce when you play something.


Open Audacity and using the device toolbar, select the same thing you saw in System Preferences. Probably stereo. Some devices won’t work if you get this wrong.

Where do you get stuck?


Hello Koz. Thank you for your assistance. Unfortunately I’m still stuck.

This time when I started the Mac Mini whilst the USB cable was connected between the phono preamp and the Mac Mini I received a Mac Notification that I did not see earlier today. It read: “USB Devices Disabled. Unplug the device using too much power to re-enable USB devices.” I got two of the same notification for some reason. Odd that this did not happen earlier in the day. the phono stage pre-amp USB output is designed to work with PCs and Macs so why the Mac Mini would feel the input was an overloaded source, I don’t understand. I did plug and unplug the USB cable at the Mac Mini. I also turned down the USB gain at the phono stage pre-amp even though I was not playing anything on the turntable at the time. I didn’t get the notification again after that for some reason.

Looking at System Preferences > Sound > Input again per your suggestion yielded nothing new. Under Audacity’s Preferences I have host as “Core Audio” and that is the only choice. Playback is via HDMI. Recording setting is yields these devices: Built-in input (selected), Soundflower (2ch), Soundflower (16ch).

I selected the Transport > Rescan feature in that menu as you suggested. Nothing changed.

I clicked on the red Record button whilst playing a vinyl record. The progress bar moved but there was now waveform being displayed.

Per your suggestion I used the toolbar device selections and they matched my Sound preferences: Core Audio, Built-in input, 2 Stereo, HDMI for speaker output.

I again launched “Audio MIDI Setup”. My only choices are: AirPlay 0 in / 2 out, Built-in Input 2 in / 0 Out (shows microphone icon), Built-in Output 0 in / 2 out (speaker icon), HDMI 0 in / 8 out (HDMI icon plus Finder and Speaker icon), Soundflower (2ch) 2 in / 2 out, Soundflower (16ch) 16in / 16 out. That’s it. No “USB Audio CODEC” or anything suggesting a USB device is connected for audio purposes.

So that’s a recap of what I’ve tried and what I’ve observed Koz. I hope you or another member here can get me on the right path. Thanks again for your help.


I got two of the same notification for some reason.

What else do you have sucking power from the Mini? That’s what the complaint is about. USB power is not open-ended. You can’t power multiple “USB Toaster-Ovens,” particularly on a Mini.

If the device doesn’t show up in System Preferences, that’s the end of the story. The Mini shut down the connection.

Unplug all the USB connections except the keyboard and mouse. Does that work? Now plug in the device again.

I started playing some vinyl and that plays through my audio system just fine.

You didn’t say “your USB audio system.” It’s never worked through the Mini, right?

It could be flat broken. People all over Earth plug in preamps and sound systems into Minis with no troubles. I have something running on all my Mini ports including port-powered memory devices. The only trouble I’ve ever had is trying to get USB3 to go through a USB extension cable (it won’t).

Google the problem and maker of your preamp.


Thanks Koz. That does cut to the chase. I have no keyboard or mouse connected. I believe I have one hard drive connected but it is not powered on. I’ll check out what else is connected and try again today and get back to you but what you say makes a lot of sense. No. The sound has never worked though the Mini. I was about to send the exchanges here to the pre-amp manufacturer for their input but, for now, I’ll troubleshot the USB items I’ve got connected, disconnect them all, except for the USB from the phono stage pre-amp and go from there. Thanks again!


I have no keyboard or mouse connected.

That’s the “doorknob moment.” A guy makes it through an entire physical and has said goodbye to the doctor and pauses with his hand on the doorknob, turns and says: “I bleed out my noise every night. That’s not important, is it?”

Most of us plug a keyboard and mouse into our Mini. In my case, only the keyboard and then my mouse plugs into that. How are you controlling your Mini?


Here’s the latest Koz. First off, I control the Mac Mini with a wireless Logitech DiNovo Keyboard.

I unplugged the one USB device connected to a hard drive. All that remains is an HDMI connection and ethernet. The Mac Mini squawked again that the USB from the phono stage preamp was overloading the Mac Mini so it disabled USB. This is odd to me. When I unplug and reconnect sometimes I don’t get the disabled message and I think it is connected but it doesn’t seem to work then either. I’m going to be gone for a few days but will check your posts here when I return. I 'm going to try and contact the phono stage pre-amp manufacturer for some of their input.


Hello Koz - and all. I got things working today!

I unplugged the Mac Mini from a UPS power supply in case that was limiting something. I had the same pop up on the Mac Mini disconnecting USB even after I had plugged the Mac Mini directly into a wall socket. I then questioned the new USB cable I had purchased and connected. Was it defective? (I had purchased two new USB cables of different lengths.)

Now, either the first, and longer USB cable was defective or the Mac Mini did not like the length because the new shorter USB worked instantly and I got the “USB Audio Codec” option to select and I was then able to successfully capture the audio to Audacity! I’ll never know if the length thwarted the proper connection to the Mac Mini or if this cable was just plain no good but using the shorter cable solved it all!

Thanks for your patience and help Koz!