No stereo, only mono

No stereo in Audacity - only mono. I am using a Soundblaster X fi Go Pro and win8.1.

When I record music from my mixer into Audacity (downloaded two days ago), Audacity only records the sound in mono,
from the left channel of the mixer.
That’s it. The sound from the mixer is in stereo but in audacity it isn’t. Don’t know what to do.

Windows probably thinks your USB soundcard is a mono USB microphone.

[u]Here[/u] is some information about configuring Windows for stereo.

I couldn’t see from your link how to make my computer change from microphone to soundcard. Could you give a link for that please. Overall, it has been very very difficult to get audio into my new lapto

Doug gave you a link that tells you how to set Windows to treat a recording device as stereo. Look in the green box when you click that link.

You’ll need to say more about the mixer (what is the exact make and model number?) and how everything is connected. If it’s a USB mixer and you want to connect it directly to your computer you will have to make that mixer stereo in Windows (see Doug’s link).

If you are connecting the mixer to your SoundBlaster USB card, you may have to make SoundBlaster stereo in Windows using the same method.

If you are connecting the mixer to line in of your computer (blue) you may have to make the line-in stereo in Windows using the same method.

If you are connecting the mixer to mic in (black or pink) of your computer, or to mic in of your SoundBlaster, don’t. The mic input is probably mono. The mic in of the computer might be “compatible stereo”, but even if you can configure Windows to make it stereo the recording is likely to be of poor quality.


Dave’s link gave information for Windows Vista and 7. I have win 8.1 and his info doesn’t apply unfortunately. I have looked for a few hours but cannot see how to change windows 8 or 8.1 for stereo microphone. All the settings in Audacity are correct - stereo selected, and correct soundcard selected.
My sound blaster sound card “X-fi Go Pro” is stereo in/out and of “pro” quality. It is connected to the master out of my analogue mixer. Accordingly to the users handbook it will record in stereo, but I can only get it to record in mono on both channels.
I realise this is a problem of my computer and soundcard. I may have to dump the soundcard.

The setting is exactly the same for Windows 8 or Windows 8.1. The Manual for the next release of Audacity will mention Windows 8 on that page. Why not simply check the setting?

To do that, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the SoundBlaster then choose “Properties”. Then click the “Advanced” tab and look in the Default Format section.

What is the make and model number of the mixer? What is the exact type of cable (make and number) you are using and the exact input you are connecting to on SoundBlaster? Remember we can’t see your computer and mixer.


Thankyou for your assistance. There is a fault! (possibly)-
AS directed, on the “Microphone/Properties/Advanced tab/Default Format”, the “2 channel 16 bit, 44100 CD quality” option box is greyed out! Also greyed out is the “Restore defaults” tick box. Is this normal? My soundblaster was connected at the time.

My mixer is a small, standard music studio mixer (Soundcraft Folio Notepad) with four channels. I connect the master out (L/R) to the soundcard. The two cables are coxial with gold ends. I swap them over but it makes no difference to the mono output.

Is this the sound card you have Sound Blaster X-Fi Go! Pro External USB Sound Card - Creative Labs (UK) ?

If so do you have the correct drivers for it?

If your sound card is as I am guessing it has only a (1/8-inch) stereo input jack for Microphones. It’s unlikely to be suitable for connecting high quality output from a mixer. I don’t even understand how you are connecting a L/R coaxial cable to it without an adaptor.

Which is your exact mixer in this list: Soundcraft - Professional Audio Mixers | English ?


My mixer is this one Products | Soundcraft - Professional Audio Mixers | English
Yes, you have the right soundcard. It is 24 bit stereo. I downloaded the drivers for win 8.1, but these are very new. I might have to use win 8. I use an adapter to connect the coax’s to the soundacrd from the mixer.
The soundcard is described as a microphone in my Recording Devices. The “2 channel 16 bit, 44100 CD quality” option button is GREYED OUT! This may be why it records in mono. I cannot see how to change the microphone designation to recording device.

You could try the tech support 'phone numbers on the Soundcraft site and see if they will help.

Either way, the Soundcraft interface you have has no digital input so it’s a waste of time connecting a coaxial cable and adaptor to it. Are you even sure the adaptor is stereo?

I’d be suspicious about recording stereo into a device where the input has a mic image and recommend you get a proper interface with RCA left and right inputs (or a TOSLINK digital input if preferred). See: .


i’ve just encountered the same problem, the frustrating thing is that this morning i was using the ‘obsolete’ version 3.3 and it was picking it up as stereo no problem - now ive put the new version on its not recording stereo - which suggests to me it is definately a software issue…

getting close to giving up with audacity, :frowning:

There is no such version as “3.3.”

According to your topic Cannot remove white noise/hiss - #3 by bandit1985 you are using a PHILIPS SBCMD110 mic which is a mono mic (single ring connector). So you don’t need stereo. A mono recording will play the same sound through both speakers of a stereo system. It is also nothing to do with your hiss issue.

If you want to record the same signal duplicated into left and right channel, please see Audacity Manual .


The adapter I got has two in’s and one out, and has two insulation bands on the out, so it’s stereo. It says stereo on the packet too.
The soundcard I bought is 24 bit stereo. It says this on the packet.
My mixer is industry standard, with master stereo out, analogue. This should go into the soundcard without any problem.

This setup will record sound. The problem is that my computer is seeing it as a microphone and records in mono. It is quite clearly not a microphone, and it says stereo on the packet.

I just got this:
"Dear John,

Thank you for contacting Creative.

With regard to your inquiry, please note that the stereo-jack for audio input as advertised on the Sound Blaster X-Fi Go! Pro does not actually refers to a stereo audio being captured by the built-in microphone when speaking or recording. The port only support 3.5mm stereo jack connection but the end result is simply a mixture of both mono signals. Therefore the quality of the audio is still in mono format combined by both left and right channels to form a single wave.

If you still require assistance, please reply to this email and include any previous correspondence to ensure a quick response.



The point is not the mixer but your interface. I have read the manual for the interface. In some places it calls the input “for microphones” and elsewhere it calls it a “line-in” jack. A proper line-in is always stereo.

The support answer you have received (if correct) appears to suggest the input isn’t even a “compatible” mic/line input as provided on low end laptops, but mixes left and right into a mono signal.

In my opinion, the device should not grey out Windows “Default Format” but offer only mono choices if the input is only mono. I think that casts more suspicion on the device.

So the advice stands. Get yourself a proper interface if you want high quality stereo recording to the computer.


I took the device back after I posted. I am looking at the ones you suggested. What a relief to know to get the right stuff.

If you have some advice on this it would also be helpful. Perhaps I do not need a soundcard? Here is what I want to do. I have a Pulsar soundcard (win 98 with no USB connection) in my other computer Pulsar was a very expensive interface for audio. How do I get the sound from that computer into my laptop so I can use it with Audacity? Is all I need a spdif/analogue to USB interface? or will I need another soundcard? Pulsar cost me 1000 pounds.

I’ve seen a couple of reviews for the sound-blaster x-fi go pro that said it was very good (for the price), but they were only concerned with playback and not recording.

For stereo line level recording and playback there are lots of options, and they need not be expensive. I use a Behringer UCA 202, which is very inexpensive (about £30 GBP) and I use it with a mixing desk, or directly plugged into my hi-fi. Although it only has a plastic box and very few additional features, I’m very happy with the sound quality for both recording and playback. ART also make suitable and relatively inexpensive USB devices (less than £100 GBP), and these tend to be built into good strong metal enclosures.

There are so many makes/models, (and obviously we have not tried them all), that we can’t really make recommendations, but only give comment about personal experience of products that we have used.

As far as I can see Creamware made Pulsar and Creamware was taken over by Sonic Core.

There is no harm in your trying to get Pulsar going with Windows 8, though be prepared that it may not work.

This page: claims to have drivers for Pulsar that support Windows XP through Windows 8, though Sonic Core only has Scope Windows 7 drivers for Pulsar which I assume to be mainly a software DSP package. If you want official advice, you are best to contact Sonic Core via their site.

If the system is well set up you should not hear that much different between S/PDIF and analogue. Exactly what you are recording into your Soundcraft mixer?