No sound through headphones

I’m using Audacity version 2.3.3 on a Mac laptop with the Catalina OS. I can’t get any sound through headphones, only through the computer’s internal speakers. How can I fix this?

Upgrade to Audacity 2.4.2 ( and give Audacity permission to use the microphone.
Ensure that your settings are correct in the Device Toolbar.

I’m running Audacity 2.4.2 on a MacBook Pro 2019 (16") under Catalina 10.15.7 and I have the problem described here: the output of Audacity goes to the built-in loudspeakers regardless of headphones being plugged in or not.
I checked that the loudspeaker jack was operating properly (speakers off and sound in headphones when headphones plugged in) when playong Music app, YouTube (via Firefox).
I just talked to Apple support who could not help… :angry:
Although I thought the jack receptacle acted as a simple switch (between speakers and male connector) it is obviously not the case.
If anyone has a clue…

Not an expert on macOS here - just something to try…

Try “Transport > Rescan Audio Devices”, then select your speakers.

Let us know how you make out.

1 Like

Thanks for your response.
I have rescaned the devices. No help. But doing so I found the solution !!

  • In Audacity menu click: Extra > Peripherals > Change Playback peripheral
  • this opens a window with a rolling banner
  • you will probably find “MacBook Pro loudspeakers” selected
  • select “external headphones” (above the speakers in my case)
    et voilà
    This selects the headphones while turning the speakers. Not very handy when you need to switch from one to the other but…

In the Mac: System Preferences > Sound, the change of output peripheral is reflected. I assume you can switch from there equally.
I did not find it earlier because “Headphone port” is the 1st choice but above the “MacBook Pro speakers” which was selected. Thus the “headphone” line was not visible.

Hope this helps others…

Excellent answer. This solved it for me too - after I’d honestly convinced myself Audacity couldn’t use headphones cos it was a freebie and nobody had thought of it!

Sorry, Audacity team, you HAD thought of it - you’d just hidden it well (As per usual with menus!!)

Yours respectfully and with great thanks


A much easier (not hidden) way to change the same setting is to use the Device Toolbar.

I’m running version on Mac OSMonterey (12.3) and am having the same issues, though there isn’t the option of ‘Extra > Peripherals > Change Playback peripheral’.

Can anyone help?

The menu is Extra > Device, but as Steve points out you should be able to make the same change using the Device Toolbar.

– Bill

Thanks Bill.

@jademan nailed it for me, Transport > Rescan audio devices

1 Like

Hello all, Im also having troubles with my Headphones. I´ve activated as playback device “external headphones” but still, I get this message “ERROR opening sound device. Try changing the audio host, playback device and the project sample rate.” Can anyone help? When I use my USB Microphone then I get sound, so I guess is not a problem on detecting external devices. Please advise.

I also have troubles by using the integrated MIC of the MAC. Does anyone know which sample rate should be selected?

Using version 3.3.3. There was simply no option for external headphones anywhere that I was looking ei. Audio Setup etc. Then after an hour (I’m embarrassed to say lol) I went to View/Toolbars/Device Toolbar, clicked Device Toolbar and there it was as a drop down choice: “External Headphones”. Until I did that absolutely nothing worked.

That solved it for me, thank you! In the menu, clicking on Transport → Rescan audio devices (I have the German version, so it’s Transport → Audiogerät neu suchen.

After that, I could choose the external headphones and it worked :slight_smile: (Audio-Einrichtung → Wiedergabegerät → externe Kopfhörer)

Same thing for me; I’m getting the message: “Error opening sound device. Try changing the audio host, playback device and the project sample rate.”

I have simple minijack earbuds plugged into my new Macbook Sonoma 14.4.1. There is a choice of External Headphones, but I’m getting an error when I want to play a track over those headphones. Speakers do work.
Problem details:

“timestamp”: 1714150040,
“event_id”: “e047c8d0648a444b9122507b04b73729”,
“platform”: “native”,
“release”: “audacity@3.5.1”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “Error”,
“value”: “Error opening sound device.\nTry changing the audio host, playback device and the project sample rate.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

Having the same trouble of not hearing anything through the headphones. I successfully used the device I am using a few years ago to transfer tape to MP3 using Audacity, and it went without a hitch. I have upgraded Audacity to 3.5.1, my OS is Mojave, and now it doesn’t work. I see no options anywhere in the device toolbar to select external headphones. I have tried re-scanning audio device - nothing works.