No sound through headphones

I am running Ubuntu 14.04

I have a Focusrite Scarlett 2i2 interface connected to my computer.

I can hear my bass through the headphones, through the 2i2.

I cannot hear the Audacity playback through the headphones.

I can hear my bass through the headphones

That’s your live instrument?

Can you play an Audacity sound into your 2i2 without overdubbing? If you are Overdubbing, you should select Audacity > Preferences > Recording > overdubbing > OK.

If you can’t ever play Audacity into your 2i2, then you have to select the 2i2 in your Audacity Device Toolbar.

And that’s where you lose me since I’m not a Linux elf.


Thanks for the reply Koz,

Yes, I’m using a bass guitar. I neglected to be clear about that.

I am not able to run Audacity through the 2i2 with or without overdubbing.

I did try selecting the 2i2, in Audacity.

Audacity still does not play through the headphones.

This is where you have to get the Linux systems to help you and it’s the exact place I go hide in the corner.


With the 2i2 explicitly chosen as Playback Device in Device Toolbar, ensure that the Audacity playback volume is turned up (speaker symbol) in Mixer Toolbar:

If that does not help, please post the complete information from Help > Audio Device Info… top right of Audacity.


Thanks for the reply Gale.

Here is the message I got: Stream is active … unable to gather information.

Press the yellow Stop button, then try Help > Audio Device Info… again.

Have you tried turning up the playback volume in Mixer Toolbar?

What version of Audacity are you using? Give us all three numbers from Help > About Audacity… .


I pressed the yellow stop button before going into help. That didn’t do anything.

I neglected to mention that I did turn up the slider.

The version that I’m using is; 2.0.5

After trying the suggestion, I still get the same message: Stream is active … unable to gather information.

It could be that you have clicked on the recording meter and activated the meter (and so started an audio stream).
Try clicking on the recording meter to stop monitoring, then try Help > Audio Device Info… again.

If that does not work, shut down Audacity entirely, then relaunch Audacity and do “Help > Audio Device Info…” (taking care to not click or type anything else).

Okay, I got it. I just need to switch from Built-In Analog Audio Stereo, to the interface. (Scarlett 2i2) To hear through the headphones.

Thanks for all the input!!

I had a problem before where I could not hear the audio playback of the input while I was recording. This time I am using an iRig Pro. I tried all the settings for the playback device to no avail. I knew I had come across the answer before and it is under the following:
Edit > Preferences > Recording > Software Playthrough of input
That option needs to be turned on. At that point, the playback devices that worked were: sysdefault and dmix.
I am running Ubuntu Mate 17.

The downside to using Software Playthrough is that there is a delay between the sound going into the microphone and coming out of the headphones, because the data has to be moved through buffers by the software. This is not a problem in some situations, such as recording cassettes, but can be a major distraction in others (such as recording vocals).

Some recording devices provide “zero latency monitoring”, which is where you plug headphones into the recording device so that the sound signal can pass from microphone through to the headphones in hardware (through wires). This avoids the delays incurred by software routing.