No Sound on Mac


I am trying to record from a cassette to my Mac which is version 10.15.4 Catalina.

I have made sure all the volume options on the converter, the software and my Mac are up (even all being on max) and it all seems to function fine but it doesn’t play anything but external noise when I play back and I just can’t understand why! I’ve tried both USB portals on my laptop and I have checked the microphone is enabled for Audacity on system preferences but still nothing…

Can you shed any light on this? I really need to get this done :neutral_face:



If you generate a tone (“Generate” menu), can you hear that when Audacity plays?

Not a mac guy here. Hopefully, you have solved your problem by now. If not, post back here and someone should reply. From your report, I am not clear as to exactly what difficulty you are having.

Is it possible that you are trying to record from your microphone, not from your USB device? You need to specify your USB cassette player in your Audacity Device Toolbar: Device Toolbar - Audacity Manual

Audacity won’t be able to find your device unless Catalina sees it first, see: If a USB device doesn’t work with Mac - Apple Support

Also, just as with your microphone, audacity may need permission to record from this device.

I hope this helps. :smiley:


Thanks for this - I’ll give it another go tomorrow with this advice, fingers crossed.

Will let you know!

Hi Steve, I can yes :confused:

Might help if you have pics to work with - there’s only one drop down which is from (stereo) recordinging to Mono but it makes no difference x
Screenshot 2020-12-09 at 19.21.44.png
Screenshot 2020-12-09 at 19.21.38.png

How is your cassette player connected to your Mac?
The settings in your Device Toolbar appear to show that you are set to record from the built-in mic rather than a cassette player.

Hi Steve,

Just by the USB cord it came with and have tried two different inputs…

Ensure that you connect the cassette player to the Mac before you launch Audacity.
If Audacity is already running, you either need to quit Audacity and restart, or “Transport menu > Rescan Audio Devices”.

Then look for the USB option in the Recording / Input Device setting of the Device Toolbar. Select that option as the recording device.

What is the make and model of the cassette deck?

After connecting the cassette deck to your Mac, go to Apple menu > System Preferences > Sound > Input. Do you see the cassette deck listed there? “USB” should be part of the device name. Click on it then start a cassette playing. Does the sound meter bounce? If you get this far you should definitely be able to record from the device in Audacity - do what Steve says.

Note: if your cassette shows up in Sound Preferences as “PnP USB Audio Device” (or similar - the key is “PnP”) then you may have one of many problematic cassette-to-USB devices that fail to maintain a consistent USB connection.

  • Bill

What he said.

The Mac has to know it’s there before Audacity sees it.

The control panel in the Mac has a little volume meter. That has to work, too.


Thanks for this - very useful.

Unfortunately it does say PNP :frowning: I’ll see if I have another cord somewhere and then I guess it’ll work?

Just to follow up I tried a different lead and said the same thing so not sure what to do now.

  1. What “Input” devices are shown in the “Sound” Preference? (see this post:

  2. What is the make and model of the cassette deck?