no sound in headphones while recording

Hello eveyrbody! Yesterday I updated Audacity to version 3.2.1 on MacOS Monterey 12.4 system; I am using a Blue Yeti microphone, USB, with headphones plugged into the microphone.
I hear my voice in the headphones until I start monitoring the microphone or start recording; then from that moment I can no longer hear my voice in the headphones. With previous versions I never had this problem. Can anyone help me?

I don’t understand what you are trying to do. If you can hear your voice in the headphones, then why do you want to monitor the microphone? This simply introduces a delay which can be confusing for most users.

I am thinking your issue may be resolved by adjusting the gain and volume controls on your Yeti, and turning off Software Playthrough (Transport > Transport Options) in Audacity.

Prior versions of Audacity are available here:

I didn’t explain myself well, sorry I’m Italian; the problem is that (in the new version) my voice in headphones disappears when I start recording; with the previous version instead, I could hear my voice even during registration.

OK; I don’t have anything else to add at this time. :frowning:

Go into Audacity preferences and turn off Playthrough.

Audacity > Preferences > Recording > [_] Playthrough (de-select) > OK


Headphones in the yeti automatically mix live performance with whatever comes down the USB connection. If your voice comes down the USB connection electrically “upside down” or interfering with the live performance, your headphones may stop working. The two sounds may cancel.

Also try setting Audacity playback to the Mac’s normal speaker or headphone connection.

Even if those suggestions don’t solve the problem, post back if anything changes.


I’ve always had this issue in Audacity when I try to edit with my headphones in the jack on my MacBook Air. I started on version 3.1.3 so I’m a newbie to all of this. I have macOS Monterey 12.6 and am now using Audacity 3.2.1 and found that I had to click on the Audio Setup button and choose “External Headphones”, and then it worked perfectly. I hope this gets fixed in a future version to be automatic like it is in other applications, but in the meantime it’s a simple fix.

As far as recording in Audacity and monitoring your mic, I agree that this causes a lag (latency) that’s not easy to fix. I tried what I saw in several videos on YT and it didn’t work for me, but now I record on a Zoom H6 and edit the .wav file in Audacity and that’s working much better for me, and I don’t have the latency issue when recording on the H6.