No sound from mic connected to MAudio interface

Once upon a time I was immersed in the digital audio recording world - way back in its infancy. I got away from it and haven’t had much need or reason to get involved in it . . . until now.

For the sound on my desktop computer I have an M-Audio Firewire Solo with a pair of Roland MA-12 powered speakers. I also have a Samson M1 1/4" microphone. The mic works. On the M-Audio there is an XLR input for a mic and a 1/4" input for guitar. There is also an on/off switch for phantom power on the 1/4" input. When I plug the Samson mic in, open Audacity and click on record - there’s no signal. I’ve played around with it for the past 45 minutes or so, changing settings, trying this, trying that . . . I don’t know. The M-Audio works fine for playback. I’m just wondering why Audacity isn’t recognizing that I have the Samson mic plugged in?

The M1 seems to be a dynamic mic so doesn’t need phantom power. So to be clear, are you connecting M1 directly to the M-Audio guitar input?

Choose the M-Audio as Recording Device in Audacity’s Device Toolbar. If you are recording in mono into the guitar input, try recording in stereo (next setting to right in Device Toolbar).

You may then have an empty left recording channel. Click in the Audio Track Dropdown Menu and choose “Split Stereo to Mono”. Then click the [X] top left of the upper track to close it. The remaining track will play through both speakers.

If that doesn’t help, make sure Windows recognises the M-Audio as a recording device. See Windows Sound.

Tell us exactly which M-Audio device it is, if problems persist.




Gale

OK I went through the steps and got Audacity to recognize a signal when I record. (my interface is an M-Audio Firewire Solo btw)It only records on the the right channel so I closed the left channel. But now I can’t hear the playback through the speakers. If I export the track as an MP3 and play that there’s no sound either. It’s showing a good strong signal, I just can’t hear it.

I can hear other MP3 files or online videos thru my speakers so I’m guessing it’s a setting in Audacity that I have wrong. I have 3 options in the drop down menu for playback:
Microsoft Sound Mapper - Output
Line 1/2 (M-Audio FW Solo)
S/PDIF (M-Audio FW Solo)

I have it set on Line 1/2 (M-Audio FW Solo) which I believe is where it has always been set. I tried the other two settings but still didn’t hear anything.

I got it to pick up the signal in the right channel only. I then have to click the Audio Track drop down menu and select “Split Stereo Track.” Then I can close out the left (empty) track. To get it to playback I have to click on the drop down menu again and switch it from “Right Channel” to “Left Channel” and then click “Set Sample Format” and switch it from “32-bit float” to “24-bit PCM”

I’m not sure what all of that does, but so far it’s the only way I have been able to record and then hear the playback. Any comments, explanations or simplifications are greatly appreciated.

I then have to click the Audio Track drop down menu and select “Split Stereo Track.” Then I can close out the left (empty) track. To get it to playback I have to click on the drop down menu again and switch it from “Right Channel” to “Left Channel”

if you make it “mono” it will play through both speakers. …That’s’ assuming everything is working correctly and stereo files play out of both speakers, etc.

To get it to playback I have to click on the drop down menu again and switch it from “Right Channel” to “Left Channel”

Is your right speaker working at all? i.e. With Windows Media Player and regular stereo music files?

and then click “Set Sample Format” and switch it from “32-bit float” to “24-bit PCM”

That’s some kind of driver issue. DACs (and ADCs) don’t work in floating-point but the drivers normally take care of any conversions. However, there is a “WASAPI exclusive” that may prevent resampling.

If I set it to “mono” it doesn’t record. It will only record a signal in stereo and only on the right channel. Yes, both speakers work for everything else. I bought this M-Audio thing several years ago when I was in a band just to record quick guitar parts to send to the other guitarist. I had a Line 6 virtual effects processor installed that I was using, (that belonged to the other guitarist). When I got out of the band I gave him his Line 6 thing back and uninstalled it. For the past 3 years I’ve just been using the M-Audio and Roland speakers as playback listening to speakers, (for youtube videos etc). I haven’t had to mess with any settings or anything for 3 years, and it seems as though I’ve forgotten most of what little I used to know.

Back in the day, (2004-2007-ish) I had Cakewalk Sonar software and a Motu 896 interface and a sound tech for the band who was recording demos with it. I remember spending hours, days, weeks, and months learning how to do all this stuff. But that was then. I didn’t keep up with it and the technology was advancing WAY faster than I had time for. Now when I have to do simple stuff like figure out why my $79 interface isn’t making noise - I feel like a completely clueless noob again. The only difference is at this point I have no desire to spend hours and hours trying to relearn everything I’ve forgotten.

So here I am. :slight_smile:

There is a quicker method so I edited my previous post to suggest that. “Use Split Stereo to Mono” in the Audio Track Dropdown Menu then close the upper track. Then the remaining track is already mono.


Gale

That will add low level Dither noise to the recording. Exporting as a 16-bit audio file (if that is what you intend) would then add another stage of dithering because of the 24-bit to 16-bit downconversion.

That means you are using MME host in Device Toolbar. See if using Windows DirectSound or Windows WASAPI host avoids the need to change the sample format of the audio. Also make sure you have the latest Windows 7 drivers for your device from the M-Audio site - here http://m-audio.com/support/download/drivers/firewire-installer-6.0.1-driver-5.10.0.5058.

Also according to your provided information, you have no built-in audio playback on your computer. Is that what you intend?


Gale

Gale Andrews wrote:
That will add low level Dither noise to the recording. Exporting as a 16-bit audio file (if that is what you intend) would then add another stage of dithering because of the 24-bit to 16-bit downconversion.

If there’s a better way to get a higher quality recording I’m open to any suggestions. I played around with it for quite awhile changing different settings and this was the only way I could get any signal to show up. It only shows up on the right channel in stereo. I couldn’t get any signal in any of the other settings I tried and at first this signal only showed up visually, (I couldn’t hear it when I pressed play).

Gale Andrews wrote:
That means you are using MME host in Device Toolbar. See if using Windows DirectSound or Windows WASAPI host avoids the need to change the sample format of the audio. Also make sure you have the latest Windows 7 drivers for your device from the M-Audio site - here > http://m-audio.com/support/download/drivers/firewire-installer-6.0.1-driver-5.10.0.5058> .

I am using MME. I think I tried using the other available settings and nothing worked. I’ll check to see if there’s any updates for the drivers.

Gale Andrews wrote:
Also according to your provided information, you have no built-in audio playback on your computer. Is that what you intend?

No idea. This desk top computer is probably 5 or 6 years old. I bought the M-Audio interface in 2013 for a band I was in so the other guitarist and I could practice parts without actually loading up gear and driving to each other’s house. He was a techie, in fact his day job is IT, so if I ran into any problems back then he could walk me thru em pretty easily. I quit that band in 2014 and he and I didn’t stay in contact, (the band was the only thing we really had in common).

Since then I haven’t done anything with the M-Audio except turn the volume knob up or down when listening to youtube videos. It’s plugged into the back of my computer and the two Roland speakers are plugged into it. If I want to listen to something on my computer I click the power buttons on my speakers on and there’s sound. Other than that I haven’t messed with any settings at all. I have also never used Audacity as recording software. I had Cakewalk Sonar installed which I used before. I also had some Line 6 virtual effects processor installed that belonged to that other guitarist. The only thing I’ve ever used Audacity for was to convert files to MP3 or edit existing MP3 files, (cut short clips out etc).

I just decided I wanted to record audio, I have the M-Audio and Samson microphone and Audacity, so I thought I’d give it a shot and see if I can do what I want with those items.

Well, if the only edits you want to do to your recording are to cut a few pieces out, you could change Default Sample Format in Quality Preferences to 24-bit PCM then export as 24-bit WAV. Then there will be no dithering and no need to convert the track before you can play it.

You might also need to set 24-bit recording in Windows Sound to avoid possible conflicts. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the M-Audio then choose “Properties”. Then click the “Advanced” tab and look in “Default Format”.

If you are having playback problems with M-Audio it does limit your options to have no built-in computer playback.

When you are in Windows Sound you can click the “Playback” tab. Right-click in empty space and choose “Show Disabled Devices”. Right-click again and “Show Disconnected Devices”. Do you see other playback devices than M-Audio now? If not the built-in device may have been uninstalled by your IT friend.


Gale