No Sound for Speakers

I’m running Audacity 2.0.4 under Windows 7 Home.

I’m trying to edit an MP3 file, but when I press the Audacity “Play” button (green triangle) no sound comes out of my speakers. But If I play the same file on the same computer with Winamp, I can hear it just fine.

Here’s what the Audacity window looks like when the file is playing:
Audacity, No Sound From Speakers.jpg
Could someone spot the setting that I need to correct so I can hear the sound?

Will in Seattle
a.k.a. “Clueless”

According to the message next to the little speaker picture, Audacity is trying to send sound to your Realtek Digital Output. Do you have a digital sound system or digital speakers?

I see you’re also using Stereo Mix next to the microphone picture. That’s the setting for recording YouTube audio or other internet sound. That can create odd sound pathways and cause you to record too much sound.


Thanks Koz, I just changed to Realtek High Definition, and now I’ve got sound.

About that other setting, the one that is now on “Stereo Mix.” The drop-down menu gives me two other choices:

  • Microsoft Sound Mapper - Input
    DigitalIn (Realtex Hight Definit

I haven’t a clue which one to select.

Will in Seattle
a.k.a. “Clueless”

“Stereo Mix” is also called “Everything Playing on the Computer.” What that does is establishes a link between the speaker system and the recording system.

Normally there is no link between YouTube music and Audacity recording.

Your browser plays sound to your speakers and Stereo Mix turns it around at the last second and sends it back down the recording pathway so Audacity can get to it. A common complaint is to either have to speakers too loud or a good recording…not both. Another common problem is recording an Adele song and have your dog barking in the background.

If you’re not actively engaged in on-line recording, I suspect Sound Mapper should be OK. I believe there’s another, more well-behaved way to handle self-recording.

I’m not a Windows elf.


What do you want to record?

“Sound Mapper - Input” appears when you choose MME host (immediately to left of the “Recording Device”). Sound Mapper - Input is whatever is the “Default” recording device in Windows Sound.


Given you’re not recording anything (your original post) you can probably leave it where it is.