No problem in Win7, totally useless in Mint 17.3 [SOLVED]

…and I remember the program working perfectly on Mint 13 when I switched from Ubuntu 11.10 to it, 11.10 was Ubuntu’s last gasp as far as I’m concerned. I’m running Linux Mint 17.3 with MATE.

It does see my audio devices in the Sound Preferences, in PavuControl, alsa-mixer (I use ALSA in Audacious and obviously in Audacity too, can’t change it even if I wanted to. I have an onboard sound device which is okay, but for some reason, Linux Mint 17.3 suddenly started not to find it about every 7th boot out of 8, so I bought the last high quality regular PCI Sound Card I could find (my Radeon HD 7870 is too big and obstructing the PCI x1 sound card port. It sees it (Asus Xonar XG something, there was only 2 choices for me, the DG which was 29,95 and this one which was a hundred bucks. Works perfectly fine in Win7, I can’t get a sound from it in Mint 17.3.

I want to use Audacity to rip vinyls, something I do easily in Windows 7 with Audacity but I just don’t boot up anymore in Win7 much at all, it’s a major problem. In Linux, Sound Prefs see the USB PnP Audio Device which is my turntable, I can’t get sound to come out from my new sound card I only bought because the onboard sound card was giving me issues. I’ve been able to record my voice through the onboard sound card once and I’ve been able to have sound come out the Xonar XG once, but I don’t what it is that I did, the XG is very strange, the only mode it allows me is Headphones, even in Qasmixer or Alsamixer, I can switch it from Headphones to Headphones FP.

I know which devices are what, hw0 is the onboard sound card, hw1 is the sound card inside my video card, hw2 is the Xonar and hw3 is the turntable. Yet, Audacious notices nothing, while it does when I’m in Windows 7 (x64 ultimate if that matters).

I’m rather angry to have spent on a 100 dollars pci sound card and have it act this strange. I wonder if “upgrading” to Mint 18 will do, I want to stick with 17.3…it’s LTS, the first Mint to be with updates until mid 2019 so…

Any help before my hypertension causes me to explode from the anger heh.

Audacity works great for me on Mint 17.3 LTS Cinnamon.

Audacity only shows hosts that are installed and running. For example, if you want to use Jack Audio System, then Jack should be started before launching Audacity.
Theoretically it should be possible to start Jack while Audacity is running and then tell Audacity to rescan, but that has never been very reliable for me, but on the other hand, I can’t think of any practical reason for doing that.

One thing to be aware of on modern Linux systems is that they (almost all distributions) use PulseAudio by default, and PulseAudio grabs exclusive control of the hardware as soon as any application asks Pulse for an audio connection. As with most other applications, Audacity will use Pulse by default (the “default” setting in the device toolbar is identical to the “Pulse” setting). In most cases this works very well and requires no user attention.

Do you mean “Asus Xonar DG”? I can find no information on-line about an “XG” model.
As far as I’m aware, the DG model “should” work on Linux, though there are many hits on Google dated 2015 from people having problems setting it up right. I don’t have a Xonar card (any model) myself, but Google search should bring up lots of relevant information which will hopefully help you.

Audacity is unlikely to work properly if your sound system is not fully functional. You really need to either fix the problem with the Asus card, or remove it before you can reliably do useful work with Audacity.

Here in the UK, we usually begin with a nice hot cup of tea. Having a break and sitting back from the problem with a good cuppa helps to relieve the tension. Then spend some time calmly searching on-line for solutions. The Xonar cards have a good reputation for sound quality, and according to this page both the DG and DGX versions are supported (since kernel version 3.14. Mint 17.3 is more recent).

In your searching, avoid old posts about hacking the sound system and removing PulseAudio.
PulseAudio is tightly integrated into the system these days. Attempting to remove it will break your system badly.

To be clear, does the Xonar show up in AlsaMixer when you press the F6 key? If it does, then it’s probably just a matter of adjusting the level settings.

Yes it does, it’s where I could change its mode from “Headphones” to “Headphones FP” and would hear it click inside my desktop changing modes. I got no idea what Headphones FP is, but I kind of given up and will boot into win7 one of these days and do the vinyl ripping there during a weekend. It’s crazy I can make proprietary video card drivers work easily in Mint but my onboard sound card acts like it doesn’t exist 4 boots out of 5 and the microphone I bought, which maybe should have been USB, but then again, my turntable while detected isn’t “heard” about the system/audacity. I need a floppy bay or dvd bay for the 6 other usb 2.0 ports I have that I can’t use right now because the guys who mounted my desktop with the parts I told them to didn’t think of doing it, I have an 11 year old desktop box, it was very expensive then so it is still useful now, 3 cooling fans in the back and on the glass side and one on top to push out the air, someday I’ll get water cooling to really use my CPU’s immense power (AMDFX8350 Black Edition octocore 4ghz…I learned that I can’t really overclock it even though it is extremely easy to do so with the windows software, you just move up and down a percentage bar, but even at 10% it starts overheating and not acting right.

Maybe it’s my distro. I want to learn ArchLinux, I know it’s almost a task as difficult as learning Gentoo, but at least there every program’s very last version are all available and I’m sure I would not have this problem. The problem with the Xonar is that the system seems to say it will only work as a headphone thing…in Sound Prefs, Alsamixer, Qasmixer, pavucontrol etc.

As for PulseAudio…it actually is ignored by Audacious when I play music, I tell it to play with ALSA hence even if I turn off pulseaudio I can still play music in audacious. I’ll make a backup of this installation on one of my usb 3.0 drives sometimes before going to bed and start with a fresh Linux Mint, maybe even Mint 18.1 and see what happens, too bad I can’t know from virtualization.

According to this web-page
“Front Panel”

Thanks…so that doesn’t change the fact it only wants to set itself in headphone mode, I don’t have cables that go from the back to the front where one can easily plug in their headphones, I still got the the bay on my desktop box with 2 broken usb ports because some idiot walked on a gamepad and although only one gamepad was connected, it was connected to the top usb port and it scrapped both entries so that bay is useless until I get a floppy bay with 4-6 usb 2.0 ports, my motherboard has 6 other usb ports I could have access to if only the guys who mounted the device with the devices I bought seperately like anybody should buy a computer, right. But they didn’t bother adding a bay on my obviously needless double floppy bay (it also has 6 dvd/cd device bays, it’s from 2005 but is still a good box (cooling etc.).

I cannot even if I have installed a lot of jack related things in Linux, have another choice than ALSA, which clearly is not doing the job, or this install of Linux is doing what windows installs do in 3 months, maybe it needs to have what’s important backed up and…sigh…reinstall, or maybe even go with Mint 18.1…surely it will not have the problem it has with its half-detections of the onboard or the Asus DGX sound card, which doesn’t sound all that better than my onboard sound card, at least when in Windows with its drivers, but that’s the same with my onboard card in Linux, it sounds amazing with ALSA when playing tunes in Audacious, but meh on Banshee which uses Pulse…

I don’t know how to show you what jack packages I have installed, i’m too lazy for that this morning, but it’s the latest stuff and the dev, libjackd2-dev and related packages. There is jack-dev but it seems like it is old, installing it would delete some stuff I find unrelated but that is really not old and is needed.

If only I could have the turntable play through the speakers like in WIndows, but through ALSA like when recording, like when I did it in Mint 13 or 15 I forgot, when there was no problem, ALSA sounds better than proprietary windows drivers it’s nuts.

I think until I get my cd or floppy bay with 4-6 additional usb 2.0 ports, the strange sometimes obvious static electricity going on in the back of the desktop would be a removed problem, I didn’t speak much about it, but for some reason I had to buy usb to ps2 adapters for my mouse (and did so at the same time for my keyboard…saves space in the USB dept, in the back there’s 2 3.0 ports and 8 usb 2.0, but for some reason because they had to adapt my newest motherboard to the board, there is some space, like empty space where one could enter a pinky inside the box a little, and well, I had to buy those adapters because, well, yes using usb for keyboard and mouse is stupid (unless you’re a major drawer with massive talent so much that you require the 10% more accuracy a laser mouse will provide you instead of optical), and also because on some ports they would not work, although other devices did, so there’s some strange stuff going on behind there, no ports are broken, but my mouse in particular cannot be in 6 out of 8 of the usb ports.

I’m looking at a topic you have called solved to at least have sound from my turntable (which while a good turntable for ripping and also sounds awesome with headphones on, it doesn’t play very loud at all if you let it use its own speakers, it’s kinda strange how it cannot get really loud by itself. It’s also got a red/white exit to those who want to plug it to their PC this way (and who know how to do that), but when I did it, bass did not come out of my subwoofer, which is kind of the sound system itself, I got a remote that has all the functions it has on the right side, one of the rare subwoofers that can be entirely killed, which is good because I live in a condo, So yeah bass guitar would be heard in the 2 cannons at the top if we are to hear it in a song, but there was no “bass” frequencies at all if I did it this way. I guess it would work great on a regular sound system amp plugged in to it, it doesn’t have the phono thing so I know it’s not top tier, but it’s decent, not a cheap cheap one, paid 320 dollars for it, I knew I would get something like this, with my sennheisers or when it played through ALSA on Linux Mint 13/15, it was great and I also could record!. Right now, i’m facepalming so hard, it’s the Asus card the system doesn’t see in Sound Prefs, but it does in Audacity, qasmixer, alsamixer…but that doesn’t matter, it can’t work at all even if it’s seen, it only is usable as “Headphones” (and no headphones do not work, anyway, they go in the same green exit, my headphones are plugged to my sound system’s right cannon with some green entry there for them.

Anyway, I’ve booted in win7 yesterday, it had been a month or so and of course it started loading infinitely again, C: had to be scandisked, hard, which I managed to get it to do it after messing around in Repair mode. It for some reason when I decided to scandisk with the GUI to use a ntfs partition I have that is still labeled “xp” where my old and loved xp x64 was, I didn’t change the label, it decided it was C: when in Repair mode so it was doing scandisk on that partition…but for some reason, when I noticed that after about 45 mins of scandisk, I pressed reset and went and tried to boot and it finally did and thankfully all it needed was scandisking because of mostly, filenames that cannot exist in Windows…yeah… ::mad::, threw em all in a found.000 folder where I got back the seven inches written as 7" in the filename that all ended up there. Anyway, I managed to record an LP, I only recorded the file since the sound from speakers in Windows is not great with the proprietary Asus driver, I wonder (but now too late I rebooted in Mint 17.3 this morning, couldn’t imagine being in that environment of slowness when I have an octocore 4.2ghz (10% overclocked) AMDFX8350, startup even with minimal things going on then still ttakes forever and well, I don’t have a kickass theme thats perfect for my eyes like what I have here, and it was hard, very hard, to install it for some reason, I could install tons of themes easily, even some came as .debs, but not this. Hence my reticence…that install of Mint 17/.1/.2/.3 is what I always wanted, it’s completely customizable which even if Firefox says is not a word…I mean I don’t even know where I found it, it’s been 2 years and I don’t think one can backup an effing MATE theme.

I’ll boot with a Mint 18.1 3.0 key (just as I get a computer with 3.0 usb ports, 3.1 shows up and my windows drivers program says I need to install 3.1 drivers…no I don’t, something 3.1 won’t work in a 3.0, I’m sure they made it this way so you had to buy a bay, which means I’d need 2 bays!

Okay I’m getting myself angry now, so, yes, there is points in there where one could find something to help me with, but sorry for the slightly long venting.

I’m sure you guys here can decipher everything in there, but I was told to do this command lsmod | grep snd.

Here is what I get, right now I have booted and the system, as least Sound Prefs, sees all sound cards. As for the microphone I had, it was a piece of junk and I tried it on other people’s sound card and it stopped working and it wasn’t a Linux issue, it didn’t work in Windows either. So next time, I will have to get a floppy or optical drive bay for the 6 usb 2.0 ports I have no access to now. Next thing to buy for this desktop, because everything else is taken, except a usb 3.0 port, but I use the 1 out of 2 for my multiple usb 3.0 thumb drives.

lsmod | grep snd 
snd_usb_audio         180224  1 
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_hda_codec_realtek    81920  1 
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     53248  1 
snd_oxygen             24576  4 
snd_oxygen_lib         45056  1 snd_oxygen
snd_mpu401_uart        16384  1 snd_oxygen_lib
snd_hda_intel          36864  7 snd_hda_codec_hdmi
snd_hda_controller     32768  1 snd_hda_intel
snd_hda_codec         143360  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              20480  2 snd_usb_audio,snd_hda_codec
snd_pcm               106496  7 snd_usb_audio,snd_hda_codec_hdmi,snd_oxygen_lib,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq_midi           16384  0 
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  3 snd_usbmidi_lib,snd_mpu401_uart,snd_seq_midi
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  3 snd_pcm,snd_seq
snd                    86016  36 snd_oxygen,snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_oxygen_lib,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_mpu401_uart,snd_seq_device
soundcore              16384  2 snd,snd_hda_codec

This is with all devices seen in Sound Prefs, Alsamixer, Qalsamixer (which I think is just a fancy GUI for Alsa-mixer). Since the fact that recording the record in Windows 7 on Audacity is just the first part, a lot of things have to be done with Audacity according to the guide, which I agree, I didn’t even know my vinyl rips should be at -6db, so the green bars and the recording do not look like a huge green block like if it was the worst Loudness Wars release of all time. If I have to spend a lot of time in Windows ripping and them after that, playing around with the vinyl recording so that it sounds the way it should before I turn those wav files into flac files…I’d rather do all of that in one OS.

Thanks a lot for your attention

So…any ideas? It’s especially annoying that now all of a sudden, at boot, all sound cards are detected, haven’t seen the onboard sound adapter be impossible to use despite being seen by alsamixer, if Sound Prefs doesn’t see it, neither does pavucontrol so I guess it’s a PulseAudio issue, but it’s not, I have Audacious player set to use ALSA (which is a great feature, I don’t know if the people who make Audacity also work on Audacious, names are similar and they are audio programs, but I really like it, but it won’t work if for an unknown reason often in the past, no so anymore, it start getting undetected, which led to the purchase of the one last good regular PCI sound card, there was 2 Asus models, the DG was dirt cheap, 29,95 and a 10 dollar mail rebate and the one I have was close to a hundred dollars, and so far I only heard it while in windows 7, so…not often heh. I’ll get a cheap external usb sound card and see what happens soon and return it saying I’m not satisfied but really it’s for testing purposes…I need to make sense of this, if i was still taking my ADD meds like when in college, Dexedrine, I would be obsessing on resolving the problem, often skipping a night to fix something…it was useful to learn how to Linux very fast though heh.

Google brought this up:

It was a Kernel issue, my 3.19-0.32 kernel was too old despite the Update Manager telling me it was the recommended Kernel. Kernel 4.4.0-59 is doing the job just fine.