No Playback on MacBook (loud click instead)

Thanks again for testing (yes I meant the Audio MIDI Setup utility).

So this isn’t a problem with Audacity making visible settings changes to the audio device, and not a problem when it queries the audio device on launch. It just occurs when you play in Audacity.

I suppose you could rebuild current Audacity with and reverted to isolate if those commits were the cause. Do you build Audacity on Mac ( ) ?


Not yet. It will be first time.

Hmm, probably not :frowning:
I’m stuck at compiling wxWidgets 2.8.12 on OS X 10.9

Are you following Missing features - Audacity Support ?

You do need Xcode 5.0 or greater on Mavericks. I’ll update the Wiki page presently to say that.

As you are building widgets from a script, all the preceding steps on Missing features - Audacity Support must be followed.

If rebuilding with older PortAudio doesn’t work for you I might try to do it, but the Audacity build system has certain quirks at the moment.


I already have cmake (version 2.8.12) and pkg-config (version 0.28). I believe that’s enough.

wxWidgets: I missed that it really needs sdk 10.4u (i.e. Xcode 3.2.6)

Conclusion: No, I didn’t exactly follow that page. Sorry about that.

(EDIT: Updated to make post more clear and correct)

I’ve updated the Wiki page .

The whole process on that page depends on linking Xcode 3.2.6 with later Xcode. This is OK when updating to Mavericks from earlier OS X as I did, because you can install Xcode 3.2.6 on Mountain Lion or earlier.

I really don’t know if you can install 3.2.6 on Mavericks. The only search result I can find is that 3.2.6 installation crashes then the machine won’t reboot properly until you reinstall Mavericks. :imp:

I’ll see if I can find any more out about this.


I’m still trying to find out. Did you make any more progress?

If you reduce or increase Audio to buffer in the Audacity recording preferences, does it make any difference to the click problem?


Sorry, not (yet). I’m on slow way to do through VM with Mountain Lion installed.

Preferences: Recording → Audio to buffer (default value 100ms):
When I change it to >= 300ms then it seems that it works properly*.

When I change it to i.e. 50ms then audio clicks and sound goes very quiet from right speaker only (it doesn’t have to be right speaker, it could be “subwoofer” which outs also on right side. But at this moment audio is quiet and without any bass. Only middle or rather treble).

*) When buffer is at 300ms or more, there becomes another (understandable, but annoying) issue - waveform progress is visibly shifted against hearable audio. I don’t know real usage of Preferences: Recording → Latency correction, but it doesn’t seem it helps in any way and progres is still shifted in unchanged form)

Thanks for letting us know, kmarty.

No, all that Latency correction does is shift a recorded track backwards when recording against playback of other tracks. See Recording Preferences - Audacity Manual .


Oh, ok. That explains everything.

It seems that it works too when Audio to buffer is set to 30ms. For playback (I didn’t tried playback nor recording through USB yet - at this moment all tests are through internal speakers and mic).

When buffer is less than 10ms an audio dropouts appears (which is normal, I think). But it still plays.

These tests are sometimes hard, because when it starts playing then it works until cold reboot. Also when I’m in critical range (somewhere between 50-200ms) then it sometimes works too (like every second cold reboot or so). So when I say it works, it doesn’t have to be necesarily 100%. It means that few (about 5) cold reboots it still works without click issue when buffer is 30ms or >=300ms.

That doesn’t completely surprise me. Someone on Mavericks who was setting Audacity output to Soundflower (for sending to another application) found that the audio had repeated fast clicks unless Audio to buffer was reduced.

Perhaps something changed with audio buffering in Mavericks, but I am OK on Mavericks with the default 100 ms Audacity buffer.


i am watching this with interest as i am experiencing the same problem, i don’t know if this helps or confuses matters but my parallels install does the same thing but i found a way in their forum to fix it doesn’t help for audacity though.

It’s not probably not relevant thanks, unless there is some fix for this in Apple Audio MIDI Setup, which I doubt.

Have you tried all the known solutions? Adjust the buffer in Audacity and in your sound device (if buffer is configurable)? Does the “click-instead-of-playback” stop happening if you play a file twice in QuickTime?


having not being able to use audacity at all yesterday when i start it to try your suggestions today it is working fine but i did use quicktime several times last night which may have helped? if it starts again i’ll give them a go, thx.

I don’t know if you saw it but I posted more detailed suggestions at Can't get any sound, just crackle - #7 by Gale_Andrews in reply to your post there.

The possible Audacity issue on MacBook Pro is that you can launch Audacity without interfering with system sound, but if you play something in Audacity then Audacity playback just clicks. If you then play audio once in QuickTime, it will just click. Play the audio a second time in QuickTime then it will play and so will Audacity.

I don’t know if playing a file in iTunes has the same restorative effect as QuickTime.


Since iTunes uses QuickTime as its underlying player, I suspect that it might


I have this same issue. It is solved bu uninstalling 2.0.4 or 2.0.5 and installing 2.0.3. This issue started since I upgraded the OSX last night. Even when I uninstall the app, I get the click. Something is incompatible with the latest Mac OSX and 2.0.5 (and 2.0.4) but is fine with 2.0.3.

Did you upgrade to 10.9.3?

It’s possible that reinstalling 10.9.3 might have cured it. Installing Mavericks over previous OS X does cause audio issues for some people, not just in Audacity.

Thanks for the comments.


Yes, I accepted the 10.9.3 upgrade that came it early this week from the app store and Audacity didn’t work since that point until I downgraded it to 2.0.3.

All I am saying is - if you had installed 10.9.3 over 10.8 or earlier and have audio issues in other applications than Audacity, installing 10.9.3 again may cure them.

Simply reboot then as soon as you see the grey screen, press COMMAND + R to enter the OS X Recovery Utility then follow the steps.

Doing that probably won’t help the Audacity issue, though one person has said that it did.