No Playback on MacBook (loud click instead)

We have just installed 2.0.5 on an IMac OS 10.8.4. All settings on the computer are at full as is setting in Audacity. Waveforms look perfect, view meter is bouncing but we hear nothing at all - not even static. Any suggestions?

You should make sure Audacity is trying to send sound to your speakers.

Audacity > Preferences > Devices > Playback: [X] Built-In Speakers (select)

Yours may say Built-In Output or something like that. It should be pretty obvious.

I have the same (or similar) issue - when I try to playback, I hear just few miliseconds of sound, then one loud click and then is all silent. Sometimes it clicks immediately.
When I try the same with Audacity 2.0.3 then everything is ok.

After this loud click, it seems that soundcard is stucked, because for playing again I have to try to play i.e. wav file through QuickTime twice (first time it just clicks as well as in Audacity 2.0.4 and 2.0.5, second time start to play).

What are you trying to play - an audio file that you imported into Audacity? If you Generate > Tone, can you hear that when you play it?

What is your playback device in Device Toolbar ? Set it to your speakers or built-in output.

Otherwise, try resetting preferences. I suggest you quit Audacity, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

then open the file “audacity.cfg”. Select all the text in audacity.cfg and delete it.

Then type the following at the top of the file:


Save audacity.cfg. Reboot the Mac and restart Audacity.

If you are trying to play to an external device, try setting that device up in Applications > Utilities > Audio MIDI Setup. Use standard settings - 16-bit, 44100 Hz.


Doesn’t matter, imported audio file or generated tone makes the same result.

No. Actually for a first time a very short tone is heard, but immediately speakers loudly clicks and sound is gone. Next try to play it makes just loud click.

“Built-In Output”

Same result. Loud click followed by silence.

No change.

Audacity should not be changing any settings of the sound device. No-one else is reporting this as far as I know.

If Quick Time can have the same issue, it sounds as if it could be a hardware problem.

Are you saying that 2.0.3 consistently does not do this, but 2.0.4 and 2.0.5 consistently have this problem?

Exactly what version of OS X is it? Exactly what Mac machine is it?

If it’s Mavericks you may need to reinstall it. Mavericks can have quirky behaviour if installed on top of an earlier version of OS X.


QuickTime (or any other sound application, including Audacity 2.0.3) doesn’t have this issue. It doesn’t seem to be HW problem.

Yes, Audacity 2.0.3 works with none of this problem. I use it regulary.

It is MacBookPro5,3
OS X version: 10.9 (installed from zero, it wasn’t “upgrade”).

I had Mountain Lion (OS X 10.8.4 or 10.8.5) when Audacity 2.0.4 was released. And it was first time I got this issues. Since that, I stayed at 2.0.3. So I think it is not Mavericks related issue.

The most detailed description of this issue is showed in this video:
(I don’t know english enough to exactly describe everything with this issue, so video with this issue could be more helpful - please notice the description of that video, the temporary “solution” works just until reboot)


I found this: OS X Maverick Support? - #9 by macbookandrew
and this: OS X Maverick Support? - #13 by Gale_Andrews
Unfortunatelly that is last macbookandrew’s (and your) post I’ve found about that.
(and no, I don’t run it from DMG file)

But you said (and show in your video)

play i.e. wav file through QuickTime twice (first time it just clicks)

Thanks. By the way, you can open QuickTime and use File > New Screen Recording to make a video of the screen (with audio if you have a microphone). See .

It’s interesting that the second QuickTime play fixes Audacity playback while you are logged in. Does Audacity playback still work if you quit and restart it immediately? Also see below about a possible reason for this problem.

OK thanks for pointing that out. I had only seen Lipwak’s response that problems had been fixed. It shows well why it’s always best to start a new topic and not jump on someone else’s. :wink:

I have added a link to this topic in that one.

So we have just two reports now, both on MacBook Pro’s, since 2.0.4 was released in September. It may or may not be related to the update to portaudio r1885 for 2.0.4 release: Google Code Archive - Long-term storage for Google Code Project Hosting. .

We updated PortAudio again for 2.0.5 release.

Might Macbooks turn off the audio subsystem after 20 seconds of inactivity be anything to do with this? That is, for some reason, Audacity 2.0.4 and later cannot restart the audio subsystem once it has stopped? If you play a file in QuickTime twice, then wait a couple of minutes before playing in Audacity, does it still play? Or if you download Antipop linked to in that “makeuseof” article, does it help?


I know that, but I purposely recorded it by external camera (phone) to avoid any distortion of that example.

EDIT: I tested recording using QuickTime player and it happened what I expected - it is unable to record this issue with screen recording (QuickTime “overrides” soundcard and everything looks like no issue exists ever).

Yes, it is still work.

After 10 minutes it still work. Also when I let laptop sleep, when resumed after two hours it still work. After reboot it still work. I have to shutdown and then power on to induce this issue (sorry if I somewhere wrote “reboot” previously, it has to be shutdown, about second wait and then power on).

“antipop” doesn’t help (I made 10 minutes length tone, whole was played without any sound - except first beep and loud click). Nothing happened, although “antipopd” was launched.
When I try manually what “antipop” should do (i.e run “say” command with space every ten seconds), then after fifth say " " tone began audible (btw. it means that it would take about 50 seconds until Audacity start playing when “antipop” do what should do).

EDIT: I’m trying to find what was wrong, because “antipopd” is just a shell script with endless loop with say " "
EDIT2: Ah, AntiPop installer firstly starts “antipopd” as root. And launchctl wasn’t quite successful when it should start under logged in user.

OK thanks for testing.

Can you confirm if you shut down the Mac, open Audio MIDI Setup, look at the output settings for built-in audio then start Audacity, do settings change in Audio MIDI Setup? If you generate a tone in Audacity and try to play it, do settings change then?

Can you confirm if you shut down the Mac, leave Audacity alone then play a file in Quick Time, does it click the first time you play it, and then play OK second time?


Are we talking about this?:
Snímek obrazovky 2013-12-04 v 10.08.41.png
(Vestavěný mikrofon = Internal mic, Vestavěný vstup = Internal input, Vestavěný výstup = Internal output)

After fresh power on:
int. mic: 44.1kHz, 2ch/16b int, M = 0.083 (-10dB)
int. input: 44.1kHz, 2ch/16b int, HW freq converter disabled, 1: 0.5 (0dB), 2: 0.5 (0dB)
int. output: 44.1kHz, 2ch/16b int, 1: 0.254 (-28.5dB), 2: 0.254 (-28.5dB)

After Audacity is launched (but nothing else):
int. mic: 44.1kHz, 2ch/16b int, M = 0.083 (-10dB)
int. input: 44.1kHz, 2ch/16b int, HW freq converter disabled, 1: 0.5 (0dB), 2: 0.5 (0dB)
int. output: 44.1kHz, 2ch/16b int, 1: 0.254 (-28.5dB), 2: 0.254 (-28.5dB)

After tone generated and (unsuccessfuly) played in Audacity:
int. mic: 44.1kHz, 2ch/16b int, M = 0.083 (-10dB)
int. input: 44.1kHz, 2ch/16b int, HW freq converter disabled, 1: 0.5 (0dB), 2: 0.5 (0dB)
int. output: 44.1kHz, 2ch/16b int, 1: 0.254 (-28.5dB), 2: 0.254 (-28.5dB)

I.e. no change.

When I power on Mac, didn’t touch anything except I play audio (through Quicklook in Finder), it plays immediately without any issues. First time, second time, doesn’t matter.

When I power on Mac, launch Audacity (just launch, nothing else), try to play audio through Quicklook in Finder, it also plays without any issues. But when I try to play audio in Audacity (for example generated tone) an issue appears.

Thanks again for testing (yes I meant the Audio MIDI Setup utility).

So this isn’t a problem with Audacity making visible settings changes to the audio device, and not a problem when it queries the audio device on launch. It just occurs when you play in Audacity.

I suppose you could rebuild current Audacity with and reverted to isolate if those commits were the cause. Do you build Audacity on Mac ( ) ?


Not yet. It will be first time.

Hmm, probably not :frowning:
I’m stuck at compiling wxWidgets 2.8.12 on OS X 10.9

Are you following Missing features - Audacity Support ?

You do need Xcode 5.0 or greater on Mavericks. I’ll update the Wiki page presently to say that.

As you are building widgets from a script, all the preceding steps on Missing features - Audacity Support must be followed.

If rebuilding with older PortAudio doesn’t work for you I might try to do it, but the Audacity build system has certain quirks at the moment.


I already have cmake (version 2.8.12) and pkg-config (version 0.28). I believe that’s enough.

wxWidgets: I missed that it really needs sdk 10.4u (i.e. Xcode 3.2.6)

Conclusion: No, I didn’t exactly follow that page. Sorry about that.

(EDIT: Updated to make post more clear and correct)

I’ve updated the Wiki page .

The whole process on that page depends on linking Xcode 3.2.6 with later Xcode. This is OK when updating to Mavericks from earlier OS X as I did, because you can install Xcode 3.2.6 on Mountain Lion or earlier.

I really don’t know if you can install 3.2.6 on Mavericks. The only search result I can find is that 3.2.6 installation crashes then the machine won’t reboot properly until you reinstall Mavericks. :imp:

I’ll see if I can find any more out about this.


I’m still trying to find out. Did you make any more progress?

If you reduce or increase Audio to buffer in the Audacity recording preferences, does it make any difference to the click problem?