No play through from USB turntable to ext. speakers

Using 10.6.8 Mac OS, Audacity 2.x from dmg. Using external computer speakers linked via the headset plug in back of computer. Ext. speakers work fine for iTunes. Am using a USB Turntable. Audacity preferences - “Divices” - Host: Core Audio, Playback Device - Built-in Output, Recording - Built-in Input, Channels 2 (Stereo), Mac preferences - Sound - Output - USB Audio CODEC (tried Headphones too), Input - USB Audio CODEC… USB.
When I put a LP on I can get no sound through the external speakers even though I click on the Input Level Mic symbol (“click to monitor”). In the cells to the right of Core Audio (top right of Audacity screen) I have “Built-in Output”/Built-in Input". I tired putting USB Audio CODEC in both as well. I also tried putting my connecting wire from speaker system in the speaker symbol plug behind the computer, instead of the headset plug, just as an experiment, though iTunes only plays through these speakers with that wire plugged into headset plug (as described above). I have gone through the tutorials now over and over. In Audacity preferences - Divices - I am not give a drop down choice of headset/ext. speaker for output, fyi.
I’ve also tried putting the session into the record mode to see if at least I’d get sound coming through actually trying to record something, but I still have no sound. I’m stumped at this point. I used an older version of Audacity last winter without this problem, interestingly. Thank you.

Clicking to monitor only gives you visual monitoring unless you also click to turn on Transport > Software Playthrough.

If Software Playthrough does not work (when you have the Built-in Output selected as playback device), use LineIn from .

The USB turntable (USB Audio CODEC) isn’t a playback device for the computer. So both Audacity and Mac Sound Preferences should use Built-in Output for playback.

I think only Windows laptops and netbooks usually offer separate playback devices - the Audacity Manual largely assumes Windows where images are concerned.


Gale, Thank you for your quick response. I have all my settings as you suggest and still no sound. I just downloaded “Line-In” and thank you for that suggestion. Once my downloads manager finished scrolling to indicate it was downloading, and finished, I did not see any folder or icon on my desktop and did not see Line-In in my applications (hard drive), where I might find an icon to double click to finish install. Did it automatically install do you think. Strange that I can’t locate it now.
Also, does LineIn opperate in the background for Audacity, once I open Audacity, or do I have to activate LineIn ahead of activating Audacity (once I locate LineIn, that is). Sorry for all the questions, my tech. skills are on the 101 level LOL.
I really appreciate your time and in-put here. Have a great day.

LineIn is a zip file if you downloaded it from the link I gave. So find where your downloads are saved, then double-click the zip and the contents should be extracted to the current folder you are in.

Then I would suggest moving the extracted LineIn app (not the zip) to your Applications folder and launching it from there. In LineIn, you have to press the PassThru button, I believe (as well as choosing the USB Audio CODEC as the input and the Built-in Output as the Output).

If you just unplug the turntable from the computer then do Generate > Tone in Audacity, turn the output slider up:

then press Play, can you hear audio now?


Dear Gale, Thanks once again for weigning in on this, and for your most expert advice. This morning after I downloaded a song file, while in the download manager I could see the zip file (completed) there as to Line-In. I double clicked it to see if that would open the zip, since I could find no trace of it in the applications or desktop. That brought up a window showing me where the mysterious zip was. Incredibly it had nested in the trash folder! Beats me! No wonder I couldn’t find it.
This might be a glitch in Line-In that those good people might want to know about LOL. At any rate I moved it out and slid it into the applications folder, then proceeded to open it.
I then opened Audacity and put an LP on and got sound - lo and behold, but… there was no activity in the meter bars to indicate a recording taking place - and sure enough when I started a session, the lines were all flat. But, thanks to your newest update to this thread, I realized that my “In-Put” was not set to USB Audio DODEC. GOOD JOB! Once properly set there I was ready to rock and roll… all systems go. Can’t thank you enough Gale.
One final note, not that it is necessary (apparently) to “just unplug the turntable from the computer…”, I’m curious (and confused). If I were to unplug the turntable from the computer and continue with your “do Generate > Tone in Audacity, turn the output slider up, then press play”, how would the turntable/LP even communicate (“talk”) to my computer? Am I missing something? (probably). Like I said, obviously a non-issue anyway, but that’s just a curiosity thing.
Have a great weekend ahead and thanks once agian for all of your time and help with this matter. I hope this if found useful to other users, which I’m sure it will be!

Gale, I forgot one last bit of information. With the “In-Put” set to USB Audio CODEC, I have lost control of my recording volume, so the bars are pushing or exceeding -6 on both channels, and may be in danger of “clipping”. Any work-around to regain control of that function? Not sure I’m electronically capable as to messing with turntable if that’s even an option? Thoughts?

Yes if you unplugged the turntable from the computer, you cannot record from it. The idea was just to make sure the presence of the turntable was not somehow preventing Audacity playing audio to the built-in output (which should not happen).

Macs don’t usually let you change the input volume of USB audio devices, so Audacity cannot do so either. Your only choice is to see if the turntable has a knob to adjust the output volume (look at its Manual or look underneath the turntable); or if the turntable has red and white cables for audio speakers, connect those cables to the Mac using a special adaptor.

-6 dB is a good level to record at if it’s only getting as high as that in the loud parts.


There is no output vol. control anywhere on record player. My record player DOES have stereo cables (red and white). The adaptor I would use, would it allow those two plugs to plug into a USB cable (USB for back of our desktop Mac)? Or some other configuration? I am pushing close to 0db on records.
I think this will be the last hurdle, if you don’t mind a last support post here. You’ve been most gracious with your time and it’s greatly appreciated. I doubt I’m the only one with such concerns. Thanks for all once again.

You want to buy a stereo RCA to stereo 1/8 inch adaptor like this: .

This assumes your Mac has an audio input (USB input is no use for this solution).

The turntable should have a phono / line switch. Set it to line if you connect the RCA cables to the computer this way.


Thanks again Gale. I have no phono/line switch on record player, so I’m going to assume that it defaults to whichever plug configuration is used. I will get the adaptor and give it a spin, and report back here what the end result is for anyone who might be following this thread, or finds it useful in the future. Would love to gain control of recording db’s.
Your help and in-put here has been invaluable and I thank you once again for your valuable time and most useful guidance.