no longer can import audio file

For months, I have been able to very easily import audio files from iTunes into Audacity for editing purposes with 1 or 2 clicks at the most. Since I updated to new 2.1.2, when I go to File/Import/Audio, my file choice shows document files instead of music files. I change the folder to Music and get the icon for the song, but when I click to choose for importing, I get the message that the file cannot be played in Audacity but that I should go to iTunes to play back. Then I click ok and Audacity looks like song is being loaded, but there is no audio actually there. No playable or editable data.
Operating system is El Capitan.
Tommy Ray

I do this in two steps. I drag the iTunes file out of iTunes and onto the desktop. Then I right-click or control-click the file > Open With: Audacity.

If you can’t do the first step, then it’s possible you have one of the $0.99 FairPlay Copy Protected sound files. Then, the only way out is to play it in iTunes and record it with “what’s playing on the computer.”


Is the exact message “Open iTunes to populate this list”? If so this is already listed in the 2.1.2 Release Notes.

As stated there, one workaround is to drag your iTunes “Music” folder to the Finder sidebar which then gives you quicker (working) access in Audacity.


(OS X 10.10) iTunes files cannot be opened from Media > Music in Audacity’s file open dialogs. You could drag your iTunes “Music” folder to the Finder sidebar to give quicker access in Audacity open dialogs.

I see the same behaviour in Mavericks, with the latest iTunes installed.

Opening iTunes doesn’t seem to populate the list.

I’m guessing this has to do with the latest iTunes version and/or the latest security update (2016-001) for OSX Mavericks, as I didn’t notice it before.

Last time I tried it with 2.1.1 it was not a problem on Mavericks, but that was a while ago.

Also last time I tried I tried it on El Capitan (recently), 2.1.0 did not have this problem.


iTunes here. I guess you still have a previous release?

On El Capitan I have the current iTunes In Audacity 2.1.0 on El Capitan I can still import files from Media > Music, but not in later versions.


OK, so it’s not iTunes, but Audacity’s error. Thx.