No longer able to record in stereo using Logitech headset

  • Ubuntu 18.04
  • Audacity 2.2.1
  • Distro release

I have a problem I just can’t figure out.

I use a Logitech H390 USB headset. When I used this on Windows 7 with Audacity, I had no problem recording in stereo.

On Ubuntu 18.04, I could record in stereo, because I always attached the headset before opening Audacity. I made the mistake once of attaching the headset after I opened Audacity, and now I’m no longer able to record in stereo. The option to select stereo no longer appears in the Device Toolbar or in Preferences » Devices.

I have tried the following:

  1. Restarting Audacity with the headset attached.
  2. Restarting the computer with the headset attached.
  3. Deleting audacity.cfg
  4. Reinstalling Audacity
  5. Deleting .audacity-data
  6. Three days of googling, with no results.

Does anyone have insight into this? I know that it is not a device problem, because I installed the Sound Recorder app, did some recordings there, imported them into Audacity, and they were stereo.

I have no idea what it is about this headset that Audacity will no longer let it record in stereo. I really have no idea what to do short of buying a new headset or reinstalling Ubuntu 18.04.

FWIW, I’ve posted the contents of audacity.cfg in my PrivateBin here:

Thanks for taking a look at this.


You got fuzzy there. Having the headset appear at all is different from recording in Stereo.

Troubleshooting tip. The USB device name doesn’t have to have any relationship to the maker of the hardware. If you can’t tell which device is the critical one, Unplug the headset and look at the Audacity recording device pull-down. Note the devices.
Screen Shot 2018-07-01 at 16.12.35.png
Close Audacity, plug in the headset, let it settle and then start Audacity. See which device got added.

In that same toolbar is a Stereo/Mono setting.


Thanks for the quick response, Koz.

Close Audacity, plug in the headset, let it settle and then start Audacity. See which device got added.

Yep, I’ve tried that. It gets added as a “Logitech USB Headset”.
The problem is that the stereo/mono setting has gone from offering me stereo and mono options to just offering me the option of mono. This occurs in both the Device Toolbar and Preferences » Devices. The only option in the pop-up is mono/1 channel.

I believe this is an Audacity issue, because I am able to record in stereo using other apps. (I could be wrong of course, but I’m not sure how to further test my hypothesis.)


If you were in Windows, we’d be sending you to the Windows Sound Control panels where you have the option (I believe) of forcing mono/stereo. This is where we wait for a Linux elf. I’m out of my world.

Just a note: Unless you have a complete celebrity/unicorn headset, the microphone is one channel mono. Somewhere there was a system change that forced it to record stereo. So in my opinion, your whole system is acting normally and you want a special case.

Is there a reason you want left and right sound channels from your mono microphone? A “real” mono sound track (one blue wave) will play to both left and right speakers in a sound system. It has to say mono in that info panel on the left.


After connecting the headset, ensure that you Quit all Audacity sessions and restart Audacity, then “Help menu > Diagnostics > Audio Device Info”. Wait for the info to appear, and click the “Save” button. Save the info somewhere convenient, then attach the saved file to your reply. See here for how to attach a file to a forum post:

As a matter of interest, why do you want to record a mono microphone as a stereo track?

As a matter of interest, why do you want to record a mono microphone as a stereo track?

Better sound quality, I believe. Important, as most people will be hearing this with earbuds or headphones.

Ubuntu 18.04 just pushed an update through, and my headset won’t even show up as a recording device—only a listening device. Oddly, if I select “pulse” as the recording device, I can record in stereo through my headset. See this screencap:
I could live with that in I knew it wouldn’t go wonky in future.

then “Help menu > Diagnostics > Audio Device Info”

I did not even realize that feature existed. I’ve attached the requested file. It was an enlightening read through. (I really need to gain a better understanding of how audio on Ubuntu works. I’ll be researching this.)

Thanks again for all your help.
deviceinfo.txt (4.72 KB)

That’s quite a common misconception (it’s not true).

When recording a mono source (such as a microphone) as a mono track, the sound is written to disk once and creates a mono track.
When playing a mono track through stereo headphones or speakers, the audio is sent to both left and right speakers / ears.

When recording a mono source as a stereo track, the signal is duplicated and written to disk twice to create a 2 channel track. The two channels are identical, and it is still a “mono” recording (sometimes referred to as “dual mono”).
When playing a 2 channel mono recording (dual mono), one track channel is sent to one ear / speaker, and the other track channel is sent to the other. Thus the sound is identical to playing a single channel mono track, except that the file size is bigger and the computer has to work a little harder because there is twice as much data.

When saving audio in a compressed format (such as MP3 or OGG), the data compression reduces the file size at the expense of sound quality. Higher compression settings produce smaller files at the expense of lower sound quality, thus there is a trade off between file size and sound quality. When saving a “dual mono” recording in a compressed format, there is more data to be saved, so either the file size will be bigger for the same sound quality, or the sound quality will be worse for the same file size, compared to a normal (single channel) mono recording. Thus, when saving a mono recording in a compressed format, it is significantly better to use single track mono.

The only benefit to recording a mono source as a 2 channel (stereo) track is if you intend to apply a stereo effect (such as “ping-pong echo”). In all other cases it is better to record a mono source as a single channel mono track.

This file shows which devices Audacity can “see”. Your headset is only listed as a playback device (the headphones) and not as a recording device (the microphone).
One common reason for a headset mic to not show up, is if it is being used by another application (“exclusive access”).
Ensure that there are no audio applications enabled for start-up on log-in (for example, Skype will start automatically by default), reboot your computer, start Audacity (before any other program), and get the “Audio Device Info” again. We’re looking for “Logitech USB” to be listed as a recording device.