"No Devices found" under Edit - Preference - Recording

I’ve got a Super USB cassette capture bought a few months back, and had used it once. However, recently I have downloaded the latest Audacity 2.3.0 and installed the program. One of the first things it says when i open the audacity is to set Preferences and select the Device. That field under Recording indicates “No Devices Found”. I have the super USB cassette capture player connected with the cable provided, i can see “USB PnP Audio Device” under Control Panel - Devices & Printers and also under Device Manager - Sound, video & controller. But under Mixer - Sound - Recording, the “USB PnP Audio Device” does not appear in both the enable / disable device. What do I do to rectify? Can anyone advise please. (It work before few months back when i first bought the player). Thank you very much.

That shows that the device drivers are present.

That shows that Windows cannot currently see the audio device.


  1. Shut down the computer completely.
  2. Disconnect the device
  3. Reboot the computer
  4. Reconnect the USB device

Windows should notify you if / when it recognises the device.
When Windows has recognised and installed the device:

  1. Open the Windows Sound Control Panel and see if the device is listed as a recording device.

If it is listed:

  1. Start playing a tape, and you should see a green meter next to the device in the Control Panel that jumps up and down in time with the music.

Tell us what happens.

Thanks, I’ve tried shutting down computer, disconnect device, reboot & reconnect USB device etc which you had mentioned but still can’t see the device in my sound control panel. I’m using window 7.

Are you able to test the device on another computer?
Windows should alert you a few moments after connecting a USB device to say that a device has been connected - if that doesn’t happen, then either the device, the lead or the USB socket are probably broken.

Audacity gets it’s sound from Windows, not the device. If Windows can’t find it, that’s the end.

Also note, Audacity checks for devices when it starts. So leave Audacity off until you resolve Windows.


Hi, thanks for all the valuable advise & solution. I tried on my laptop & the USB device can be seen in Audacity. But still in my pc indicate no devices found. However I’d resolve it by going to Device Manager - Sound & click uninstall the PnP Audio device. Thereafter I unplug & plug back the USB connection to cassette player & finally can see the audio device in Audacity in my pc. Thank you. :blush: