No audio in spite of source being selected

I use Audacity all the time. I just recorded a podcast interview, which I’ve done 10,000 times before, which I then edit in Audacity. Only today, when I opened the audio file, there is no sound in my headphones.
Yes, the headphones are visible as an input and recording source, and selected. Normally, I plug the headphones in before opening Audacity, so that they are visible as the audio playback device.
Yes, the headphones are functioning. If I switch to YouTube, or a radio station, all loud and clear.
Yes, the audio registers in the playback meter when being played.
The audio is set to 100% on the computer, and the headphones.
When there’s an error, for example if you try to do something not allowed while playing back audio, you hear the error sound over the headphones.
If I unplug the headphones, and reopen Audacity, and change the output to the computer speakers, it plays and is audible. Close Audacity, plug headphones in, reopen Audacity, reset playback to the USB headphones, no audio in the headphones.
This only just happened today, as yesterday I was editing audio using my headphones as I’ve done for the past 10 years with Audacity. I’ve restarted the computer, tried both USB inputs (Windows 11, by the way) - and the headphones work with every other application in both USB slots.
I cannot figure why I’m getting no audio in my selected output source. I could understand if the audio output source was greyed out, but it’s not, it’s the correct source, and the headphones are selected. I’ve tried opening/playing a dozen different files. It’s the same result - audio from the computer, but not the headphones. And the headphones work with Teams, YouTube, Spotify, you name it, there’s audio coming through loud and clear.
Just as an experiment, I opened a file, and cranked the effects gain up to +36dB. You can very, very faintly hear garbled audio over the headphones.
It will also not record from the headset, but will record from the computer’s built-in speakers. But the headset mic works, if you test it in settings, and when I make calls with it, it’s also working fine.
Anyone have any suggestions?
Thanks in advance.