No Audio heard during recording [SOLVED]

I am trying to get my Audio-Technica (connected via USB) turntable configured with Audacity.

The computer system is running PCLinuxOS KDE 64 bit and the Audacity software is 2.1.1 (installed from the PCLinuxOS repositories).

My objective is to transfer my vinyl to .mp3’s. I am at the point that I can capture the audio but there is no sound while the LP is being captured.

The default sound is Pulse - however since the manual for the turntable refers to the use of the USB Audio Codec, I have the Audio Host set to ALSA and the Recording Device set to USB Audio Codec:Audio (hw:2,0):Line:1. I did try Pulse and default as options for the Recording Device but there was nothing being captured from the turnable with those options. I have tried a couple of options in the PulseAudio Volume Control (Build In Audio Analog Stereo and PCM2900C Audio Codec Analog Stereo) but neither seem to have any effect (other than I get an input device error if I leave the PulseAudio Volume Control open when I try to capture the audio in Audacity).

Not sure what else I should be looking at so would appreciate any suggestions.

Just to be clear, there are two levels of this: Audacity is recording if the sound meters are jumping and you get blue waves. That’s very different from you being able to hear it. Many people confuse those two.

Koz

Yes - I am aware of that being the case. Otherwise I wouldn’t be able to play it back. From the info on the Audacity wiki, it would seem that the problem lies with the interface between Audacity and Pulse with not being able to hear audio while capturing.

The USB Audio CODEC (hw) is likely to be the best choice for Recording Device in Audacity’s Device Toolbar.

Nowhere have you said what Audacity’s Playback Device is set to. Try setting it to pulse, with the pulse playback device set in pavucontrol to whatever audio output your speakers or headphones are connected to.

Assuming you can then hear what you have already recorded when you press Play in Audacity, enable Transport > Software Playthrough to listen while you are recording.


Gale

Nowhere have you said what Audacity’s Playback Device is set to. Try setting it to pulse, with the pulse playback device set in pavucontrol to whatever audio output your speakers or headphones are connected to.

Assuming you can then hear what you have already recorded when you press Play in Audacity, enable Transport > Software Playthrough to listen while you are recording.

I have tried both default and pulse for the playback device. (in my case default = pulse and both have the same result) I had turned the Transport > Software Playthrough to off as that is what was suggested on the wiki. Once I did that, I was able to record (but not hear) what was being captured. After stopping the recording and pressing Play I can hear what was captured. However, when I enable the Transport > Software Playthrough - it will no longer capture the audio from the turntable - its a flat line in the monitoring window.

If you want to hear while recording you have to enable Software Playthrough or use some alternative method to route the input to the output. It is as simple as that. :wink: This would typically work on Windows but if you have a USB device never intended for Linux then it is more common that it might not record when software playthrough is enabled. The main problem though is using software playthrough when recording using pulse. So have you set the recording device to the (hw) device for the turntable? This might ease the load on pulse.

If that does not help then a simple method to route input to output is to install PulseAudio volume control (pavucontrol) then enter:

pactl load-module module-loopback

at the command-line with the USB turntable set as the pulse input. See https://forum.audacityteam.org/t/turn-off-pulseaudio-and-use-only-alsa-in-ubuntu-11-04/22037/9

I would suggest

pactl load-module module-loopback latency_msec=1

or some other lowish msec number, but you can experiment.


Gale

Thank you Gale - the routing of the input to output has solved the problem!!